Intermittent LeakSanitizer | leak at createTable, mozilla::detail::HashTable, reserve, reserve and many more in mochitest-browser-chrome

RESOLVED DUPLICATE of bug 1546945

Status

defect
P5
normal
RESOLVED DUPLICATE of bug 1546945
3 months ago
3 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

(Regression, {intermittent-failure, regression})

Details

This large leak started happening very frequently in the remote/test/browser/ directory on 4/24. See bug 1540949. Looking over the test files in that directory, bug 1546385 changed one of those files on that same day, so it is likely related. ato, can you take a look? Thanks. There's presumably a similar leakcheck intermittent leak out there somewhere, too.

Component: Agent → Target
Flags: needinfo?(ato)
Regressed by: 1546385
See Also: → 1540949

We disabled remote/test/browser/browser_cdp.js because it perma-failed
the leakcheck in bug 1546945 and we thought it was limited to that
test specifically. According to this and bug 1546850, it appears
to happen also for the other tests in the same directory, though
less frequently.

We should disable all the browser-chrome tests under remote/test/browser/
until we’ve had time to plug the leak.

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(ato)
Resolution: --- → DUPLICATE
Duplicate of bug: 1546945
You need to log in before you can comment on or make changes to this bug.