Mozilla can't animate this broken image

RESOLVED FIXED

Status

()

--
minor
RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: aha, Assigned: pavlov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Mozilla can't animate broken image, but other browsers (MSIE5.0, Opera 6.x,
NN4.79) are able to do it. Mozilla IMHO should also support this sometime in far
future. =)

2002062308/trunk/W2k
(Reporter)

Updated

17 years ago
Keywords: 4xp
paper, this seems like your thing... ;)
Confirming under Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a+)
Gecko/20020619, but why should Mozilla be able to display broken images? If it's
broken, fix it.

Comment 3

16 years ago
confirming with 1.1beta on win2k.

IE also animates the broken gif (with some corruption on one of the frames).

this could be a wontfix, but that's not my call...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Blocks: 119597

Comment 4

16 years ago
*** Bug 195523 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
Created attachment 116214 [details] [diff] [review]
Finish up Decoding

Never saw this bug before until today.. bugmail must have slipped under my
nose.  Sorry.

Here's a patch.  Upon recieving a Close notification from the stream, this
patch closes off a GIF frame if one is still open, and then it closes off the
GIF if the GIF is still open.

Updated

16 years ago
Attachment #116214 - Flags: review?(cbiesinger)

Updated

16 years ago
Attachment #116214 - Flags: review?(cbiesinger)

Comment 7

16 years ago
Created attachment 116285 [details] [diff] [review]
Finish Up Decoding

Now less fuzzy
Attachment #116214 - Attachment is obsolete: true

Updated

16 years ago
Attachment #116285 - Flags: review?(cbiesinger)
Comment on attachment 116285 [details] [diff] [review]
Finish Up Decoding

+  : mImageContainer(nsnull)
+  , mImageFrame(nsnull)
+  , mObserver(nsnull)

No need to explicitly initialize these to nsnull (it's a nsCOMPtr, which are
nsnull by default). Remove this initialization, and r=biesi.
Attachment #116285 - Flags: review?(cbiesinger) → review+

Updated

16 years ago
Attachment #116285 - Flags: superreview?(tor)

Comment 9

16 years ago
Comment on attachment 116285 [details] [diff] [review]
Finish Up Decoding

Make mGIFOpen a PRPackedBool, do biesi's tidying, and sr=tor.
Attachment #116285 - Flags: superreview?(tor) → superreview+

Comment 10

16 years ago
Created attachment 116353 [details] [diff] [review]
Checked-In Patch

This is the patch I'll check in.

Don't worry about r+/sr+

Comment 11

16 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.