Closed Bug 1547961 Opened 2 years ago Closed 2 years ago

Intermittent remote/test/browser/browser_runtime_executionContext.js | Test timed out -

Categories

(Remote Protocol :: Agent, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

(Regressed 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell unknown])

Attachments

(1 file)

Filed by: rgurzau [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=243601513&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/ES4Ma6OvTj-y9mRSo6Vtgg/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/ES4Ma6OvTj-y9mRSo6Vtgg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


12:25:34 INFO - TEST-START | remote/test/browser/browser_runtime_executionContext.js
12:25:35 INFO - GECKO(823) | 1556627135707 RemoteAgent INFO Remote debugging agent listening on ws://localhost:9222/devtools/browser/dcebb924-f922-af49-b959-d305c1deab66
12:25:48 INFO - GECKO(823) | 2019-04-30 12:25:48.040 firefox[823:6126] Persistent UI failed to open file file:///Users/cltbld/Library/Saved%20Application%20State/org.mozilla.nightly.savedState/window_1.data: No such file or directory (2)
12:26:20 INFO - TEST-INFO | started process screencapture
12:26:20 INFO - TEST-INFO | screencapture: exit 0
12:26:20 INFO - Buffered messages logged at 12:25:34
12:26:20 INFO - Entering test bound
12:26:20 INFO - Buffered messages logged at 12:25:36
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | CDP client has been instantiated -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | Runtime domain has been enabled -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context has an id -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context is the default one -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context has a frame id set -
12:26:20 INFO - Navigate to a new URL
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | A new page has been loaded -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | Page.navigate returns the same frameId than executionContextCreated -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The destroyed event reports the previous context id -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context has an id -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The new execution context has a different id -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context is the default one -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context frame id is the same than the one returned by Page.navigate -
12:26:20 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The destroyed id is different from the created one -
12:26:20 INFO - Navigate back to the previous document
12:26:20 INFO - Buffered messages finished
12:26:20 INFO - TEST-UNEXPECTED-FAIL | remote/test/browser/browser_runtime_executionContext.js | Test timed out -
12:26:20 INFO - GECKO(823) | MEMORY STAT | vsize 5441MB | residentFast 310MB | heapAllocated 89MB
12:26:20 INFO - TEST-OK | remote/test/browser/browser_runtime_executionContext.js | took 45065ms
12:26:20 INFO - Not taking screenshot here: see the one that was previously logged
12:26:20 INFO - TEST-UNEXPECTED-FAIL | remote/test/browser/browser_runtime_executionContext.js | Found a tab after previous test timed out: data:text/html;charset=utf-8,test-page -
12:26:20 INFO - checking window state
12:26:21 INFO - GECKO(823) | Completed ShutdownLeaks collections in process 831
12:26:21 INFO - GECKO(823) | Completed ShutdownLeaks collections in process 829
12:26:21 INFO - GECKO(823) | Completed ShutdownLeaks collections in process 832
12:26:21 INFO - GECKO(823) | Completed ShutdownLeaks collections in process 833

Summary: Intermittent TV remote/test/browser/browser_runtime_executionContext.js | Test timed out - → Intermittent remote/test/browser/browser_runtime_executionContext.js | Test timed out -

Alexandre please take a look at this.

There are 53 total failures since April 29th on osx-10-10-shippable opt.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=243887707&repo=autoland&lineNumber=4693

10:53:10 INFO - TEST-START | remote/test/browser/browser_runtime_executionContext.js
10:53:11 INFO - GECKO(1326) | 1556707991063 RemoteAgent INFO Remote debugging agent listening on ws://localhost:9222/devtools/browser/66dc03c3-a4b0-0c41-8669-1f999648d82f
10:53:21 INFO - GECKO(1326) | 2019-05-01 10:53:21.409 firefox[1326:18621] Persistent UI failed to open file file:///Users/cltbld/Library/Saved%20Application%20State/org.mozilla.nightly.savedState/window_1.data: No such file or directory (2)
10:53:55 INFO - TEST-INFO | started process screencapture
10:53:55 INFO - TEST-INFO | screencapture: exit 0
10:53:55 INFO - Buffered messages logged at 10:53:10
10:53:55 INFO - Entering test bound
10:53:55 INFO - Buffered messages logged at 10:53:11
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | CDP client has been instantiated -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | Runtime domain has been enabled -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context has an id -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context is the default one -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context has a frame id set -
10:53:55 INFO - Navigate to a new URL
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | A new page has been loaded -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | Page.navigate returns the same frameId than executionContextCreated -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The destroyed event reports the previous context id -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context has an id -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The new execution context has a different id -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context is the default one -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The execution context frame id is the same than the one returned by Page.navigate -
10:53:55 INFO - TEST-PASS | remote/test/browser/browser_runtime_executionContext.js | The destroyed id is different from the created one -
10:53:55 INFO - Navigate back to the previous document
10:53:55 INFO - Buffered messages finished
10:53:55 INFO - TEST-UNEXPECTED-FAIL | remote/test/browser/browser_runtime_executionContext.js | Test timed out -
10:53:55 INFO - GECKO(1326) | MEMORY STAT | vsize 5438MB | residentFast 317MB | heapAllocated 95MB
10:53:55 INFO - TEST-OK | remote/test/browser/browser_runtime_executionContext.js | took 45068ms
10:53:55 INFO - Not taking screenshot here: see the one that was previously logged
10:53:55 INFO - TEST-UNEXPECTED-FAIL | remote/test/browser/browser_runtime_executionContext.js | Found a tab after previous test timed out: data:text/html;charset=utf-8,test-page -
10:53:55 INFO - checking window state
10:53:55 INFO - TEST-START | remote/test/browser/browser_tabs.js
10:53:55 INFO - GECKO(1326) | !!! could not start server on port 9222: [Exception... "Component returned failure code: 0x804b0036 (NS_ERROR_SOCKET_ADDRESS_IN_USE) [nsIServerSocket.init]" nsresult: "0x804b0036 (NS_ERROR_SOCKET_ADDRESS_IN_USE)" location: "JS frame :: chrome://remote/content/server/HTTPD.jsm :: _start :: line 509" data: no]
10:53:55 INFO - Not taking screenshot here: see the one that was previously logged
10:53:55 INFO - Buffered messages logged at 10:53:55
10:53:55 INFO - Entering test bound
10:53:55 INFO - Buffered messages finished
10:53:55 INFO - TEST-UNEXPECTED-FAIL | remote/test/browser/browser_tabs.js | Uncaught exception - at [Exception... "Component is not available" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: chrome://remote/content/server/HTTPD.jsm :: _start :: line 542" data: no]:97 - Error: Unable to start remote agent:
10:53:55 INFO - Stack trace:
10:53:55 INFO - listen@chrome://remote/content/RemoteAgent.jsm:97:13
10:53:55 INFO - @chrome://mochitests/content/browser/remote/test/browser/browser_tabs.js:16:15
10:53:55 INFO - Tester_execTest/<@chrome://mochikit/content/browser-test.js:1116:34
10:53:55 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:1144:12
10:53:55 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:1005:14
10:53:55 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
10:53:55 INFO - Leaving test bound
10:53:55 INFO - GECKO(1326) | MEMORY STAT | vsize 5443MB | residentFast 317MB | heapAllocated 96MB
10:53:55 INFO - TEST-OK | remote/test/browser/browser_tabs.js | took 22ms

Flags: needinfo?(apoirot)
Regressed by: 1543098
Whiteboard: [stockwell needswork:owner]
Priority: P5 → P3

Possibly relevant comment by jdescottes in https://phabricator.services.mozilla.com/D32538?id=109620#inline-193145:

My second test testBringToFrontUpdatesFocusedWindow keeps leaking
on debug. It seems that the leak is linked to the entry that
httpd.js creates in its _handler._overridePaths for the tab of the
otherWindow. This map is never cleared, but for some reason this
only creates an issue when registering the path for otherWindow.

Adding a disconnect handler in RemoteAgent.jsm seems to fix the
issue, but again I don't understand why the problem is only
triggered when I have an additional window.

Depends on: 1585464

The test works just fine for me on Mac, so I triggered a try build to check if we might get rid of the skip on Mac and for verify jobs on Windows.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=66d438b46dd8dbf2d3cbe725cd006d467b9c0814

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d8211c6625d6
[remote] Unskip browser_runtime_executionContext.js on Mac and Windows. r=remote-protocol-reviewers,ato
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Flags: needinfo?(apoirot)
Priority: P3 → P1
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Regressions: 1586503
No longer blocks: 1586503
Regressions: 1587858
You need to log in before you can comment on or make changes to this bug.