Closed Bug 1548043 Opened 5 months ago Closed 4 months ago

In recommendations, the "Tech πŸ–₯" section depends on system-font support for the U+1F5A5 DESKTOP COMPUTER emoji

Categories

(Firefox :: New Tab Page, defect, P1, minor)

defect

Tracking

()

VERIFIED FIXED
Firefox 69
Iteration:
69.2 - May 27 - Jun 9
Tracking Status
firefox69 --- verified

People

(Reporter: Waldo, Assigned: gsuntop)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(3 files)

Attached image Screenshot of missing emoji β€”

The new-tab page in nightlies recently picked up sectioned recommendation support. Each section is a name (e.g. "Tech") and an emoji ("πŸ–₯"). This is cool and all -- but this means the headings' font must support that emoji.

Unfortunately, the "Tech" associated emoji, U+1F5A5 DESKTOP COMPUTER, doesn't seem to be guaranteed in the relevant font. On a largely basic Fedora 28, it instead shows up as some sort of missing-glyph thing. (Or maybe there's actually a glyph there? Usually missing glyphs get box-of-hexadecimal treatment, not sure what's up there.) Maybe the Mozilla emoji-font we ship needs to have support added for this...or something.

One possible hackaround, if font support isn't quite there and can't readily be added, might be to switch to U+1F4F1 MOBILE PHONE. That arguably has the virtue of being more "modern" than a desktop, and it displays for me so support for it is better at least some places.

Per emojipedia Desktop Computer was approved as part of Unicode 7.0 in 2014 and added to Emoji 1.0 in 2015.
https://emojipedia.org/desktop-computer/

Priority: -- → P2
No longer blocks: pocket-newtab-69
No longer blocks: pocket-newtab-68

FWIW latest Fedora (30 -- 28 from comment 0 is now unsupported) still doesn't support this emoji.

Assignee: nobody → gsuntop
Priority: P2 → P1
Blocks: 69-ds-polish

Looks like U+1F4F1 MOBILE PHONE was approved in Unicode 6.0. I'm not sure if that means anything in 6.0 is fair game since there are so many Linux distros.

FWIW the font-family stack for those headers is -apple-system, BlinkMacSystemFont, 'Segoe UI', 'Ubuntu', 'Helvetica Neue', sans-serif.

As fonts have varying support for emoji I'm not sure if there's any 100% bulletproof choice. We may want to consider embedding SVG glyphs to ensure compatibility. That will, however, require an update to our layout schema.

It seems like the best short term solution is to go with the mobile phone emoji as suggested, or find something else from Unicode 6 or lower.

Wolasi, thoughts?

Flags: needinfo?(wkonu)

Another option from Unicode 6: https://emojipedia.org/personal-computer/

πŸ’»

Personal Computer seems like a decent compromise

Flags: needinfo?(wkonu)

IRC suggests that font-family: "Twemoji Mozilla" may be adequate to ensure display happens, using the internal emoji-support font we ship with.

If we use that font-family it should just be applied to the emoji, which will need a schema change. That seems like the better long term solution, but as a speedier interim solution we can just switch to the personal computer emoji for wider support.

I can update the emoji in the shipped/bundled layout, and then I believe Mathijs can update it in the remote layouts.

Blocks: 1555507
Status: NEW → RESOLVED
Iteration: --- → 69.2 - May 27 - Jun 9
Closed: 4 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (69.0a1 Build ID - 20190604034844) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, the "Tech" section's icon is changed.

Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.