Closed Bug 1548046 Opened 4 years ago Closed 2 years ago

Picture-in-Picture toggle button that are obscured by video settings pop-up respond to mouse clicks

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

68 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1666739
Tracking Status
firefox68 - ---

People

(Reporter: alice0775, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Attached file video_youtube.html (obsolete) —

[Tracking Requested - why for this release]:PiP toggler and video settings menu will interfere.

Reproducible: always

Steps To reproduce:

  1. Open https://www.twitch.tv/
  2. Click on gear icon in the vidio controls
  3. Click at right-bottom corner of ">" mark of "Quality"

Steps To reproduce:

  1. Open embedded Youtube video
  2. Click on gear icon in the vidio controls
  3. Click at right side of ">" mark of "Playback Speed"

Actual Results:
The video pops out

Expected Results:
Should not.
The Picture-in-Picture toggle button should not activate when the settings menu is clicked and hovering mouse pointer.

Attached image image.png

Very bad UX.
May be z-index problem?

Priority: -- → P3
Attached file video_youtube.html
Attachment #9061687 - Attachment is obsolete: true

P-i-P is nightly only for now.

Blocks: 1527926
No longer regressed by: 1527926

I think the issue on Instagram falls into the same category.

Steps to reproduce

  1. Visit https://www.instagram.com/p/BwmBz2hnHgD/.
  2. Play the video.
  3. Try to advance to the next image by clicking the arrow (shown in the attached screenshot).

Actual result

The video pops out. I have to click a second time to advance.
The PiP video stops too. (bug 1547349?)

See Also: → 1550453
Duplicate of this bug: 1579488
Blocks: 1532675
No longer blocks: 1527926
Duplicate of this bug: 1595372
No longer blocks: 1532675
Duplicate of this bug: 1629546

Due to Bug 1653663, The toggle button in Nightly82.0a1 is bigger than Firefox81.0b7.
The problem was aggravated :(

screencast: https://youtu.be/fiz3eIAuCcA

Regressed by: 1653663
Keywords: regression
See Also: → 1666739

Facing the same issue on Youtube. PiP button is clickable under drop-up menu
82.0.3 (64-битный) OSX
https://imgur.com/a/HOqqOTb

Same here, it happened a few times already. Problem is, the 480p setting is on top of the PiP button.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1666739
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.