Closed Bug 1548311 Opened 7 months ago Closed 4 months ago

Google Calendar doesn't track current time accurately in restored, pinned tab

Categories

(Firefox :: Session Restore, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox66 --- affected
firefox67 --- affected
firefox68 --- affected
firefox69 --- ?
firefox70 --- unaffected

People

(Reporter: bytesized, Unassigned)

References

Details

Attachments

(1 file)

Steps to reproduce:

  1. In about:preferences, check "Restore Previous Session"
  2. Open Google Calendar (https://calendar.google.com)
  3. Right click on the tab and press "Pin Tab"
  4. Create an event starting in a half and hour with an alert at the time of the event
  5. Close Firefox
  6. Reopen Firefox
  7. Wait 1 hour

Expected results:
After 30 minutes, I should be alerted about my event. The red line indicating the current time should show the current time.

Actual results:
I am not notified of my event. The red line still indicates the time that I loaded the page at rather than the current time.

Component: General → Session Restore
Product: Core → Firefox

Here is a screenshot of a particularly nasty instance of this problem. Note that Google Calendars thinks that it is May 2nd, but Windows thinks (correctly) that it is May 3rd.

You can also see that I have a meeting less than 5 minutes from when the screenshot was taken, but I have not been notified about it.

I noticed this same problem about two days ago in my pinned Google Calendar tab. My calendar is roughly 29 hours and 45 minutes behind the current time. I'm running Windows 10 Insider Preview.

The problem went away when I opened Google Calendar in a second, non-pinned tab and then refreshed my pinned tab.

Also seeing this on Nightly on macOS. A restored Google Calendar tab is reporting that today is Wednesday, May 1st when it's Friday, May 3rd. Running "new Date()" in the Web Console does show the correct date and time.

After a reload (Command-R), the site reports the current date correctly.

Change the status for beta to have the same as nightly and release.
For more information, please visit auto_nag documentation.

I've reached out to Google via our partner list to see if they can help us.

I notice that when I update my nightly my google calendar loads the previous version of the page from when I last did a F5 refresh, which was yesterday morning when I noticed the same problem. After I refreshed yesterday, my calendar functioned correctly and I got all my meeting notifications so I'm a little surprised to see it still thinks it was yesterday morning.

FWIW this may be a general Google Calendar problem and not Firefox specific. I opened Google Calendar yesterday morning on Chrome and left it in the background and it still shows the date as yesterday.

Is this a change on Google Calendar's end, or potentially a regression we should be searching for a window for?

(In reply to Vicky Chin [:vchin] from comment #6)

FWIW this may be a general Google Calendar problem and not Firefox specific. I opened Google Calendar yesterday morning on Chrome and left it in the background and it still shows the date as yesterday.

(In reply to Cameron McCormack (:heycam) from comment #7)

Is this a change on Google Calendar's end, or potentially a regression we should be searching for a window for?

Vicky said in comment 6 that she saw the problem in Chrome. But considering how many people here have seen this bug, you would think the Google Chrome or Calendar teams would have noticed this bug if it was a Calendar bug.

So my guess here is that Google Calendar has changed to rely on time-server live (through a websocket connection or somesuch), which would cause this behavior for restored sessions. This is because we restore to the last known session history, which doesn't restore the background connections to a server, since they're usually tied to a server session.
In order to see the live version of the page, you need to refresh it indeed.

This behavior hasn't changed recently in Firefox. This must be a Google Calendar change. Bug 669070 is what I found as the earliest dupe.

(In reply to Dennis Schubert [:denschub] from comment #5)

I've reached out to Google via our partner list to see if they can help us.

No response yet from Google. I'll give a gentle nudge early next week.

Flags: needinfo?(miket)

Update: Google is investigating.

Flags: needinfo?(miket)
Priority: -- → P3

I don't know about others, but I haven't experienced this problem in a while.

Chris- You said you were experiencing this problem too. Has it gone away for you, or are you still having the same issue?

Flags: needinfo?(cpeterson)

(In reply to Kirk Steuber (he/him) [:bytesized] from comment #12)

Chris- You said you were experiencing this problem too. Has it gone away for you, or are you still having the same issue?

I haven't seen this problem since it was first reported. This might have been a server problem. I think we can close this bug as WORKSFORME.

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(cpeterson)
Resolution: --- → WORKSFORME

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

You need to log in before you can comment on or make changes to this bug.