Closed Bug 1548339 Opened 6 months ago Closed 3 months ago

Swizzle support in WebRender

Categories

(Core :: Graphics: WebRender, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: kvark, Assigned: kvark)

References

Details

(Whiteboard: [wr-q2][wr-may])

Attachments

(3 files)

glTextureStorage doesn't play well with BGRA8 textures on some platforms (MacOS and some Androids). We can work around it by having some of the textures swizzled by WebRender, at the cost of potentially breaking more batches.

allow the swizzle to be configurable with a texture binding

Priority: -- → P3
Whiteboard: [wr-q2][wr-may]
Attachment #9061972 - Attachment description: [WIP] WR swizzle configuration of texture units → [Draft] WR swizzle configuration of texture units

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:kvark, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(dmalyshau)

No activity on the code side is expected - it's been in discussion.
We need to rework the code a bit to be less principled and catering to GL driver assumptions (accept BGRA inputs for RGBA internal format as a norm, but no windows/linux GL only)

Flags: needinfo?(dmalyshau)
Duplicate of this bug: 1562817
See Also: → 1474281
Attachment #9061972 - Attachment description: [Draft] WR swizzle configuration of texture units → WR swizzle configuration of texture units
Attachment #9061972 - Attachment description: WR swizzle configuration of texture units → [Draft] WR swizzle configuration of texture units
Keywords: leave-open

Getting close to finishing this. One of the missing pieces is handling the blits correctly, in particular ones that are caused by tiled images.

this makes the shader simpler at no cost

Pushed by dmalyshau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/72904ab48c45
WR: Remove the color/alpha feature in cs_scale shader r=jrmuizel
Assignee: nobody → dmalyshau
Status: NEW → ASSIGNED
Attachment #9061972 - Attachment description: [Draft] WR swizzle configuration of texture units → WR swizzle configuration of texture units

looks like a typo that got unnoticed? I wonder how our alpha saved tasks work today :)

Pushed by dmalyshau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4af33fd2da39
Fix WR saved alpha task sampling r=gw
Keywords: leave-open
Pushed by dmalyshau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bc58681d2407
WR swizzle configuration of texture units r=gw
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1570816
Regressions: 1570736
You need to log in before you can comment on or make changes to this bug.