Closed Bug 1549814 Opened 5 months ago Closed 5 months ago

Can open a blank LoginItem in Edit mode

Categories

(Firefox :: about:logins, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox69 --- verified

People

(Reporter: jaws, Assigned: jaws)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: [passwords:management] [skyline] )

Attachments

(6 files)

No description provided.
Flags: qe-verify+

This will allow for creation of logins. Logins should have an empty string for the formSubmitURL which will create them as "wildcard" logins not tied to a specific formSubmitURL.

User Story: (updated)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Depends on: 1553184
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b3c8b0e8a870
Update common.inc.css to style password inputs similar to text inputs. r=MattN
https://hg.mozilla.org/integration/autoland/rev/dacfa366cb7e
Update the login-list count on login additions and removals. r=MattN
https://hg.mozilla.org/integration/autoland/rev/6c90643f1024
Include a title with the login object that removes http(s) or www prefix. r=MattN
https://hg.mozilla.org/integration/autoland/rev/78c10f828b20
LoginHelper.searchLoginsWithObject always returns an array so no need to check for a falsy return value. r=MattN
https://hg.mozilla.org/integration/autoland/rev/59f879c15252
Add 'New Login' button to create new saved logins. r=MattN,Pike
https://hg.mozilla.org/integration/autoland/rev/9fb6895ef8fd
Add automated tests for creating a login. r=MattN
Regressions: 1553373

Verified - fixed on latest Nightly 69.0a1 (2019-05-23) (64-bit) on Windows 10 x64, Mac OS 10.13 and Ubuntu 18.04.

  • New Login button is available and allows the user to create new logins
  • Entry count is updated after adding or removing newly created logins
  • Password styling is applied correctly for new logins
  • The https:// or www prefixes are correctly removed from the new entry title

However, adding a new login via the button - after we already added one using the same method - will pre-fill the Website Adress with the address from the previous entry.

Jared, should I submit a bug for this or it is known/expected?

Status: RESOLVED → VERIFIED
Flags: qe-verify+ → needinfo?(jaws)
Depends on: 1557533
Whiteboard: [passwords:management] [skyline]

(In reply to Timea Babos [on PTO until 19th Aug - ni? Brindusa Tot] from comment #10)

However, adding a new login via the button - after we already added one using the same method - will pre-fill the Website Adress with the address from the previous entry.

Jared, should I submit a bug for this or it is known/expected?

I can't reproduce this on latest mozilla-central builds. I think it has been since fixed. Please file a new bug if you are still able to reproduce this.

Flags: needinfo?(jaws)
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla69 → Firefox 69
You need to log in before you can comment on or make changes to this bug.