Closed Bug 1553373 Opened 3 years ago Closed 3 years ago

xul:textbox type=password show multiple borders

Categories

(Toolkit :: Themes, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- verified

People

(Reporter: jaws, Assigned: jaws)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [passwords:management] [skyline] )

Attachments

(1 file, 1 obsolete file)

xul:textbox[type=password] is implemented via an inner html:input[type=password]. The changes in bug 1549814 are causing a double border to appear on html:input[type=password] when the input is focused.

This is visible in the Set Master Password dialog in about:preferences.

We could change the CSS to not apply these styles to xul:textbox that have a type attribute specified.

Flags: qe-verify+
Component: Theme → Themes
Product: Firefox → Toolkit

(In reply to (Limited availability 5/20-5/24) Jared Wein [:jaws] (please needinfo? me) from comment #0)

xul:textbox[type=password]

Do we need to keep supporting this at all?

This is visible in the Set Master Password dialog in about:preferences.

Could this use <input type="password">?

Flags: needinfo?(jaws)
Flags: needinfo?(jaws)

(In reply to Dão Gottwald [::dao] from comment #2)

(In reply to (Limited availability 5/20-5/24) Jared Wein [:jaws] (please needinfo? me) from comment #0)

xul:textbox[type=password]

Do we need to keep supporting this at all?

This is visible in the Set Master Password dialog in about:preferences.

Could this use <input type="password">?

Yeah, that would be simpler and in the right direction.

Attachment #9066599 - Attachment is obsolete: true
Blocks: 1547372
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f6cb5057e282
Change to use html:input type=password instead of xul:textbox type=password in Master Password dialogs since they use common styling which defines proper styling for html:input[type=password] now. r=dao
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Hi, I managed to reproduce this issue in an older version of Nightly 69.0a1 (2019-05-22) but it no longer occurs in Nightly 69.0a1 (2019-05-29).
This issue was tested on All operating systems.

Status: RESOLVED → VERIFIED
Whiteboard: [passwords:management] [skyline]
No longer depends on: 1567095
Regressions: 1567095
Regressions: 1572445
Depends on: 1572445
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.