Closed Bug 1549815 Opened 1 year ago Closed 1 year ago

Unexpected autocomplete behaviour when entering IP address

Categories

(Firefox :: Address Bar, defect)

66 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1537640

People

(Reporter: general.bison, Unassigned)

Details

Attachments

(1 file)

Attached image Animated GIF of problem

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Type http://192.168.0.38 into Firefox location bar

Actual results:

After typing "http://192.", the location bar automatically changes to "192.0.0.0" and places the cursor at the end. Not the regular behaviour for URL autocomplete

Expected results:

As I type the URL/IP address, autocomplete options are highlighted and appropriately overwritten as I finish typing

Not I've also had this problem on my Windows 10 machine (Also branch 66 I think), this behaviour persists after clearing all browsing data including auto complete data.

hi, thanks for reporting. this issue is looking related to bug 1537640 which got a fix in firefox 68. could you test if the behaviour is still reproducible in firefox nightly?

It's fixed in Firefox 67 as well. You can either test the latest beta now, or wait until it's released on May 14th.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Component: Untriaged → Address Bar
Resolution: --- → DUPLICATE
Duplicate of bug: 1537640
You need to log in before you can comment on or make changes to this bug.