Youtube AV1 video glitch(block noise)

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
2 months ago

People

(Reporter: alice0775, Assigned: achronop)

Tracking

(Regression, 4 keywords)

68 Branch
mozilla68
x86_64
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68+ verified, firefox69 verified)

Details

Attachments

(4 attachments)

[Tracking Requested - why for this release]: Youtube video is important. Firefox 68 should not release until fix this.

Reproducible: always

Steps to Reproduce:

  1. Open https://youtu.be/NL2jL_ZMuqU?t=79

Actual Results:
Block noise appears

Expected Results:
no such glitch

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=98adabf295d0bdd1d48cf715fb8ac8ea4ead8766&tochange=8ce9905a2eec887a9b4ed63798961cef1fa3fded

Regressed by: Bug 1540830

Alex Chronopoulos [:achronop],
Your patch seems to cause the glitch. Can you please look into this?

Flags: needinfo?(achronop)
Posted image Status for nerds
Posted file about:support
Summary: Youtube video glitch(block noise) → Youtube AV1 video glitch(block noise)

and if you can't reproduce it, go to https://www.youtube.com/testtube and enable "Always Prefer AV1" instead of default "Auto"

Thanks for the detailed information. I can reproduce that in my win 10 machine latest Nightly. I will report it upstream.

Flags: needinfo?(achronop)

The following issue filed upstream: https://code.videolan.org/videolan/dav1d/issues/275

It would be helpful to know if anyone with AVX2-capable CPU can reproduce this.

(In reply to Alex Chronopoulos [:achronop] from comment #7)

It would be helpful to know if anyone with AVX2-capable CPU can reproduce
this.

I have a AVX2 enabled CPU (Broadwell-U). I enabled AV1, and confirmed the video was serving AV1 video by checking the stats-for-nerds.
I was not able to repro the glitch.
I assume that the glitch is the "blueish color" of background and hands in the video at 1:19-1:21 mark.

Flags: needinfo?(achronop)

Thank you very much for checking, that was very helpful. I have reported that upstream. The issue is fixed now.

Flags: needinfo?(achronop)
Assignee: nobody → achronop
Status: NEW → ASSIGNED
OS: Windows 10 → Windows

I think 67 (beta) may have an old enough dav1d that this doesn't occur. Can someone on windows check?

(In reply to Thomas Daede [:TD-Linux] from comment #12)

I think 67 (beta) may have an old enough dav1d that this doesn't occur. Can
someone on windows check?

I cannot reproduce this problem on Firefox67.0b18 Windows10.

Priority: -- → P1
Pushed by achronopoulos@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dd4958dfdea0
Import dav1d from upstream to a713643. r=TD-Linux
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Flags: qe-verify+

I managed to reproduce the issue using an older version of Nightly (2019-05-07) on Windows 10 x64.
I retested everything using latest Nightly 69.0a1 and Firefox 68.0b12 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64 and the bug is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.