Closed Bug 1550521 Opened 7 months ago Closed 7 months ago

[about:addons] Theme detail page shows label with private browsing text

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: robwu, Assigned: mstriemer)

References

(Regression)

Details

Attachments

(2 files)

STR:

  1. Visit about:config and set extensions.htmlaboutaddons.enabled to true
  2. Install a theme.
  3. Go to about:addons and click on the Themes list. Then click on the theme that you just installed.
  4. Look below the "Allow automatic updates" section.

Expected:

  • Author, version, etc.

Actual:

  • The following text is visible:

    When allowed, the extension will have access to your online activities while private browsing. Learn more

Note that the radio inputs to toggle the private browsing permission are not visible.

Blocks: 1545427
Priority: -- → P1
Regressed by: 1535683
Assignee: nobody → mstriemer
Duplicate of this bug: 1550938
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/01fcbba06f1c
Remove private browsing help message with settings hidden r=jaws
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Attached image Bug1550521.png

I was able to reproduce this issue on Firefox 68.0a1 (20190513082256) under Win 7 64-bit.

This issue is verified as fixed on Firefox 69.0a1 (20190523215203) and Firefox 68.0b4 (20190523115432) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached screenshot.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.