Last Comment Bug 155053 - Make the spinbuttons a real widget
: Make the spinbuttons a real widget
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Themes (show other bugs)
: Trunk
: All All
: -- minor (vote)
: ---
Assigned To: Neil Deakin
: Patty Mac
:
Mentors:
: 276146 319088 (view as bug list)
Depends on:
Blocks: 467901 260487
  Show dependency treegraph
 
Reported: 2002-06-30 00:29 PDT by John Dobbins
Modified: 2014-04-25 15:16 PDT (History)
12 users (show)
asa: blocking‑aviary1.5-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
spinbtn-dn.gif (82 bytes, image/gif)
2003-10-15 06:50 PDT, John Dobbins
no flags Details
spinbtn-dn-act.gif (80 bytes, image/gif)
2003-10-15 06:51 PDT, John Dobbins
no flags Details
spinbtn-up.gif (81 bytes, image/gif)
2003-10-15 06:52 PDT, John Dobbins
no flags Details
spinbtn-up-act.gif (80 bytes, image/gif)
2003-10-15 06:53 PDT, John Dobbins
no flags Details
native theme changes for spinbuttons (30.70 KB, patch)
2006-06-09 11:22 PDT, Neil Deakin
roc: review+
roc: superreview+
Details | Diff | Splinter Review
Add spinbuttons widget (16.53 KB, patch)
2006-06-09 11:25 PDT, Neil Deakin
no flags Details | Diff | Splinter Review
Add images for other platforms (19.25 KB, patch)
2006-06-19 09:53 PDT, Neil Deakin
no flags Details | Diff | Splinter Review
fix sizing issues (19.36 KB, patch)
2006-07-11 13:02 PDT, Neil Deakin
neil: review-
neil: superreview+
Details | Diff | Splinter Review
Fix issues described above by setting a minimum height (19.32 KB, patch)
2006-07-12 13:13 PDT, Neil Deakin
neil: review+
Details | Diff | Splinter Review

Description John Dobbins 2002-06-30 00:29:23 PDT
spinbuttons.css refers to icons that are no longer there.

In Classic,
http://lxr.mozilla.org/seamonkey/source/themes/classic/global/mac/spinbuttons.css
and
http://lxr.mozilla.org/seamonkey/source/themes/classic/global/win/spinbuttons.css
have referances like this
.up {
  list-style-image: url("chrome://global/skin/spinbtn-up.gif")
}
All icons were removed from the global directory in December. No new directory
was created to hold these icons.

In Modern,
http://lxr.mozilla.org/seamonkey/source/themes/modern/global/spinbuttons.css
refers to
.up {
  list-style-image: url("chrome://global/skin/spinbuttons/btn-up.gif");
}
There is no spinbuttons directory holding these icons.
Comment 1 HJ 2002-09-06 22:57:49 PDT
Hakan, can you help us with the missing images? Thanks.
Comment 2 Håkan Waara 2002-09-07 03:53:39 PDT
This did work, I know glazou used the spinbuttons widget in his XUL application;
someone broke it, and it sure wasn't me! :-)

CC'ing some random people, does anyone have any idea?
Comment 3 Daniel Glazman (:glazou) 2002-09-10 07:45:20 PDT
Yes, I do use spinbuttons
Comment 4 HJ 2002-09-10 13:00:04 PDT
Hakan or Daniel, can one of you guys please commit the missing images into the
tree, this way we can have a go with the buttons, I don't have a clue what they
do/can do yet.
Comment 5 John Dobbins 2003-10-15 06:50:24 PDT
Created attachment 133331 [details]
spinbtn-dn.gif
Comment 6 John Dobbins 2003-10-15 06:51:17 PDT
Created attachment 133332 [details]
spinbtn-dn-act.gif
Comment 7 John Dobbins 2003-10-15 06:52:12 PDT
Created attachment 133333 [details]
spinbtn-up.gif
Comment 8 John Dobbins 2003-10-15 06:53:02 PDT
Created attachment 133334 [details]
spinbtn-up-act.gif
Comment 9 John Dobbins 2003-10-15 06:55:49 PDT
I Found Copies of the missing icons and added attached them to this bug.
Comment 10 Daniel Glazman (:glazou) 2004-04-16 07:19:31 PDT
Taking bug
Comment 11 neil@parkwaycc.co.uk 2004-04-16 07:32:07 PDT
This should so be done with CSS borders and backgrounds.
Comment 12 Daniel Glazman (:glazou) 2004-04-16 07:34:17 PDT
(In reply to comment #11)
> This should so be done with CSS borders and backgrounds.

Right.
Comment 13 neil@parkwaycc.co.uk 2005-01-28 13:51:55 PST
*** Bug 276146 has been marked as a duplicate of this bug. ***
Comment 14 Richard Klein 2005-02-16 09:38:44 PST
I'm going ask for 1.1 blocking on a couple of spinbutton bugs.  We have been
trying to use them in our ForcastFox extension, but they won't theme correctly
since we have to supply our own images.
Comment 15 zug_treno 2005-12-05 16:14:29 PST
*** Bug 319088 has been marked as a duplicate of this bug. ***
Comment 16 Neil Deakin 2006-03-15 18:49:19 PST
Morphing this bug into one about making the <spinbuttons/> a real XUL element with  propery properties, methods and events, etc.

Comment 17 Neil Deakin 2006-06-09 11:22:44 PDT
Created attachment 225034 [details] [diff] [review]
native theme changes for spinbuttons
Comment 18 Neil Deakin 2006-06-09 11:25:51 PDT
Created attachment 225036 [details] [diff] [review]
Add spinbuttons widget
Comment 19 neil@parkwaycc.co.uk 2006-06-09 16:57:05 PDT
I can't see any code that draws the spinbuttons on Windows 2000 or BeOS?
Comment 20 Neil Deakin 2006-06-19 09:53:34 PDT
Created attachment 226165 [details] [diff] [review]
Add images for other platforms

Added to Windows spinbuttons.css, but otherwise unchanged.

The only issue is that for xpfe, the spinbuttons appears too tall, but I can't figure out what the reason for that is. Different images, maybe?
Comment 21 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-06-22 03:17:47 PDT
Comment on attachment 225034 [details] [diff] [review]
native theme changes for spinbuttons

mostly a rubber-stamp...
Comment 22 neil@parkwaycc.co.uk 2006-07-03 04:51:58 PDT
(In reply to comment #20)
>The only issue is that for xpfe, the spinbuttons appears too tall, but I can't
>figure out what the reason for that is. Different images, maybe?
You're using the 11x11 arrow images that Classic has. Strangely on my XP build the spinbuttons has a height of 22. Where did the borders go? I'm worried that the native theme code is overriding the border size even when it's not painting.
Comment 23 neil@parkwaycc.co.uk 2006-07-03 04:56:16 PDT
I removed the -moz-appearance and it makes makes things look as expected.
I'd say that's bad :-(
Obviously if I was using Luna then I would expect it to override the size.
Comment 24 neil@parkwaycc.co.uk 2006-07-03 05:18:05 PDT
The Modern styles are forcing the image to be 2px high which seems odd.
Comment 25 Neil Deakin 2006-07-11 13:02:22 PDT
Created attachment 228842 [details] [diff] [review]
fix sizing issues

- fix up modern theme appearance
- for Classic themes, use background images for spinbuttons rather than list-style-images
Comment 26 neil@parkwaycc.co.uk 2006-07-11 15:43:54 PDT
Comment on attachment 228842 [details] [diff] [review]
fix sizing issues

Well the good news is that the Modern theme looks quite nice. However, I'd say the Classic theme still has issues.
* I hunted around my RH7.3 linux box for some spinbuttons and found some that were 15x22 so I'm not sure where your dimensions came from.
* On Windows 2000, or Windows XP with Classic theme, the default height of the spinbuttons is zero. That's right, you don't even get any borders.
* On either platform, if you disable (or don't have) themeing (I do this because I don't like the GTK native themeing) then you do get to see the borders, but you have to set a height to see the arrows.
* Once I'd done that I noticed that an odd width looks better. In fact I'd say an odd width looks better in Modern too.
Comment 27 Neil Deakin 2006-07-12 13:13:11 PDT
Created attachment 228991 [details] [diff] [review]
Fix issues described above by setting a minimum height

The spinbuttons look the right size on my FC4 system, comparing to various preference panels. Are you using gtk1?
Comment 28 neil@parkwaycc.co.uk 2006-07-13 09:00:17 PDT
Comment on attachment 228991 [details] [diff] [review]
Fix issues described above by setting a minimum height

Still hacky but at least it works...
Comment 29 neil@parkwaycc.co.uk 2006-07-13 15:37:40 PDT
So it looks as if the problem with the Classic theme was that when Classic themeimg was first written not all of the Classic* functions were implemented for spinbuttons, in they are given neither size, border nor background.

Note You need to log in before you can comment on or make changes to this bug.