Closed Bug 1551200 Opened 3 months ago Closed 3 months ago

getOriginalLocations should bail if there are no locations

Categories

(DevTools :: Debugger, defect, P1)

defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox68 --- fixed

People

(Reporter: jlast, Assigned: jlast)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [debugger-mvp])

Attachments

(1 file)

console.warn: "Action setBreakpointPositions had an exception:" "TypeError: locations.some is not a function"

https://searchfox.org/mozilla-central/source/devtools/client/debugger/packages/devtools-source-map/src/source-map.js#269

Duplicate of this bug: 1551199
Assignee: nobody → jlaster
Status: NEW → ASSIGNED
Whiteboard: [debugger-mvp]
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2f0be794dff5
getOriginalLocations should bail if there are no locations. r=loganfsmyth
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.