Closed Bug 1551223 Opened 3 years ago Closed 3 years ago

MacOS 10.14.4 - 'NSInternalInconsistencyException', reason: 'Could not create texture for accelerated surface.'

Categories

(Core :: Widget: Cocoa, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox68 --- affected

People

(Reporter: Gankra, Unassigned)

References

Details

Seems like 10.14.4 has an issue when using a firefox built with the 10.14 sdk. I can get this deterministically when visiting https://www.channelfireball.com/all-strategy/

full output of my session:

/Users/ABeingessner/dev/gecko/obj-x86_64-apple-darwin18.5.0/dist/Nightly.app/Contents/MacOS/firefox -no-remote -foreground -profile /Users/ABeingessner/dev/gecko/obj-x86_64-apple-darwin18.5.0/tmp/profile-default
console.log: WebExtensions: new intermediate certificate added
console.log: WebExtensions: signatures re-verified
bootstrap_check_in():  (os/kern) unknown error code (44c)
2019-05-13 10:29:49.593 firefox[29173:786195] *** Assertion failure in -[NSCGLSurface flushRect:], /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppKit/AppKit-1671.40.119/OpenGL.subproj/NSCGLSurface.m:569
2019-05-13 10:29:49.614 firefox[29173:786195] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Could not create texture for accelerated surface.'
*** First throw call stack:
(
	0   CoreFoundation                      0x00007fff34f84cf9 __exceptionPreprocess + 256
	1   libobjc.A.dylib                     0x00007fff5fb19a17 objc_exception_throw + 48
	2   CoreFoundation                      0x00007fff34f9fa16 +[NSException raise:format:arguments:] + 98
	3   Foundation                          0x00007fff37231e11 -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 194
	4   AppKit                              0x00007fff32fb8c0a -[NSCGLSurface flushRect:] + 4475
	5   AppKit                              0x00007fff32fb79f4 NSCGLSurfaceFlush + 214
	6   GLEngine                            0x00007fff3eb20a4a glSwap_Exec + 186
	7   OpenGL                              0x00007fff3eb0274f CGLFlushDrawable + 59
	8   AppKit                              0x00007fff32911478 -[NSOpenGLContext flushBuffer] + 27
	9   XUL                                 0x00000001071c427d _ZN7mozilla2gl12GLContextCGL11SwapBuffersEv + 125
	10  XUL                                 0x0000000107484fd8 _ZN7mozilla2wr11RendererOGL15UpdateAndRenderERKNS_5MaybeINS_3gfx12IntSizeTypedINS3_12UnknownUnitsEEEEERKNS2_INS0_11ImageFormatEEERKNS2_INS_5RangeIhEEEEbPNS0_13RendererStatsE + 392
	11  XUL                                 0x000000010748465b _ZN7mozilla2wr12RenderThread15UpdateAndRenderENS0_10WrWindowIdERKNS_6layers17BaseTransactionIdINS_11VsyncIdTypeEEERKNS_9TimeStampEbRKNS_5MaybeINS_3gfx12IntSizeTypedINSD_12UnknownUnitsEEEEERKNSC_INS0_11ImageFormatEEERKNSC_INS_5RangeIhEEEEb + 427
	12  XUL                                 0x0000000107484352 _ZN7mozilla2wr12RenderThread11HandleFrameENS0_10WrWindowIdEb + 610
	13  XUL                                 0x000000010748e5bf _ZN7mozilla6detail18RunnableMethodImplIPNS_2wr12RenderThreadEMS3_FvNS2_10WrWindowIdEbELb1ELNS_12RunnableKindE0EJS5_bEE3RunEv + 47
	14  XUL                                 0x0000000106aa4425 _ZN11MessageLoop6DoWorkEv + 693
	15  XUL                                 0x0000000106aa4df4 _ZN4base18MessagePumpDefault3RunEPNS_11MessagePump8DelegateE + 836
	16  XUL                                 0x0000000106aa3bf6 _ZN11MessageLoop3RunEv + 86
	17  XUL                                 0x0000000106aae2a6 _ZN4base6Thread10ThreadMainEv + 518
	18  XUL                                 0x0000000106aa9f5a _ZL10ThreadFuncPv + 10
	19  libsystem_pthread.dylib             0x00007fff615352eb _pthread_body + 126
	20  libsystem_pthread.dylib             0x00007fff61538249 _pthread_start + 66
	21  libsystem_pthread.dylib             0x00007fff6153440d thread_start + 13
)
libc++abi.dylib: terminating with uncaught exception of type NSException
Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=1.40207) [GFX1-]: Receive IPC close with reason=AbnormalShutdown
Exiting due to channel error.
Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=3.62389) [GFX1-]: Receive IPC close with reason=AbnormalShutdown
Exiting due to channel error.
Exiting due to channel error.
Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=5.28787) [GFX1-]: Receive IPC close with reason=AbnormalShutdown
Exiting due to channel error.

This isn't a huge issue since we still don't fully support building with the 10.14 SDK, but it is a regression in the usability of such a build (it is now unusable for me).

Blocks: mojave-sdk

note: we aren't the only ones running into this. Some quick googling indicates SublimeText and Flutter users are also running into this, but no one seems to know what the issue is yet.

Would be useful to know what the assertion is in -[NSCGLSurface flushRect:], /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppKit/AppKit-1671.40.119/OpenGL.subproj/NSCGLSurface.m:569

Nice, this was a macos bug and they just released 10.14.5 with the fix an hour after I filed this!

Confirmed built and run locally.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.