Closed Bug 1551306 Opened 1 year ago Closed 2 months ago

Remove context parameter from nsIProgressEventSink.onProgress() and nsIProgressEventSink.onStatus()

Categories

(Core :: Networking, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox68 --- wontfix
firefox76 --- fixed

People

(Reporter: jorgk-bmo, Assigned: sonakshisaxena1, Mentored)

References

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file)

Whiteboard: [necko-triaged]

You need to get in touch with a person from Core::Networking.

(In reply to Sonakshi Saxena from comment #1)

Can I work on this?

For AsyncRead we handle it in bug 1528649.

The context parameter of nsIProgressEventSink.onProgress() and nsIProgressEventSink.onStatus() appears to be unneeded now. It's hard to see where event sinks are finally implemented, but these ones here ignore the context parameter:

You can take this if you want.

Assignee: nobody → sonakshisaxena1
Mentor: valentin.gosu
See Also: → 1528649
Summary: Remove context parameter from nsIInputStreamPump.asyncRead(), nsIProgressEventSink.onProgress() and nsIProgressEventSink.onStatus() → Remove context parameter from nsIProgressEventSink.onProgress() and nsIProgressEventSink.onStatus()
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d91e4acdd63c
Remove context parameter from nsIProgressEventSink.onProgress() and nsIProgressEventSink.onStatus() r=valentin
Backout by malexandru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62c68147c735
Backed out changeset d91e4acdd63c for causing bustages in request::InitBitsRequest

Missed that! Apologies!
Have made the changes now :)

Flags: needinfo?(sonakshisaxena1)
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ad4847d17298
Remove context parameter from nsIProgressEventSink.onProgress() and nsIProgressEventSink.onStatus() r=valentin
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/daaa31a001e5
Backed out changeset ad4847d17298 for causing build bustages. CLOSED TREE

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&revision=ad4847d1729808586718cf6e525d6ea8af6761fd&selectedJob=295106188

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=295106188&repo=autoland

Backout link: https://hg.mozilla.org/integration/autoland/rev/daaa31a001e5

[task 2020-03-27T18:35:08.130Z] 18:35:08 INFO - [swgl 0.1.0] running: "/builds/worker/fetches/sccache/sccache" "/builds/worker/fetches/clang/bin/clang-cl" "-Xclang" "-std=gnu99" "-m32" "-nologo" "-MD" "-O1" "-Z7" "-Brepro" "-m32" "-arch:IA32" "-Xclang" "-ftrivial-auto-var-init=pattern" "-guard:cf" "-DDEBUG=1" "-I/builds/worker/checkouts/gecko/toolkit/library/gtest/rust" "-I/builds/worker/workspace/obj-build/toolkit/library/gtest/rust" "-I/builds/worker/workspace/obj-build/dist/include" "-I/builds/worker/workspace/obj-build/dist/include/nspr" "-I/builds/worker/workspace/obj-build/dist/include/nss" "-MD" "-FI" "/builds/worker/workspace/obj-build/mozilla-config.h" "-DMOZILLA_CLIENT" "-Qunused-arguments" "-fcrash-diagnostics-dir=/builds/worker/artifacts" "-D_HAS_EXCEPTIONS=0" "-W3" "-Gy" "-Zc:inline" "-arch:SSE2" "-Gw" "-Wno-unknown-pragmas" "-Wno-ignored-pragmas" "-Wno-deprecated-declarations" "-Wno-invalid-noreturn" "-Z7" "-Xclang" "-load" "-Xclang" "/builds/worker/workspace/obj-build/build/clang-plugin/libclang-plugin.so" "-Xclang" "-add-plugin" "-Xclang" "moz-check" "-O2" "-Oy-" "-Xclang" "-fexperimental-new-pass-manager" "-DMOZILLA_CONFIG_H" "/EP" "-DWR_FRAGMENT_SHADER=1" "-E" "/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/build/swgl-7344ae344ea3c418/out/brush_yuv_image_YUV_DEBUG_OVERDRAW.c"
[task 2020-03-27T18:35:08.130Z] 18:35:08 INFO - [swgl 0.1.0] exit code: 0
[task 2020-03-27T18:35:08.130Z] 18:35:08 INFO - Compiling bookmark_sync v0.1.0 (/builds/worker/checkouts/gecko/toolkit/components/places/bookmark_sync)
[task 2020-03-27T18:35:08.131Z] 18:35:08 INFO - Running LD_LIBRARY_PATH='/builds/worker/workspace/obj-build/debug/deps:/builds/worker/fetches/rustc/lib' CARGO=/builds/worker/fetches/rustc/bin/cargo CARGO_PKG_VERSION_MINOR=1 CARGO_PKG_REPOSITORY= CARGO_PKG_NAME=bookmark_sync CARGO_PKG_VERSION_PRE= CARGO_PKG_AUTHORS='Lina Cambridge <lina@yakshaving.ninja>' CARGO_PKG_VERSION=0.1.0 CARGO_PKG_VERSION_MAJOR=0 CARGO_MANIFEST_DIR=/builds/worker/checkouts/gecko/toolkit/components/places/bookmark_sync CARGO_PKG_DESCRIPTION= CARGO_PKG_HOMEPAGE= CARGO_PKG_VERSION_PATCH=0 /builds/worker/fetches/sccache/sccache /builds/worker/fetches/rustc/bin/rustc --edition=2018 --crate-name bookmark_sync toolkit/components/places/bookmark_sync/src/lib.rs --error-format=json --json=diagnostic-rendered-ansi,artifacts --crate-type lib --emit=dep-info,metadata,link -C opt-level=1 -C panic=abort -C debuginfo=2 -C debug-assertions=on -C metadata=dddfce9e5e7b7c04 -C extra-filename=-dddfce9e5e7b7c04 --out-dir /builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps --target i686-pc-windows-msvc -C linker=/builds/worker/checkouts/gecko/build/cargo-linker -L dependency=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps -L dependency=/builds/worker/workspace/obj-build/debug/deps --extern atomic_refcell=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libatomic_refcell-29a7a3db0d094583.rmeta --extern cstr=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libcstr-fc8bec182864076a.rmeta --extern dogear=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libdogear-c32649eb8edaae0d.rmeta --extern libc=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/liblibc-e8ddf7ece08c84ad.rmeta --extern log=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/liblog-a9891d17afc27116.rmeta --extern moz_task=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libmoz_task-25a825c3272e3c54.rmeta --extern nserror=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libnserror-eefbfc69df166a28.rmeta --extern nsstring=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libnsstring-6aa7acd5fa0c9c42.rmeta --extern storage=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libstorage-0df5481982268df1.rmeta --extern storage_variant=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libstorage_variant-3e0117e0de7eb56c.rmeta --extern thin_vec=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libthin_vec-d19a913602c1139f.rmeta --extern url=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/liburl-18e1afe8a001ecde.rmeta --extern xpcom=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libxpcom-0a1b8cb66ee5b72e.rmeta -C opt-level=2 -C debuginfo=2 -C force-frame-pointers=yes -Dwarnings -C codegen-units=1
[task 2020-03-27T18:35:08.131Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/brush_yuv_image.glsl
[task 2020-03-27T18:35:08.131Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/shared.glsl
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/base.glsl
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/prim_shared.glsl
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/rect.glsl
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/render_task.glsl
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/gpu_cache.glsl
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/transform.glsl
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/brush.glsl
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] cargo:rerun-if-changed=/builds/worker/checkouts/gecko/gfx/wr/webrender/res/yuv.glsl
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] OPT_LEVEL = Some("1")
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] TARGET = Some("i686-pc-windows-msvc")
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] HOST = Some("x86_64-unknown-linux-gnu")
[task 2020-03-27T18:35:08.132Z] 18:35:08 INFO - [swgl 0.1.0] CC_i686-pc-windows-msvc = None
[task 2020-03-27T18:35:08.133Z] 18:35:08 INFO - [swgl 0.1.0] CC_i686_pc_windows_msvc = Some("/builds/worker/fetches/sccache/sccache /builds/worker/fetches/clang/bin/clang-cl -Xclang -std=gnu99 -m32")
[task 2020-03-27T18:35:08.133Z] 18:35:08 INFO - [swgl 0.1.0] CFLAGS_i686-pc-windows-msvc = None
[task 2020-03-27T18:35:08.134Z] 18:35:08 INFO - [swgl 0.1.0] CFLAGS_i686_pc_windows_msvc = Some("-Xclang -ftrivial-auto-var-init=pattern -guard:cf -DDEBUG=1 -I/builds/worker/checkouts/gecko/toolkit/library/gtest/rust -I/builds/worker/workspace/obj-build/toolkit/library/gtest/rust -I/builds/worker/workspace/obj-build/dist/include -I/builds/worker/workspace/obj-build/dist/include/nspr -I/builds/worker/workspace/obj-build/dist/include/nss -MD -FI /builds/worker/workspace/obj-build/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -fcrash-diagnostics-dir=/builds/worker/artifacts -D_HAS_EXCEPTIONS=0 -W3 -Gy -Zc:inline -arch:SSE2 -Gw -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -Z7 -Xclang -load -Xclang /builds/worker/workspace/obj-build/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -O2 -Oy- -Xclang -fexperimental-new-pass-manager -DMOZILLA_CONFIG_H")
[task 2020-03-27T18:35:08.134Z] 18:35:08 INFO - [swgl 0.1.0] CRATE_CC_NO_DEFAULTS = None
[task 2020-03-27T18:35:08.134Z] 18:35:08 INFO - [swgl 0.1.0] CARGO_CFG_TARGET_FEATURE = Some("fxsr,sse,sse2")
[task 2020-03-27T18:35:08.134Z] 18:35:08 INFO - [swgl 0.1.0] DEBUG = Some("true")
[task 2020-03-27T18:35:08.134Z] 18:35:08 INFO - [swgl 0.1.0] running: "/builds/worker/fetches/sccache/sccache" "/builds/worker/fetches/clang/bin/clang-cl" "-Xclang" "-std=gnu99" "-m32" "-nologo" "-MD" "-O1" "-Z7" "-Brepro" "-m32" "-arch:IA32" "-Xclang" "-ftrivial-auto-var-init=pattern" "-guard:cf" "-DDEBUG=1" "-I/builds/worker/checkouts/gecko/toolkit/library/gtest/rust" "-I/builds/worker/workspace/obj-build/toolkit/library/gtest/rust" "-I/builds/worker/workspace/obj-build/dist/include" "-I/builds/worker/workspace/obj-build/dist/include/nspr" "-I/builds/worker/workspace/obj-build/dist/include/nss" "-MD" "-FI" "/builds/worker/workspace/obj-build/mozilla-config.h" "-DMOZILLA_CLIENT" "-Qunused-arguments" "-fcrash-diagnostics-dir=/builds/worker/artifacts" "-D_HAS_EXCEPTIONS=0" "-W3" "-Gy" "-Zc:inline" "-arch:SSE2" "-Gw" "-Wno-unknown-pragmas" "-Wno-ignored-pragmas" "-Wno-deprecated-declarations" "-Wno-invalid-noreturn" "-Z7" "-Xclang" "-load" "-Xclang" "/builds/worker/workspace/obj-build/build/clang-plugin/libclang-plugin.so" "-Xclang" "-add-plugin" "-Xclang" "moz-check" "-O2" "-Oy-" "-Xclang" "-fexperimental-new-pass-manager" "-DMOZILLA_CONFIG_H" "/EP" "-DWR_VERTEX_SHADER=1" "-E" "/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/build/swgl-7344ae344ea3c418/out/brush_yuv_image_YUV_TEXTURE_2D.c"
[task 2020-03-27T18:35:08.134Z] 18:35:08 INFO - [swgl 0.1.0] exit code: 0
[task 2020-03-27T18:35:08.135Z] 18:35:08 INFO - [swgl 0.1.0] running: "/builds/worker/fetches/sccache/sccache" "/builds/worker/fetches/clang/bin/clang-cl" "-Xclang" "-std=gnu99" "-m32" "-nologo" "-MD" "-O1" "-Z7" "-Brepro" "-m32" "-arch:IA32" "-Xclang" "-ftrivial-auto-var-init=pattern" "-guard:cf" "-DDEBUG=1" "-I/builds/worker/checkouts/gecko/toolkit/library/gtest/rust" "-I/builds/worker/workspace/obj-build/toolkit/library/gtest/rust" "-I/builds/worker/workspace/obj-build/dist/include" "-I/builds/worker/workspace/obj-build/dist/include/nspr" "-I/builds/worker/workspace/obj-build/dist/include/nss" "-MD" "-FI" "/builds/worker/workspace/obj-build/mozilla-config.h" "-DMOZILLA_CLIENT" "-Qunused-arguments" "-fcrash-diagnostics-dir=/builds/worker/artifacts" "-D_HAS_EXCEPTIONS=0" "-W3" "-Gy" "-Zc:inline" "-arch:SSE2" "-Gw" "-Wno-unknown-pragmas" "-Wno-ignored-pragmas" "-Wno-deprecated-declarations" "-Wno-invalid-noreturn" "-Z7" "-Xclang" "-load" "-Xclang" "/builds/worker/workspace/obj-build/build/clang-plugin/libclang-plugin.so" "-Xclang" "-add-plugin" "-Xclang" "moz-check" "-O2" "-Oy-" "-Xclang" "-fexperimental-new-pass-manager" "-DMOZILLA_CONFIG_H" "/EP" "-DWR_FRAGMENT_SHADER=1" "-E" "/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/build/swgl-7344ae344ea3c418/out/brush_yuv_image_YUV_TEXTURE_2D.c"
[task 2020-03-27T18:35:08.135Z] 18:35:08 INFO - [swgl 0.1.0] exit code: 0
[task 2020-03-27T18:35:08.135Z] 18:35:08 INFO - error: unused import: ptr
[task 2020-03-27T18:35:08.135Z] 18:35:08 INFO - --> toolkit/components/bitsdownload/src/bits_interface/request.rs:29:28
[task 2020-03-27T18:35:08.136Z] 18:35:08 INFO - |
[task 2020-03-27T18:35:08.136Z] 18:35:08 INFO - 29 | use std::{cell::Cell, fmt, ptr};
[task 2020-03-27T18:35:08.136Z] 18:35:08 INFO - | ^^^
[task 2020-03-27T18:35:08.136Z] 18:35:08 INFO - |
[task 2020-03-27T18:35:08.136Z] 18:35:08 INFO - = note: -D unused-imports implied by -D warnings
[task 2020-03-27T18:35:08.136Z] 18:35:08 ERROR - error: aborting due to previous error
[task 2020-03-27T18:35:08.136Z] 18:35:08 INFO - error: could not compile bitsdownload.
[task 2020-03-27T18:35:08.136Z] 18:35:08 INFO - Caused by:
[task 2020-03-27T18:35:08.137Z] 18:35:08 INFO - process didn't exit successfully: LD_LIBRARY_PATH='/builds/worker/workspace/obj-build/debug/deps:/builds/worker/fetches/rustc/lib' CARGO=/builds/worker/fetches/rustc/bin/cargo CARGO_PKG_VERSION_MINOR=1 CARGO_PKG_REPOSITORY= CARGO_PKG_NAME=bitsdownload CARGO_PKG_VERSION_PRE= CARGO_PKG_AUTHORS='Kirk Steuber <bytesized@mozilla.com>' CARGO_PKG_VERSION=0.1.0 CARGO_PKG_VERSION_MAJOR=0 CARGO_MANIFEST_DIR=/builds/worker/checkouts/gecko/toolkit/components/bitsdownload CARGO_PKG_DESCRIPTION= CARGO_PKG_HOMEPAGE= CARGO_PKG_VERSION_PATCH=0 /builds/worker/fetches/sccache/sccache /builds/worker/fetches/rustc/bin/rustc --crate-name bitsdownload toolkit/components/bitsdownload/src/lib.rs --error-format=json --json=diagnostic-rendered-ansi,artifacts --crate-type lib --emit=dep-info,metadata,link -C opt-level=1 -C panic=abort -C debuginfo=2 -C debug-assertions=on -C metadata=94c33b04fdd0f50f -C extra-filename=-94c33b04fdd0f50f --out-dir /builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps --target i686-pc-windows-msvc -C linker=/builds/worker/checkouts/gecko/build/cargo-linker -L dependency=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps -L dependency=/builds/worker/workspace/obj-build/debug/deps --extern bits_client=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libbits_client-6fddb9f349f5ea98.rmeta --extern comedy=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libcomedy-7a5a055a1317fd89.rmeta --extern crossbeam_utils=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libcrossbeam_utils-144a59066ef35b8b.rmeta --extern failure=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libfailure-ff262e3f2fa188ea.rmeta --extern failure_derive=/builds/worker/workspace/obj-build/debug/deps/libfailure_derive-75e04c0f3d36aff6.so --extern libc=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/liblibc-e8ddf7ece08c84ad.rmeta --extern log=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/liblog-a9891d17afc27116.rmeta --extern moz_task=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libmoz_task-25a825c3272e3c54.rmeta --extern nserror=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libnserror-eefbfc69df166a28.rmeta --extern nsstring=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libnsstring-6aa7acd5fa0c9c42.rmeta --extern xpcom=/builds/worker/workspace/obj-build/i686-pc-windows-msvc/debug/deps/libxpcom-0a1b8cb66ee5b72e.rmeta -C opt-level=2 -C debuginfo=2 -C force-frame-pointers=yes -Dwarnings -C codegen-units=1 (exit code: 1)
[task 2020-03-27T18:35:08.137Z] 18:35:08 INFO - warning: build failed, waiting for other jobs to finish...

Flags: needinfo?(sonakshisaxena1)
Flags: needinfo?(sonakshisaxena1)
Depends on: 1625679
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d5efb485c09c
Remove context parameter from nsIProgressEventSink.onProgress() and nsIProgressEventSink.onStatus() r=valentin
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
You need to log in before you can comment on or make changes to this bug.