If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

internet keyword search doesn't honour search engine pref

VERIFIED DUPLICATE of bug 53171

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 53171
15 years ago
13 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
STEPS TO REPRODUCE
   1. Edit, Preferences, Navigator, Internet Search.
   2. Set "Search Using" to "Google".
   3. Make sure "Internet Keywords" are enabled under "Smart Browsing".
   4. Click OK.
   5. Type "naked girls" into the location bar and press enter.

EXPECTED RESULTS
   Google should open. [1]  

ACTUAL RESULTS
   Netscape search opens. [2]

[1] Google URI:
http://www.google.com/search?q=naked+girls&sourceid=mozilla-search&start=0&start=0

[2] Netscape search URI:
http://search.netscape.com/nscp_results.adp?query=naked%2bgirls&source=NSCPRedirect

Comment 1

15 years ago
I think it's a dupe of bug 53171, btw: with that search you'll only find
thousands of bad advertising-filled pages ;)

*** This bug has been marked as a duplicate of 53171 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
Internet Keywords has it's own prefs: keyword.URL is a URL prefix for the reqeust.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.