Closed Bug 53171 Opened 20 years ago Closed 16 years ago

Location Bar should use Search (rather than Internet Keywords)

Categories

(SeaMonkey :: Search, enhancement, P3)

enhancement

Tracking

(Not tracked)

VERIFIED WORKSFORME
Future

People

(Reporter: mozbug, Unassigned)

References

Details

(Keywords: helpwanted)

If I type some words (not an url) followed by enter, those words are searched
using Netscape's search engine. I think they should be searched with the engine
choosen in the prefs (the one used when clicking on the search button)
Gilles, is this still an issue?
Well, when Internet Keyword is disabled, I get a "www.the keywords I
searched.com" not found.
When Internet Keyword is enabled they are still looked for using Netscape search
engine.
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Netscape nav triage team: as per Matt Fisher's pre-triage recommendation, this 
bug is nsbeta1-.
Keywords: nsbeta1-
*** Bug 65287 has been marked as a duplicate of this bug. ***
4xp keyword
Keywords: 4xp
Summary: Pressing enter in location/search field should search using select search engine → [rfe] Pressing enter in location/search field should search using select search engine
See also bug 62067 (search on Alt+Enter).
*** Bug 72409 has been marked as a duplicate of this bug. ***
Marking nsbeta1- bugs as future to get off the radar.
Target Milestone: --- → Future
Since the new autocomplete has a "search using the default engine" on the last
line, I wonder if this rfe is still useful.
In build 2001050420 the autocomplete drop-down says 
Search Google for "<<search text>>", but when you hit enter, it still uses
search.netscape.com .

(Which in turn may use google, but provides a different interface.  Since I
prefer the result page returned by google, I'd like to be able to choose to use it.)

Hitting the search button does return Google's page.
(You have to hit the button twice now, one to close the drop-down, one to push
the button.)
Have a look at bug 84809. That should cover fixing this bug, I believe. You can
now search easily from the location bar without being bothered by autocomplete.
Or check out Mozilla Custom Keywords at:
http://www.mozilla.org/docs/end-user/keywords.html

---> WORKSFORME

Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
Diego: No, this bug is for configuring which search engine is used if you just
press enter in the location bar and if internet keywords are enabled.

Currently, always Netscape Search is used. This should be configurable.

--> Reopening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
*** Bug 118611 has been marked as a duplicate of this bug. ***
reassigning matt's old bugs to default owner.
Assignee: matt → sgehani
Status: REOPENED → NEW
*** Bug 65911 has been marked as a duplicate of this bug. ***
Most recent dup bug has lots of discussion (some of it confused, IIRC).
Summary: [rfe] Pressing enter in location/search field should search using select search engine → Pressing enter in location/search field should search using selected search engine
Copying the keywords from the duped bug. Please be sure to check the discussion
there too.
*** Bug 128707 has been marked as a duplicate of this bug. ***
If you want a search to occur from hitting "enter" in the location field, isn't
configuring your Internet Keyword server to point to a search engine enough?

If so, this bug would be fixed via a set of depends bugs that would change the
prefs UI (and documentation) so this would be sensible. You should read the
various  Internet Keyword bugs for a discussion about how IK and Search are very
similar in some ways.
This isn't for typing a single word - it happens when you have a space in what
you've typed.

When you first use the browser, and set your internet search engine, typing
several words with spaces between them launches the wrong search engine.
That's because your "search" was actually sent to the IK server. Search is only
used if you do control-enter or the search button or select search in the
Location drop-down menu (if I understand that part correctly).

Can you provide some steps as an example? The default IK server sends some
queries to search.netscape.com, and returns them to you, so that might be the
point of confusion.
*** Bug 128857 has been marked as a duplicate of this bug. ***
A few comments I posted on other bug about this:

For a handful of searches I tried I get exactly the same results with Netscape
Search and the search button as I do with internet keywords (hitting return). 
So if someone wants the default IK behavior, they can just select Netscape
Search as their default search engine and lose nothing.

It might be nice to also have a dependable suffix added to the query string,
e.g. '&mozilla-ik=true' so, as someone writing a search engine, you can know
you're handling an IK search and do a 302, if appropriate.  That way any search
engine can provide 1:1 keyword support if they'd like.  I'll file an new bug for
that.
adding self to cc list
How do I get things set up to use Google for all searches by default every time
I launch the browser? Making appropriate entries in user.js (and having Mozilla
pay attention) would be a satisfactory solution.

Please note that I do NOT want Netscape search or participation/interference
with the search for anything!

Bug owner: please mark this bug Major; it is not an enhancement.
Bug owner: please mark this bug for 1.0.
Also, please see related bug 131654.
You can make your Internet Keywords server preference point to a search engine.
That is what Netscape does (then they name the server keywords.netscape.com) to
confuse the real function of the feature.

(I don't work for Netscape.com (the site), so I'm speaking here as an individual)

You can click on "more info" to find out how to hack this, there is no exposed
prefs yet. Can't remember if there is a bug request to expose this pref.

I know exactly why Benjamin means because I've been there, just to clarify, he's
referring to the help page at:

http://www.mozilla.org/docs/end-user/internet-keywords.html

that you get when you go Mozilla->Preferences->Navigator->Smart
Browsing->Internet Keywords->More Information
This is really annoying.  It is even more annoying that it isn't totally clear
that this is a bug!  When typing any word into the location bar, the drop down
says "search google for ..."  but it doesn't search google.  If I have keywords
disabled, then it looks for www.<string>.com and fails (stupid).  If I have
keywords enabled, then it uses netscape search which I don't like.  Just because
there are work arounds doesn't mean that this isn't a bug.  The dropdown says
"search google" !! but it doesn't.  blatant bug.
Esteban, that isn't telling you what it's going to do when you press enter, it's
giving you another option, but I can totally understand the source of confusion.

That search option box is really whacko UI.  I can't think of anywhere besides
browsers that kind of widget is used.  The browser mindset is, of course, to
copy everybody else's bad ideas. ;)

Interested parties might like to look at bug 137026, which I promised to file
back in comment #24.  I believe it solves this bug and democratizes Mozilla a
bit more.
+ lori:
UI impact...
Blocks: 14532
*** Bug 155162 has been marked as a duplicate of this bug. ***
From bug 155162:

STEPS TO REPRODUCE
   1. Edit, Preferences, Navigator, Internet Search.
   2. Set "Search Using" to "Google".
   3. Make sure "Internet Keywords" are enabled under "Smart Browsing".
   4. Click OK.
   5. Type "naked girls" into the location bar and press enter.

EXPECTED RESULTS
   Google should open. [1]  

ACTUAL RESULTS
   Netscape search opens. [2]

[1] Google URI:
http://www.google.com/search?q=naked+girls&sourceid=mozilla-search&start=0&start=0

[2] Netscape search URI:
http://search.netscape.com/nscp_results.adp?query=naked%2bgirls&source=NSCPRedirect
Bad reproduction. It will just distract any possible coder, so we will never get
this bug fixed.
If this bug only occurs when internet keywords are enabled, this is a dup of bug
76547.
bug 76547 calls for the removal of the IK feature.  As benc@netscape.com mentioned:

>This bug is actually for the "absolutely tear it out forever" people. 

So, this doesn't seem like a dup of that one.
Summary: Pressing enter in location/search field should search using selected search engine → Pressing enter in location/search field should search using selected search engine rather than netscape search
This is a "make the UI do what it should do bug."

The steps describe selected a menu item, but then hitting enter is the same as
just typing something and hitting enter (rather than executing the selected menu
item)
Summary: Pressing enter in location/search field should search using selected search engine rather than netscape search → Pressing enter in location/search field should search using selected search engine rather than Internet Keywords
*** Bug 162981 has been marked as a duplicate of this bug. ***
*** Bug 84661 has been marked as a duplicate of this bug. ***
I've been playing around with keywords recently, and I now find them extremely
useful. But I still get caught by typing search terms in the location bar.

IMO the best solution to this is to check if the first word in the location bar
is *not* a keyword, and in that case assume it is search terms (if it's multiple
words).

That way, advanced users could still have keywords, whilst novice users could
use the location bar as they'd expect, for search terms.
Nominating nsbeta1.
Keywords: nsbeta1
*** Bug 141670 has been marked as a duplicate of this bug. ***
*** Bug 167974 has been marked as a duplicate of this bug. ***
*** Bug 174203 has been marked as a duplicate of this bug. ***
Nav triage team: nsbeta1-
Keywords: nsbeta1nsbeta1-
Depends on: 58867
->me
Assignee: sgehani → asa
oops, thought this was a bug for changing the keyword server. Seems more like a
bug for making the keyword server the same as the search engine. I don't care
about that. Sorry for the spam.
Assignee: asa → nobody
RESOLVED: wontfix.
fixed summary, fixed depends (IK and space handling would not have fixed this
bug) and blocks (fixing this would not have removed netscape-branding from Mozilla).

For end users, if you want a search to occur when you hit [enter], you can
configure Internet Keywords to point to search (in fact, Mozilla was changed
recently to do just that).

From a feature perspective, IK and search are distinct software functions, that
can be easily confused by strange configurations (lets use the same server for
requests from both features, but give them diffent domain names so the URL's
look different!).

The crucial difference is that IK is very simple, it attempts to resolve
user-typed input by asking a server where the user wanted to "go". The user to
IK server relationship is 1:1, and immediate. The remote server behavior could
be anything, server-side bookmarks, a prefered search result, a single search
result.

Search is a flexible, multi-service feature that allows users to type something
and to explore or discover meaning. Most users would need a selection of more
than one engine. Presumably the engines return content that has meaning or
useful links.

Over the years, there was a lot of confusing UI, prefs, and bugs that made this
hard to understand, but I think it makes a lot more sense now. 

If you look at the current Mozilla release (1.6f), this is our least-confusing
release to date. (If the location bar search button displayed the available
engines the way sidebar would, then this would really make sense.)

Politics aside, the underlying problem was overloaded functionality of the URL
bar. The FireFox UI splits these two functions, and for end users, it really is
the future. (If this point sounds vague, think also about how the URl bar means
both "Location" and "Go" sometimes...)

As for the Mozilla trunk, unless Internet Keywords is completely ripped out
(hence the new dependency), search will never take over the enter key. Since
this bug is actually depends on a WONTFIX, I'm going to WONTFIX this bug as well.

Many of the things you want IK to do to help you search are simply IK bugs that
need to be fixed. I've added "Internet Keywords" to the front of most of the
relevant bug summaries, for searchability.
QA Contact: claudius → benc
Summary: Pressing enter in location/search field should search using selected search engine rather than Internet Keywords → Location Bar should use Search (rather than Internet Keywords)
No longer blocks: 14532
Status: NEW → RESOLVED
Closed: 18 years ago16 years ago
Depends on: 76547
No longer depends on: 58867
Resolution: --- → WONTFIX
(In reply to comment #48)
> For end users, if you want a search to occur when you hit [enter], you can
> configure Internet Keywords to point to search (in fact, Mozilla was changed
> recently to do just that).

For posterity's sake, is there a bug# to go along with this change?  I didn't
find it in a search.  This sounds like a good solution for most people here.
Verifying that the Location bar will not use Search in place of IK.  Ben's
comments make the good argument that IK can be superset of Search, even if the
old Netscape and the new Google IK don't implement it.

There's no UI for selecting the IK provider at this point - somebody ought to
file a bug on that if it's desirable.  Then it would be easy to point Mozilla IK
at a different IK provider or a search engine (other than Google).
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
Works in SM2 as asked.
Resolution: WONTFIX → WORKSFORME
You need to log in before you can comment on or make changes to this bug.