Closed Bug 1551849 Opened 8 months ago Closed 6 months ago

[socket process] onLookupComplete - [onLookupComplete : 17] 2152398864 == 0, test_dns_offline.js

Categories

(Core :: Networking: DNS, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1559865

People

(Reporter: kershaw, Assigned: kershaw)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 obsolete file)

Why this test failure:
At [1], we expect the status to be NS_OK, but the status is NS_ERROR_OFFLINE.

Steps that caused this failure:

  1. We use ChildDNSService on parent process to do DNS resolution.
  2. At [2], we set flag to RESOLVE_OFFLINE.
  3. On socket process, we check the offline flag again at [3].
  4. The flag should not be set to RESOLVE_OFFLINE since the test set network.dns.offline-localhost to true.
  5. ResolveHost still returns NS_ERROR_OFFLINE since the flag is already set to RESOLVE_OFFLINE at step 2.

[1] https://searchfox.org/mozilla-central/rev/116bd975c30746ddefc3d20e6947d1871469354f/netwerk/test/unit/test_dns_offline.js#17
[2] https://searchfox.org/mozilla-central/rev/116bd975c30746ddefc3d20e6947d1871469354f/netwerk/dns/ChildDNSService.cpp#82
[3] https://searchfox.org/mozilla-central/rev/116bd975c30746ddefc3d20e6947d1871469354f/netwerk/dns/nsDNSService2.cpp#824-827
[4] https://searchfox.org/mozilla-central/rev/116bd975c30746ddefc3d20e6947d1871469354f/netwerk/test/unit/test_dns_offline.js#52

Attachment #9065044 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1559865
You need to log in before you can comment on or make changes to this bug.