Closed Bug 1551947 Opened 5 months ago Closed 4 months ago

[about:addons] Hide private browsing setting if it cannot be changed

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1557792
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- disabled
firefox68 --- affected
firefox69 --- affected

People

(Reporter: mstriemer, Assigned: mstriemer)

References

(Blocks 1 open bug)

Details

Attachments

(1 obsolete file)

Themes can always run in private windows, so changing the pref doesn't do anything. The private browsing settings should be hidden for extension-based themes.

(In reply to Mark Striemer [:mstriemer] from comment #0)

Themes can always run in private windows, so changing the pref doesn't do anything. The private browsing settings should be hidden for extension-based themes.

I just briefly tried locally and the private browsing settings isn't visible for me on themes, and so I was wondering:
is there anything still missing to close this issue? (e.g. do we have a test case for this scenario that runs on the HTML about:addons?).

Flags: needinfo?(mstriemer)

It works. I've updated toolkit/mozapps/extensions/test/browser/browser_webext_incognito.js to test both XUL and HTML: https://phabricator.services.mozilla.com/D34277

Searchfox hasn't been updated yet, but the logic is equivalent to https://searchfox.org/mozilla-central/rev/153172de0c5bfca31ef861bd8fc0995f44cada6a/toolkit/mozapps/extensions/test/browser/browser_webext_incognito.js#375-390

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(mstriemer)
Resolution: --- → WORKSFORME

The description wasn't clear, this is for dynamic themes that show up in the extensions tab, like Firefox Color. They're always allowed in private windows.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: Don't allow changing private browsing setting for (extension) themes → Don't allow changing private browsing setting for dynamic themes

After discussing with Luca, this isn't related to dynamic themes but privileged extensions. The PERM_CAN_CHANGE_PRIVATEBROWSING_ACCESS permission can be used to check if the setting should be shown [1].

[1] https://searchfox.org/mozilla-central/rev/0da35261b6789eec65476dbdd4913df6e235af6d/toolkit/mozapps/extensions/content/extensions.js#2924

Summary: Don't allow changing private browsing setting for dynamic themes → [about:addons] Hide private browsing setting if it cannot be changed

This is related to the test that I mentioned. I added two TODOs that both reference bug 1557792, but one of them could be referencing this one instead.

Basically, this bug can be resolved when the following TODO is addressed: https://searchfox.org/mozilla-central/rev/227f5329f75bd8b16c6b146a7414598a420260cb/toolkit/mozapps/extensions/test/browser/browser_webext_incognito.js#126

See Also: → 1557792

This is fixed by bug 1557792 along with the related message.

Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1557792
Attachment #9071911 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.