Closed Bug 1552724 Opened 1 year ago Closed 1 year ago

[Feature Request] Add complete disconnection as throttle speed option

Categories

(DevTools :: Netmonitor, enhancement)

66 Branch
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1029203

People

(Reporter: firefox, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

  1. load a page
  2. open the developer pane
  3. go to "network"
  4. click on "No throttling"

Actual results:

The listed options include

  • Good 3G
  • regular 3G
  • DSL
  • Wi Fi
    etc

Expected results:

One of the included options should be disconnection. A throttle down to 0Mb/s.

Use case:

I went to this page: http://www.donkeyvotie.org/cheatsheet.php?State=BallotOrderNSW
It presents a click and drag list which allows you to plan how you will order candidates before an election, then you print out the sheet and take it to the ballot place.

Obviously I don't want any information about my user input to leave my computer. The site probably won't upload anything, but I want to be absolute sure. So I want to disconnect that tab from the internet.
But I still want to connect online and open other browser tabs to research each party when making my choice.

So what I want is an option to disconnect just one page.

The existing throttle functionality seems the best avenue. Of course this option only makes sense after a page has loaded.

I think other use cases are conceivable, like if you're making a chat application and you want to test whether it can detect connectivity issues and display "your device is disonnected" prior to the user trying to send something.

Status: UNCONFIRMED → RESOLVED
Type: defect → enhancement
Closed: 1 year ago
Component: Untriaged → Netmonitor
Product: Firefox → DevTools
Resolution: --- → DUPLICATE
Duplicate of bug: 1029203
You need to log in before you can comment on or make changes to this bug.