"clear cache" does not clear downloaded entires

RESOLVED WORKSFORME

Status

()

Core
Networking: Cache
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Steve Brecht, Assigned: gordon)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Set my disk cache to 5 Meg (from 10 Meg) yesterday amd at the same time cleared
the disk cache. I have been in and out of mozilla numerous times since.  Just
checked my disk cache and it had 71.8 Meg of files.  After I cleared the cache
again it went down to 67.6 Meg.  It appears to be possibly related to downloads
since a number of the files remaining are multiple-meg ZIP and Executables I
have downloaded in the last few days.  (and I have cleared all files from the
Download Manager)  Possible that when "Clear Cache" is selected the cache
directory is completely emptied?  This would have to be connected to any files
currently being downloaded I guess.  Or check all cache files against the cache
index and remove any that aren't indexed.
Build ID ?

-> Cache
Assignee: Matti → gordon
Component: Browser-General → Networking: Cache
QA Contact: imajes-qa → tever
(Reporter)

Comment 2

16 years ago
This is happening for me on Mozilla 1.1 alpha

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 159794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
I'm not sure this bug is a duplicate... the files I have left over are not rdf
files... they are randomly named cache files of varying sizes.  It's like they
slipped through the indexing process.  Even when I clear downloads and clear
cache I still have currently 50.1 megs of files in my cache folder when I have a
cache limit of 10 Meg and 0 files in my download manager.

Please reconsider... I will send my current cache if desired.

Comment 5

16 years ago
I think this sounds more like a duplicate of 138117
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 138117 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
please re-open if you disagree
Status: RESOLVED → VERIFIED

Comment 8

15 years ago
This problem sounds related to, but not the same as bug.

That bug focuses on the behavior of download manager putting things into cache.
This bug seems to focus more on the fact that you can't use the clear cache
button to remove them.

Please try Mozilla 1.3f and see if still happens.
Status: VERIFIED → UNCONFIRMED
QA Contact: tever → cacheqa
Resolution: DUPLICATE → ---
Summary: Cache not clearing properly... → "clear cache" does not clear downloaded entires

Comment 9

14 years ago
(In reply to comment #8)
> This bug seems to focus more on the fact that you can't use the clear cache
> button to remove them.

WFM. Tested with 1.4.1 and 1.7b on WinNT. If you try "Clear Cache", all files
will be deleted (in fact, the whole cache directory is erased and newly created!).

Comment 10

14 years ago
wfm 2004031509
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 11

14 years ago
There was probably some cache change where we gave up on removing most files and
reseting the cache index files... I'm going to look for a fixing bug and dupe to
it, in part b/c this still doesn't solve the downloads go into cache behavior.
You need to log in before you can comment on or make changes to this bug.