Closed Bug 1553231 Opened 3 years ago Closed 2 months ago

Port bug 1436086: Make all groups of buttons within our toolbars keyboard accessible and reachable via tab and shift+tab

Categories

(Thunderbird :: Upstream Synchronization, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1776192

People

(Reporter: Paenglab, Assigned: aleca)

References

(Depends on 1 open bug)

Details

(Keywords: access)

It would be great if we could port bug 1436086 to TB. We have a lot more buttons on our toolbars which would be great if they would be accessible through keyboard.

The new appmenu is more accessible by keyboard. For example, once it is open you can use arrow keys to navigate it. So it would make a lot of sense to have an easy way to open it by keyboard. Minimally, that should include by tab/shift+tab like other toolbar buttons. It also might make sense to give it its own keyboard shortcut. (That would probably be a separate bug.)

I've been trying to implement this but there's a technical limitation due to our toolbar implementation being different from what FF is using.
I think we should follow the FF implementation and update our toolbars accordingly and inherit all the benefits that come with it.
Thoughts?

Flags: needinfo?(richard.marti)
Flags: needinfo?(mkmelin+mozilla)

I can't say if the FX toolbar implementation is an easy conversion. Different to FX, we have toolbars on multiple places like main toolbar, chat toolbar, Lightning toolbars on the main window and in the AB, the composer and the event dialog. This could make the FX customize tab implementation a bit tricky.

I think, if we can convert it, it would make this bug and future ports easier. And if it's possible to convert it, we should do it.

Flags: needinfo?(richard.marti)
Flags: needinfo?(mkmelin+mozilla)
Depends on: 1571408
Depends on: 1119948
No longer depends on: 1571408
Component: Toolbars and Tabs → Upstream Synchronization

Henry, fyi wrt general accessibility of our app.
Ryan, ni just fyi. Maybe worth trying this for 114. I don't know how involved this is.

It's worth noting that new AB doesn't have any actions in the main menu, so most of the following actions from AB toolbar are currently not reachable in any way for keyboard-dependent users incl. the blind:

  • New Address book (bug 1751282)
  • New Contact (Ctrl+N not implemented, bug 1751288; clumsily available via File > New > Address Book Contact)
  • New List (bug 1751282)
  • Import
Severity: normal → --
Flags: needinfo?(ryan)
Flags: needinfo?(henry)
Keywords: access
Priority: -- → P3

(In reply to Thomas D. (:thomas8) from comment #4)

Henry, fyi wrt general accessibility of our app.

Yes, this is bad. Unfortunately I don't think I'll be able to handle this before 102. I commented on bug 1751282 about what we can do with your specific examples.

Flags: needinfo?(henry)

Given a bit of time has passed since this bug was opened, a better approach for the next release might be to replace these xul:toolbar elements with our own custom widget that manages focus. And maybe port the new spaces toolbar to use it as well.

Flags: needinfo?(ryan)

(In reply to Henry Wilkes [:henry] from comment #6)

Given a bit of time has passed since this bug was opened, a better approach for the next release might be to replace these xul:toolbar elements with our own custom widget that manages focus. And maybe port the new spaces toolbar to use it as well.

If we're not going to bring keyboard controls to xul:toolbar we might want to close this in favour of bug 1776192

See Also: → 1776192

I'm okay with this.
We should move away from XUL anyway and a pure HTML toolbar is the way to go for 114.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1776192
You need to log in before you can comment on or make changes to this bug.