[GTK/GFX] Combobox Rollup called when it shouldn't be

VERIFIED FIXED

Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: pollmann, Assigned: pavlov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

20 years ago
"GFX Combobox doesn't work on GTK"

This is a GTK specific bug (possibly Mac too).  When a combobox is dropped down,
then clicked on, the click event is not sent to the frame.  Thus, the selection
isn't updated, and onchange events aren't sent out.

This seems rooted in the code here, so I'm giving it to Pavlov even though it
may really be somebody else's:
widget/src/gtk/nsWidget::OnButtonPresSignal()
...
if (rollupWidget != thisWidget...
...

In this case, even when I click on the rollup widget, 'thisWidget' and
'rollupWidget' have different values, and the Rollup handler is called.

In a random fit of desperation, I remembered Pav saying something about removing
the CaptureMouse() call on Friday, so I unleashed nedit on
layout/html/forms/src/nsListControlFrame::CaptureMouseEvents() and axed the code
Rods marked "// XXX this is temp code" which calls the widget's CaptureMouse().
It does allow clicks on other places within the app to roll up the combo.
However, as with most desperate acts, it did not have the intended effect.  The
click was still not making it past Pav's impenetrable "if rollup != this".

Can you fix this?
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
Assignee

Comment 1

20 years ago
checked in fix
Reporter

Comment 2

20 years ago
*** Bug 15699 has been marked as a duplicate of this bug. ***

Comment 3

20 years ago
If there's an easy way to verify this, please let me know so that I may do so...
Reporter

Comment 4

20 years ago
The duplicate bug has a better description of the problem.

On Linux, go to any page with a combobox.  Click on it to select an option.  If
the text area of the option appears to have been updated normally that the bug
was fixed.  Before this bug was fixed, clicking on the combobox didn't update
the text or selected options, so comboboxes were very broken.

Thanks!

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 5

20 years ago
Somebody please slap me for not looking at the duplicate first. :)
Using the 1999110908 build and the handy test case at the URL above (thanks very
much), this is verified fixed under Red Hat Linux 6. Marking as such.
You need to log in before you can comment on or make changes to this bug.