Closed Bug 1554458 Opened 8 months ago Closed 6 months ago

"View Saved Logins" and "Use a Securely Generated Password" can be truncated

Categories

(Toolkit :: Password Manager, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: flod, Assigned: MattN)

References

Details

(Keywords: regression, Whiteboard: [passwords:fill-ui] [passwords:generation] [skyline])

Attachments

(6 files)

Attached image immagine.png

In Italian this is translated as "Visualizza credenziali salvate", and most of the label is completely cut off.

Blocks: 433238

Hmm… would wrapping be acceptable here? Is that a narrow <input>?

Blocks: 1189618
No longer blocks: 433238

From a localization point of view, wrapping would definitely work.

The input in question is about 120px wide, not exactly narrow I'd say.

Priority: -- → P2
Whiteboard: [passwords:fill-ui]

This also affects the even longer password generation string too. We have talked about increasing the min-width… not sure if we can easily make it locale-specific.

Unfortunately our min-width for autocomplete is based upon the style of the first row but the footer and password generation aren't always the first row so we will probably apply a blanket min-width for all login autocomplete meaning we may be wider than necessary in some cases.

Blocks: 1565696
Summary: "View Saved Logins" is cut on localized builds → "View Saved Logins" and "Use a Securely Generated Password" can be truncated
Whiteboard: [passwords:fill-ui] → [passwords:fill-ui] [passwords:generation] [skyline]
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED

Regular login popups go to 200px whereas a popup containing password generation goes to 250px.

Attachment #9081062 - Attachment description: Bug 1554458 - Increase min-width for login autocomplete popups. r=sfoster,Pike → Bug 1554458 - Increase min-width for login autocomplete popups. r=sfoster!
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/ccf54bf91af8
Increase min-width for login autocomplete popups. r=sfoster,flod
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Verified - Fixed on latest Nightly 70.0a1 (2019-07-29) (64 bit) on Windows 10, MacOS 10.14 and Ubuntu 18.04.
Checked the strings on an Italian build. Check the attached screenshot for reference.

Waiting for potential uplift request.

Reminder to myself to request uplift if there are no regressions in the next little while.

Flags: needinfo?(MattN+bmo)

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Hi Matt, is this ready for an approval request?

(In reply to Timea Babos [on PTO until 19th Aug - ni? Brindusa Tot] from comment #8)

Verified - Fixed on latest Nightly 70.0a1 (2019-07-29) (64 bit) on Windows 10, MacOS 10.14 and Ubuntu 18.04.
Checked the strings on an Italian build. Check the attached screenshot for reference.

Attachment 9081608 [details] isn't a valid confirmation since the field was already wide enough to show the footer text. You need to test on a narrower username or password field.

Comment on attachment 9081062 [details]
Bug 1554458 - Increase min-width for login autocomplete popups. r=sfoster!

Beta/Release Uplift Approval Request

  • User impact if declined: Text in login autocomplete popups can be truncated enough that the text isn't understandable or too much of the username gets cut off. This is especially noticeable with the new footer added in Fx67. See attachment 9067596 [details].
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Baked for 15 days with nobody noticing.
  • String changes made/needed: None
Flags: needinfo?(MattN+bmo)
Attachment #9081062 - Flags: approval-mozilla-beta?

Comment on attachment 9081062 [details]
Bug 1554458 - Increase min-width for login autocomplete popups. r=sfoster!

Fixes possible truncation in the login autocomplete popups. Approved for 69.0b14.

Attachment #9081062 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I've used v 70.0a1 20190727213541 for bad and v 70.0a1 20190816094815 for good, comparing the results(https://bugzilla.mozilla.org/attachment.cgi?id=9086055), it looks expectantly better.
Verified the above on Ubuntu 16.04/Mac 10.13 / Win 10 using latest Nightly 70 2019-08-16 and latest Beta 69.0b14 2019-08-15.

Also, gave it a run on the de locale, since it is one of the locales that usually has long labels, and for de locale, the 200px regular login (comment 5) doesn't do it: it is still truncated (see https://bugzilla.mozilla.org/attachment.cgi?id=9086056). For the first part verification, I will mark this issues as verified and tagging :mattN to confirm that the comment 5 pop-up sizes take in account the long labelled locales.

Status: RESOLVED → VERIFIED
Flags: needinfo?(MattN+bmo)

(In reply to Adrian Florinescu [:adrian_sv] from comment #18)

Also, gave it a run on the de locale, since it is one of the locales that usually has long labels, and for de locale, the 200px regular login (comment 5) doesn't do it: it is still truncated (see https://bugzilla.mozilla.org/attachment.cgi?id=9086056). For the first part verification, I will mark this issues as verified and tagging :mattN to confirm that the comment 5 pop-up sizes take in account the long labelled locales.

We knew it wouldn't be perfect for narrow fields but UX's view is that the user will see the full string on wider fields and will learn what the footer does and therefore it's okay if the text is truncated on narrow fields.

Flags: needinfo?(MattN+bmo)
Duplicate of this bug: 1561673
You need to log in before you can comment on or make changes to this bug.