Closed Bug 1554474 Opened 6 months ago Closed 6 months ago

Crash in [@ nsFrameLoader::TryRemoteBrowserInternal]

Categories

(Core :: Graphics, defect, critical)

68 Branch
Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1554073
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: calixte, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-9a018138-1ebd-4b4f-a630-37be30190525.

Top 10 frames of crashing thread:

0 xul.dll bool nsFrameLoader::TryRemoteBrowserInternal dom/base/nsFrameLoader.cpp:2608
1 xul.dll nsFrameLoader::TryRemoteBrowser dom/base/nsFrameLoader.cpp:2761
2 xul.dll nsFrameLoader::ShowRemoteFrame dom/base/nsFrameLoader.cpp:1023
3 xul.dll nsFrameLoader::Show dom/base/nsFrameLoader.cpp:890
4 xul.dll nsSubDocumentFrame::ShowViewer layout/generic/nsSubDocumentFrame.cpp:201
5 xul.dll nsresult AsyncFrameInit::Run layout/generic/nsSubDocumentFrame.cpp:90
6 xul.dll nsContentUtils::RemoveScriptBlocker dom/base/nsContentUtils.cpp:5172
7 xul.dll mozilla::dom::Document::EndUpdate dom/base/Document.cpp:4960
8 xul.dll nsINode::ReplaceOrInsertBefore dom/base/nsINode.cpp:2374
9 xul.dll mozilla::dom::Node_Binding::appendChild dom/bindings/NodeBinding.cpp:1018

There are 6 crashes (from 6 installations) in nightly 69 starting with buildid 20190525093913. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1525720.

[1] https://hg.mozilla.org/mozilla-central/rev?node=a902acfbc868

Flags: needinfo?(rhunt)
QA Whiteboard: [qa-regression-triage]

This is a duplicate of bug 1554073. The method name was just renamed to TryRemoteBrowserInternal, but the crashes are all on the same line with the same reason.

Status: NEW → RESOLVED
Closed: 6 months ago
Flags: needinfo?(rhunt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1554073
You need to log in before you can comment on or make changes to this bug.