Closed Bug 1555302 Opened 2 years ago Closed 2 years ago

nsStandardURL::Resolve should not treat tel: URIs as relative

Categories

(Core :: Networking, defect, P1)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- unaffected
firefox69 + fixed

People

(Reporter: calixte, Assigned: valentin)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression, Whiteboard: [necko-triaged])

Crash Data

Attachments

(1 file)

This bug is for crash report bp-a3958638-574d-438d-861a-dc09e0190529.

Top 10 frames of crashing thread:

0 xul.dll NS_NewURI netwerk/base/nsNetUtil.cpp:1874
1 xul.dll NS_NewURI netwerk/base/nsNetUtil.cpp:1632
2 xul.dll NS_NewURI netwerk/base/nsNetUtil.cpp:1658
3 xul.dll nsContentUtils::NewURIWithDocumentCharset dom/base/nsContentUtils.cpp:2859
4 xul.dll nsGenericHTMLElement::GetURIAttr dom/html/nsGenericHTMLElement.cpp:1435
5 xul.dll mozilla::dom::HTMLAnchorElement::GetHrefURI dom/html/HTMLAnchorElement.cpp:242
6 xul.dll mozilla::dom::Link::LinkState dom/base/Link.cpp:372
7 xul.dll mozilla::dom::Document::FlushPendingLinkUpdatesFromRunnable dom/base/Document.cpp:9962
8 xul.dll nsresult mozilla::detail::RunnableMethodImpl<mozilla::dom::Document*, void  xpcom/threads/nsThreadUtils.h:1177
9 xul.dll nsresult IdleRunnableWrapper::Run xpcom/threads/nsThreadUtils.cpp:331

There are 11 crashes (from 4 installations) in nightly 69 starting with buildid 20190528214841. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1536744.
The moz_cras_reason is always: MOZ_RELEASE_ASSERT(newScheme == scheme)
I can reliably reproduce it with url: https://phonebook.mozilla.org/?search/anne
But it's ok in replacing "anne" by "calixte" or "valentin".

[1] https://hg.mozilla.org/mozilla-central/rev?node=d418e0d5594a

Flags: needinfo?(valentin.gosu)
Duplicate of this bug: 1555309
Assignee: nobody → valentin.gosu
Flags: needinfo?(valentin.gosu)
Priority: -- → P1
Whiteboard: [necko-triaged]
Summary: Crash in [@ NS_NewURI] → nsStandardURL::Resolve should not treat tel: URIs as relative
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/32f9907bf1f7
Ensure that nsStandardURL::Resolve() doesn't parse URLs with a different scheme as relative r=mayhemer
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e3ec1f61c75e
Backed out changeset 32f9907bf1f7 for causing permafailures in  dom/url/tests/test_url.html CLOSED TREE
Duplicate of this bug: 1555435
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2c154027b928
Ensure that nsStandardURL::Resolve() doesn't parse URLs with a different scheme as relative r=mayhemer
Flags: needinfo?(valentin.gosu)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.