Closed Bug 155538 Opened 22 years ago Closed 22 years ago

Mailnews window inherits colours from html attachments

Categories

(SeaMonkey :: MailNews: Message Display, defect)

PowerPC
Mac System 9.x
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 31052

People

(Reporter: IDontUseMozillaAnyMore, Assigned: sspitzer)

Details

If you recieve an HTML attachment with non-defauls colours then the mailnews
window uses those colours to show the body of the mail message. Steps to reproduce.

1) Create an HTML file with say a background colour of black and a text colour
   of white.
2) Email this file to yourself. Enter some text in the body of the message.

What's wrong:

When you recieve this message the body text for the message (not the attachment)
will be white on black.

What should happend:

The attachment should be displayed using it's colours but the mail message
should show in the standard mailnews window colours. This is actually what
happens in 4.x.

Seen in all builds upto and including 2002061103 (1.1a) on Mac, sorry can't
comment on other platforms.
Duplicate of bug 57666 ("HTML Attach: Attachment colors are used for mail body")
which is itself a duplicate.

*** This bug has been marked as a duplicate of 31052 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
QA Contact: olgam → trix
verified dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.