Closed Bug 1555828 Opened 7 months ago Closed 6 months ago

Incorrect redirect_uri in Sign in

Categories

(Webtools :: Pontoon, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: olafura, Assigned: mathjazz)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36

Steps to reproduce:

Following the instructions on https://mozilla-pontoon.readthedocs.io/en/latest/admin/deployment.html

When I try to sign in to my account I get redirected to:
https://stable.dev.lcip.org/authorization?scope=profile%3Aemail%20profile%3Adisplay_name%20profile%3Auid%20profile%3Auid%20profile%3Aemail%20profile%3Adisplay_name&state=iAuU4IjeQ7tj&redirect_uri=http%3A%2F%2Flocalhost%3A8014%2Faccounts%2Ffxa%2Flogin%2Fcallback%2F&response_type=code&client_id=2651b9211a44b7b2

Actual results:

I get:
Bad Request
Incorrect redirect_uri

Expected results:

I should be logged in, or allowed to be logged in.

That's likely because you use the default login method (Firefox Accounts), which is not available to 3rd parties. For now, you can circumvent the problem by using DJANGO_LOGIN.

I'll update the deployment docs.

We should also change the default login method as part of bug 1558484.

Assignee: nobody → m
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
See Also: → 1558484
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.