Closed Bug 1556437 Opened 1 year ago Closed 10 months ago

Crash in [@ org.xmlpull.v1.XmlPullParserException: at android.graphics.drawable.Drawable.createFromXmlInner(Drawable.java)]

Categories

(Firefox for Android :: General, defect, P2)

Firefox 68
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- verified
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: marcia, Assigned: petru)

References

Details

(Keywords: crash, regression, Whiteboard: [fennec68.1])

Crash Data

Attachments

(1 file)

This bug is for crash report bp-0f9b8484-cb16-4f6e-aa3d-e746e0190515.

Crash seen while reviewing 68.0b5 crashes. Crashes go back to at least 20190510095015 when Fennec was in nightly: https://bit.ly/2IdLX5Z. Currently in beta 5 this is in the top 20 list of crashes.

Comments and correlations don't look particularly useful. No real pattern in the few URLs. APIs range from 16-19.

Java stack trace:

org.xmlpull.v1.XmlPullParserException: Binary XML file line #1: invalid drawable tag vector
	at android.graphics.drawable.Drawable.createFromXmlInner(Drawable.java:986)
	at android.graphics.drawable.Drawable.createFromXml(Drawable.java:930)
	at android.content.res.Resources.loadDrawable(Resources.java:3436)
	at android.content.res.Resources.getDrawable(Resources.java:1917)
	at org.mozilla.gecko.FindInPageBar.updateFindTextError(FindInPageBar.java:166)
	at org.mozilla.gecko.FindInPageBar.onMatchesCountResult(FindInPageBar.java:150)
	at org.mozilla.gecko.FindInPageBar.handleMessage(FindInPageBar.java:237)
	at org.mozilla.gecko.EventDispatcher$3.run(EventDispatcher.java:368)
	at android.os.Handler.handleCallback(Handler.java:733)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:146)
	at android.app.ActivityThread.main(ActivityThread.java:5602)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:515)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1283)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1099)
	at dalvik.system.NativeStart.main(Native Method)

Some of the crash comments mention crashing when searching, specifically on wikipedia.

I tried to reproduce this issue following some scenarios on Wikipedia but I wasn't able to find the crash.

  • searching from the page search bar;
  • searching on Wikipedia the copied text;
  • making Wikipedia the search engine;
  • using the search engine icon;
  • Selecting an option from the search bar of Wikipedia;

Devices:

  • Samsung Galaxy S8 (Android 9);
  • Motorola Moto G6 (Android 8);
  • Nokia 6 (Android 7.1.1).

Builds:

  • Nightly 68.0a1 (2019-06-05);
  • Beta 68.0b5;
  • Beta 68.0b7.

I'll keep an eye on my daily work to see if I can track the problem.

Triaging as P2 for now. Will keep an eye on this as we continue through the 68 cycle.

Priority: -- → P2

This crash is continuing to be visible on 68 release. No useful comments. Samsung and asus devices are the top crashing devices, running older APIs 17-19.

I hit this crash too on a Samsung Tab running Android 4.2.2.
I was browsing likes on a Facebook profile when it happened.
bp-ba5dc5a9-a65c-4e3a-acae-acccb0190712
bp-60ae357d-f421-40bf-be4b-aabe60190712

Hi,

I also get this crash ( https://crash-stats.mozilla.org/report/index/38596be2-2f33-41d9-8989-a3f660190712 and others) on asus memopad hd7 ME173X, android 4.2.2

If it help, I can reliably trigger the crash if I search inside the page (for any page, including about:crashes or others) for a sequence of character not present (such as 'iii' ) , it crashes at the third character.

Actually, I must amend my previous statement, it crashes at the first character not found when I search inside a page.

I can also trigger a freeze with the same steps on ff 68 on android 4.4 (lg G tab 8.3) but I didn't manage to get a crash log.

No issue on android 7.0 (motoG 3) and 9.0 (oneplus 3t).

let me know which information/test can help you.

regards

Hardware: Unspecified → ARM

Hi,

I managed to narrow the crash between nighty 2019-04-24-09-53-59-mozilla-central-android-api-16 (last good) and nighly 2019-04-25-09-46-25-mozilla-central-android-api-16 (first bad)

For an unkwown reason, I don't get the crash reporter before a nightly in may, it just crash.

Asus memopad hd7 me173x , android 4.2

Bug 1345104 is in that range and looks like a good candidate given the STR from comment 6.

Flags: needinfo?(petru.lingurar)
Regressions: 1345104
Flags: needinfo?(andrei.teslovan)
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Flags: needinfo?(petru.lingurar)

Thanks Mjules, indeed, this is trivial to reproduce with your STRs.

Flags: needinfo?(andrei.teslovan)

VectorDrawableCompat allows backwards compatibility up to API 14.

Keywords: checkin-needed

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dfdb610b82b9
Use VectorDrawableCompat to load the error svg; r=AndreiLazar

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Flags: qe-verify+

Petru, we'll want to uplift your crash fix to Fennec ESR 68.1 and Beta 69.

Flags: needinfo?(petru.lingurar)

I have tested the issue on the latest Nightly build 70.0a1 (2019-07-22) using an LG G3 (Android 4.4.2) and the issue no longer occurs, I will mark it accordingly.

Flags: qe-verify+

Comment on attachment 9078393 [details]
Bug 1556437 - Use VectorDrawableCompat to load the error svg; r?AndreiLazar

Beta/Release Uplift Approval Request

  • User impact if declined: Crash on Android 16-19 when searching in page for nonexistent term.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
    • On an Android device with API version 16-19
    • open Find in page
    • enter a text that is not present in the current page
    • confirm the error drawable is shown in the searchbox and the app does not crash
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small change, verified by QA.
  • String changes made/needed:

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Crash on Android 16-19 when searching in page for nonexistent term.
  • User impact if declined: Crash on Android 16-19 when searching in page for nonexistent term.
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small change, verified by QA.
  • String or UUID changes made by this patch:
Flags: needinfo?(petru.lingurar)
Attachment #9078393 - Flags: approval-mozilla-esr68?
Attachment #9078393 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9078393 [details]
Bug 1556437 - Use VectorDrawableCompat to load the error svg; r?AndreiLazar

Fixes a frequent Fennec crash. Approved for 68.1b3.

Attachment #9078393 - Flags: approval-mozilla-esr68?
Attachment #9078393 - Flags: approval-mozilla-esr68+
Attachment #9078393 - Flags: approval-mozilla-beta?
Attachment #9078393 - Flags: approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Hi,

Bug fixed with today nightly on my memopad, android 4.2

Thanks all
Regards

Hi! I tested this, with the steps provided in Comment 6, on ESR 68.1b3, Beta 69.0b8 with Prestigio Grace X5 (Android 4.4.2) and the browser did not crash. I will mark this issue as verified on Firefox 68 and Firefox 69.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Whiteboard: [fennec68.1]

Is this fix going to make it into Android Google Play Store 68.1.x releases (it is in ESR 68.x) or will it only be available when 69 is released? Thanks.

This was fixed in 68.1.

You need to log in before you can comment on or make changes to this bug.