Closed Bug 1557239 Opened 1 year ago Closed 1 year ago

Regression: Background png shows fuzzy artefacts/glitches

Categories

(Core :: ImageLib, defect, P2)

defect

Tracking

()

VERIFIED DUPLICATE of bug 1555934
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: nachtigall, Assigned: aosmond)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [gfx-noted])

Attachments

(2 files)

Attached image png icon artefacts

According to mozregression bug 1255108 and bug 1255106 introduced this png display artefact as shown in the screenshot.

STR:

  1. Install brief from https://addons.mozilla.org/en-US/firefox/addon/brief/
  2. Go to any rss feed like https://planet.mozilla.org/
  3. In the page action bar (in awesome bar) click on the RSS feed to subscribe
  4. In browser action bar click on brief RSS icon
  5. In Brief click on "all items"
  6. Then switch to "View headlines" in brief (which is on the top right). Looks like a hamburger menu

ER:
There should be no graphic glitches

AR:
7. On the right the arrow png icon has an artefact recently.

I tried to create a minimal working example at https://codepen.io/nachtigall/full/zQQWYB but was no really able to get all the relevant html/css in it to reproduce it, but maybe it helps as a skeleton...

fwiw, I run this:

$ mozregression --bad=2019-06-05 --good=2017-05-20 --addon brief-2.6.0b2-fx.xpi --arg="https://planet.mozilla.org/"
...
86:48.16 INFO: Last good revision: ca4f3b736dd6cbe6e1b195a4800b009ea55bf91d
86:48.16 INFO: First bad revision: 44fa715640dd2a4d06014e6d5fdda63c52707188
86:48.16 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ca4f3b736dd6cbe6e1b195a4800b009ea55bf91d&tochange=44fa715640dd2a4d06014e6d5fdda63c52707188

Blocks: 1255108
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(aosmond)
Regressed by: 1255108

Looking at the two pushlog bugs I think that rather Bug 1255106 introduced this because it does more stuff with filters and png "things".

No longer blocks: 1255108
Regressed by: 1255106
No longer regressed by: 1255108
Priority: -- → P3
Whiteboard: [gfx-noted]

Changing the priority to p2 as the bug is tracked by a release manager for the current nightly.
See What Do You Triage for more information

Priority: P3 → P2

Please reopen if you still see this on recent nightlies, 20190611213517 or newer. Regardless, please attach your about:support if you get a chance, because it now includes the color management profiles, which will be useful to me reproducing in the future. Thanks!

Assignee: nobody → aosmond
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(aosmond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1555934

I can verify that the bug is fixed now. Thanks, Andrew! I also attached my about:support for future cases as I understood. Happy hacking :)

Status: RESOLVED → VERIFIED

(In reply to Jens from comment #5)

I can verify that the bug is fixed now. Thanks, Andrew! I also attached my about:support for future cases as I understood. Happy hacking :)

Thanks! I extracted the profile and will add it to the test suite.

You need to log in before you can comment on or make changes to this bug.