Closed Bug 1557961 Opened 6 months ago Closed 6 months ago

tab & url text blurs when mouse enters tab under cairo

Categories

(Core :: Graphics: Text, defect)

67 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bugzilla.hundreAd, Unassigned)

References

Details

Attachments

(3 files)

Attached video blur.mp4

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Steps to reproduce:

  • go to about:config
  • remove skia from gfx.content.azure.backends
  • restart firefox

Actual results:

when there is more than a single tab, the text in the tab and url blurs briefly when mouse cursor enters tab, then returns to normal (see attached video)

Expected results:

no blur
(why would a blur be called for the text in the first place?)

Hi hundreAd,

I was unable to reproduce the issue using the following firefox versions:

  • firefox-58.0a1.en
  • firefox latest Nightly: 69.0a1

Since the version you report is from 2017, I suggest downloading the latest Firefox Nightly and check if you still experience the same problem. You can download it from here: https://nightly.mozilla.org/.

I noticed that you may be using any custom theme, can you also test if the issue is reproducible by using the default firefox themes?

If you still have the issue please create a new profile, you have the steps here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Also, you could test if the issue is reproducible in safe mode, here is a link that can help you:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

If there is any other info you can provide to help us figure out how we can can reproduce the issue please share them. Thanks for your contribution!

Flags: needinfo?(bugzilla.hundreAd)

(In reply to Virginia Balducci from comment #2)

  • bug exists from first bad build (2017-09-29) up to and including latest branch (67.0.2), and probably beyond.
  • pristine firefox installation, everything is on defaults except for the STR. no custom theme/plugings/etc.
  • this is very noticeable under vmware, otherwise try in userChrome.css (non-blurry font and good contrast on colors for best effect, but will obviously work with other settings as well) :
* {
    font-family: arial !important;
    background-color: beige;
    color: blue;
}
  • tab text always blurs, url line sometimes does not; however if you open e.g. about:config, the Firefox "button" text in the left side will blur.
  • another thing: entering a long url like bugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzillabugzilla will have its text appear blurred (may need to move focus elsewhere, e.g. by tab) -- this is not necessarily the same bug.
Flags: needinfo?(bugzilla.hundreAd)

i think in the video windows default app mode was set to dark, so firefox conformed to that
anyhow everything in Comment 3 is for light mode

another scenario:

  • have a single unpinned tab
  • create another tab; pin it
  • switch to the original (unpinned) tab

blur on mouse enter (see new video)
will not reproduce if there are multiple regular tabs (does blur on multiple pinned tabs and 1 regular)

Bug 1559810 - disallow Cairo as content/canvas backend. r=jrmuizel

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Component: Untriaged → Graphics: Text
Depends on: 1559810
OS: Unspecified → Windows 10
Product: Firefox → Core
Hardware: Unspecified → x86_64
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
No longer depends on: 1559810
Ever confirmed: true
Resolution: WORKSFORME → ---
See Also: → 1559810

disallowing cairo is NOT a solution
skia results in horrible font rendering
see https://bugzilla.mozilla.org/show_bug.cgi?id=1536875#c13 and https://bugzilla.mozilla.org/show_bug.cgi?id=1536875#c16

(In reply to hundreAd from comment #5)

Created attachment 9072205 [details]
yet another blur example.mp4

Hi, I'm just a contributing user, not an employee.
Windows 10 doesn't look such pixelated by default. If it was Firefox' fault, someone would have filed a bug as this would not meet quality expectations users hold Firefox up to, but it seems to be caused by your modifications:

Years ago, I had such a bad monitor that I rather wanted to have pixelated Windows XP-like fonts, but such unusual configurations are not supported anymore as almost no one needs or wants it and therefore maintenance cost would be unjustified. There are cheap screens with good PPI on the market showing fonts smoothly without causing eye cancer.

Otherwise please try resetting all graphics related prefs to go back to a supported configuration.
If you want, you could try out Firefox' new graphics engine: Open about:config on Nightly, set gfx.webrender.all to true and restart Nightly. In the future, Pathfinder will likely be integrated for high quality font rendering. They are working hard to remove old and potentially insecure components by rewriting them in safer languages, achieving better quality and performance.

(Hopefully my attempt to be helpful in some kind is not completely wrong, otherwise please just hide this comment. Thanks)

(from comment #0)

Windows NT 10.0

  • go to about:config
  • remove skia from gfx.content.azure.backends
  • restart firefox
Status: REOPENED → RESOLVED
Closed: 6 months ago6 months ago
Depends on: 1559810
Resolution: --- → WORKSFORME
See Also: 1559810

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #8)

Windows 10 doesn't look such pixelated by default.

yes, segoe is horrible, but with some effort, windows CAN be changed to use crisp fonts.

If it was Firefox' fault, someone would have filed a bug as this would not meet quality expectations users hold Firefox up to

go back and check when skia was forced upon us by default, around v52/3 i think. MANY MANY people complained about blurry fonts. the only workaround was to switch back to cairo.

it seems to be caused by your modifications

no, new ff installation, everything is set to default. only changes are the VERY minimal STR.

cairo used to work perfectly until v58.0.2, shortly afterwards some major bug were introduced, and have never been resolved since.

see in attachment how obvious the differences are. i understand some people like blurry fonts. i DON'T. it makes my eyes hurt. literally.

tested gfx.webrender.all, doesn't seem to affect font rendering in any way?
still crisp under cairo, regardless.
still blurry under skia, regardless.

Of course it looks blurry if you zoom into it. It would also look blurry if you artificially lower the display resolution instead of increasing font size.
For example, I can't see blurriness with my Dell monitor, unless I zoom into a screenshot. You should find a good monitor - the most extreme example would be a Retina display - but it doesn't need to be expensive.
(WebRender is unrelated to this. I just wanted to point out what is supported, what is being worked on and what you could have an eye on or try out.)

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #12)

Of course it looks blurry if you zoom into it.

the blurriness is obvious even when un-zoomed; the screenshot is at 400% to make it more obvious. and kindly note that the top half (cairo) is NOT blurry even when zoomed: https://bugzilla.mozilla.org/attachment.cgi?id=9073890

the problem is that skia uses sub-pixel rendering, unfortunately the only workaround atm is using cairo

You should find a good monitor

my monitor is excellent. my eyes, sadly, aren't.

You need to log in before you can comment on or make changes to this bug.