Closed Bug 1558502 Opened 3 years ago Closed 3 years ago

Local file doesn't load from Homescreen Shortcut

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox-esr68 wontfix, firefox67 unaffected, firefox68 wontfix, firefox69 wontfix, firefox70 wontfix, firefox71 wontfix)

RESOLVED WONTFIX
Tracking Status
firefox-esr68 --- wontfix
firefox67 --- unaffected
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix

People

(Reporter: mozbz, Unassigned)

References

Details

(Keywords: regression, regressionwindow-wanted)

STR.

  1. Load a local HTML file, eg from the Downloads folder.
  2. Once loaded, long-press the address bar and then select 'Add Page Shortcut'.
  3. Place the shortcut on the homescreen.
  4. Tap the shortcut.

Expected result:
The page opens in a new tab.

Actual Result:
The browser opens a blank page.
Refreshing navigates to 'about:blank'.
The tabs list shows the correct cached thumbnail.

Work around:
Tapping the address bar and then the 'go' arrow loads the page as expected.
Loading from a bookmark works as expected.

Tested on Android 9 from the Play Store:

  • Beta (68.0b5 and 68.0b7, possibly earlier)
  • Nightly (68.0a1 2019-06-10)

Hi, I reproduced the issue with device Huawei MediaPad M3 Lite 10 (Android 7.0) with builds: Firefox Nightly 68.0a1 (2019-06-11) and Firefox Beta 68.0b9. On Firefox Release 67.0.2 I did not reproduce the issue. I will mark the ticket as new.

Status: UNCONFIRMED → NEW
Component: General → Overlays
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → ARM

The priority flag is not set for this bug.
:st3fan, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(sarentz)

Hi, I reproduce the issue with device Huawei MediaPad M3 Lite 10 (Android 7.0) with builds Firefox Nightly 70.0a1 (2019-08-13), ESR Firefox Beta 68.1b6

Change the status for beta to have the same as nightly and release.
For more information, please visit auto_nag documentation.

I expect this is fallout from fixing bug 1558299 mozregression could say for sure.

Has STR: --- → yes
Component: Overlays → General

baku is this something you could investigate? It's from a change in 68.

Flags: needinfo?(amarchesini)
Flags: needinfo?(sarentz)

Closing this since this now works as expected. Fully recognizing this is a behaviour change.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(amarchesini)
See Also: → 1593331
Duplicate of this bug: 1593331

Wontfix explains the situation better.

Resolution: WORKSFORME → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.