Closed Bug 1559195 Opened 4 months ago Closed 3 months ago

PdfJs.jsm shouldn't use the app.update.postupdate preference

Categories

(Firefox :: File Handling, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: rstrong, Assigned: Gijs)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [fxperf:p1])

Attachments

(1 file)

This preference is only set for a profile that performs an update. It doesn't get set for other profiles including the profiles of other users on the system. It also doesn't get set when a client manually upgrades to a new version.

If a method is needed to only do this on version change it could check the browser.startup.homepage_override.mstone pref and if it needs to only run when running a newer version it can check if the version is greater.

I've attached a patch to bug 1555088 since it was mostly done and will submit it to phab after this bug is fixed.

Florian, can you find someone to fix this bug so I can move forward with the patch in bug 1555088?

Blocks: 1555088
Flags: needinfo?(florian)

I mentioned this during the front-end performance meeting yesterday, Mike agreed to have a look at this to find an owner.

Flags: needinfo?(florian) → needinfo?(mconley)

I'll take this.

Assignee: nobody → mconley
Flags: needinfo?(mconley)

Talked to Conley, going to steal this. :-)

Assignee: mconley → gijskruitbosch+bugs
Whiteboard: [fxperf] → [fxperf:p1]

The nshandlerservice-json.js bit is misleading - it got renamed to HandlerService.js, and in any case the check is not there but in pdfjs, which is where bug 1389443 added it - https://hg.mozilla.org/mozilla-central/rev/22ad20546ae7#l2.2 . That makes this sort of a dupe of bug 1545167, but at this point I might as well just attempt to fix this here...

See Also: → 1545167, 1547693
Summary: nsHandlerService-json.js shouldn't use the app.update.postupdate preference → PdfJs.jsm shouldn't use the app.update.postupdate preference

This is a fun rabbithole. AFAICT bug 1479245 removed the last access of PdfJs.enabled. It's just dead code.

Depends on: 1479245

OK, so I'm not fixing this stuff init'ing the handler service well early, that's bug 1545167. I'm just removing the code that checks the update pref because it's dead, and took the opportunity to remove a slew of other dead code (we no longer support npapi pdf plugins, so no need to have code to cater to that usecase).

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2af514f1a7bc
clean up PdfJs enabled checking code, r=bdahl

Backed out changeset 2af514f1a7bc (bug 1559195)for failures at browser_startup_mainthreadio.js

Backout link: https://hg.mozilla.org/integration/autoland/rev/06d4b70144ff6e923f61b06d4164b9eda977c8cb

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&resultStatus=testfailed%2Cbusted%2Cexception&revision=2799cfb271ca258e9087a16601dd16561bd4a3f3&selectedJob=255488228

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=255488228&repo=autoland&lineNumber=1730

Log snippet:

[task 2019-07-09T14:00:08.404Z] 14:00:08 INFO - TEST-PASS | browser/base/content/test/performance/browser_startup_mainthreadio.js | read on /etc/mime.types allowed 1 more times before first paint -
[task 2019-07-09T14:00:08.405Z] 14:00:08 INFO - TEST-PASS | browser/base/content/test/performance/browser_startup_mainthreadio.js | close on /etc/mime.types allowed 1 more times before first paint -
[task 2019-07-09T14:00:08.406Z] 14:00:08 INFO - Buffered messages finished
[task 2019-07-09T14:00:08.407Z] 14:00:08 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_startup_mainthreadio.js | unused whitelist entry before first paint: /etc/mime.types -
[task 2019-07-09T14:00:08.408Z] 14:00:08 INFO - Stack trace:
[task 2019-07-09T14:00:08.408Z] 14:00:08 INFO - chrome://mochikit/content/browser-test.js:test_ok:1576
[task 2019-07-09T14:00:08.409Z] 14:00:08 INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/browser_startup_mainthreadio.js:null:1009
[task 2019-07-09T14:00:08.409Z] 14:00:08 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1346
[task 2019-07-09T14:00:08.410Z] 14:00:08 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1381
[task 2019-07-09T14:00:08.411Z] 14:00:08 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1209

Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c224dc32222b
clean up PdfJs enabled checking code, r=bdahl
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.