Closed Bug 1560127 Opened 2 months ago Closed 2 months ago

Intermittent TV tier 2 TinderboxPrint: Per-test run of .../browser/browser_target_close.js<br/>: FAILURE

Categories

(Remote Protocol :: Agent, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: ochameau)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=252450595&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/UkVsWAm2Tx-l-YP2qJCj3w/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/UkVsWAm2Tx-l-YP2qJCj3w/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2019-06-19T13:15:01.444Z] 13:15:01 INFO - :::
[task 2019-06-19T13:15:01.663Z] 13:15:01 ERROR - No tests were found for flavor 'browser' and the following manifest filters:
[task 2019-06-19T13:15:01.663Z] 13:15:01 ERROR - skip_if, run_if, fail_if, remove_imptest_failure_expectations, subsuite(name=None), pathprefix(['remote/test/browser/browser_target_close.js'])
[task 2019-06-19T13:15:01.664Z] 13:15:01 ERROR -
[task 2019-06-19T13:15:01.664Z] 13:15:01 ERROR - Make sure the test paths (if any) are spelt correctly and the corresponding
[task 2019-06-19T13:15:01.664Z] 13:15:01 ERROR - --flavor and --subsuite are being used. See mach mochitest --help for a
[task 2019-06-19T13:15:01.665Z] 13:15:01 ERROR - list of valid flavors.
[task 2019-06-19T13:15:01.665Z] 13:15:01 ERROR -
[task 2019-06-19T13:15:01.665Z] 13:15:01 INFO - :::
[task 2019-06-19T13:15:01.666Z] 13:15:01 INFO - ::: 1. Run each test 10 times in one browser. : FAIL
[task 2019-06-19T13:15:01.666Z] 13:15:01 INFO - ::: 2. Run each test 5 times in a new browser each time. : not run / incomplete
[task 2019-06-19T13:15:01.667Z] 13:15:01 INFO - ::: 3. Run each test 10 times in one browser, in chaos mode. : not run / incomplete
[task 2019-06-19T13:15:01.667Z] 13:15:01 INFO - ::: 4. Run each test 5 times in a new browser each time, in chaos mode. : not run / incomplete
[task 2019-06-19T13:15:01.668Z] 13:15:01 INFO - :::
[task 2019-06-19T13:15:01.668Z] 13:15:01 INFO - ::: Test verification FAILED!
[task 2019-06-19T13:15:01.669Z] 13:15:01 INFO - :::
[task 2019-06-19T13:15:01.669Z] 13:15:01 INFO - Buffered messages finished
[task 2019-06-19T13:15:01.669Z] 13:15:01 INFO - SUITE-END | took 0s
[task 2019-06-19T13:15:01.708Z] 13:15:01 INFO - Return code: 0
[task 2019-06-19T13:15:01.710Z] 13:15:01 ERROR - No checks run.
[task 2019-06-19T13:15:01.711Z] 13:15:01 INFO - TinderboxPrint: mochitest-mochitest-browser-chrome<br/><em class="testfail">T-FAIL</em>
[task 2019-06-19T13:15:01.711Z] 13:15:01 ERROR - # TBPL FAILURE #
[task 2019-06-19T13:15:01.711Z] 13:15:01 WARNING - setting return code to 2
[task 2019-06-19T13:15:01.712Z] 13:15:01 ERROR - TinderboxPrint: Per-test run of .../browser/browser_target_close.js<br/>: FAILURE
[task 2019-06-19T13:15:01.712Z] 13:15:01 INFO - Per-test suites: {}
[task 2019-06-19T13:15:01.713Z] 13:15:01 INFO - Per-test suites: {}

Regressed by: 1543071

Hi, could you please take a look at this bug? It looks like it started with your push here: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=252450595&revision=b16a957f53f7be1b7414ba1c00d74328f640e7e2

Flags: needinfo?(jdescottes)

Hi Geoff! We recently started running the /remote tests in a dedicated "remote" job and it seems to be an issue when trying to run the tests in TV mode. I suppose this is similar to the issue we had with webreplay tests?

Edit: the remote job was introduced in https://bugzilla.mozilla.org/show_bug.cgi?id=1545147

Flags: needinfo?(jdescottes) → needinfo?(gbrown)
Flags: needinfo?(gbrown)
Duplicate of this bug: 1560298
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b094e680bba
Fix test-verify against mochitest-remote. r=gbrown
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Assignee: nobody → poirot.alex
You need to log in before you can comment on or make changes to this bug.