Closed Bug 1560267 Opened 6 months ago Closed 6 months ago

foreignObject left position

Categories

(Core :: SVG, defect)

69 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1557245
Tracking Status
firefox67 --- affected
firefox68 --- affected
firefox69 --- affected

People

(Reporter: tlebreton, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

In our foreignObject we got a div and an image . We want that image to be left aligned by 65px .
1 - Go on this https://codepen.io/anon/pen/bPgbBe
2 - Click on first step (image appear , we transform the left to 64px)
3 - Click on second step (back to original position , we transform the left to 65px).

This issue is reproducted on
Firefox 69.0.a1
Firefox 67.0.2

Actual results:

The problem is that the image is not show when the foreignObject is built but if we modify the left position by just one px the image is shown.

Expected results:

The image should be shown at the first load

Tested on below Os and versions and issue was reproducible on all of them using link provided:

Steps:

  1. Open link https://codepen.io/anon/pen/bPgbBe
  2. Green object should show up without pressing button "first step" or "second step"
    (the green button appears on other browsers without having to press a button, but on firefox you have to press any of those 2 buttons first)

Windows 10 64bit
Firefox nigthly 69.0a1 reproducible.
Firefox release 67.0.4 reproducible
Firefox beta 68.0.b12 reproducible.

Ubuntu 18.04 LTS 64bit
Firefox nigthly 69.0a1 reproducible.
Firefox release 67.0.4 reproducible
Firefox beta 68.0.b12 reproducible.

MAC 10.14
Firefox nigthly 69.0a1 reproducible.
Firefox release 67.0.4 reproducible.
Firefox beta 68.0.b12 reproducible.

Status: UNCONFIRMED → NEW
Component: Untriaged → SVG
Ever confirmed: true
Product: Firefox → Core

same as bug 1557245 maybe?

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1557245
You need to log in before you can comment on or make changes to this bug.