Closed Bug 1560359 Opened 4 months ago Closed 4 months ago

Accessibility issues for about:logins

Categories

(Firefox :: about:logins, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox69 --- fixed

People

(Reporter: jaws, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [passwords:management] [skyline] )

Attachments

(3 files)

I met with Jamie at All Hands and got the following feedback to improve accessibility in about:logins.

  1. The login-list <ol> should have tabindex=0 so it is tabbable and also should have role="listbox".
  2. The login-list-item elements inside of the login-list <ol> should have role="option"
  3. In JS, add support for up/down arrow keys to navigate the selected item
  4. Upon selecting an item, focus the Title of the login-item
  5. The menu needs to be closeable via keyboard (Esc)
Flags: qe-verify-
Flags: a11y-review+
Summary: Accessibility feedback from Jamie → Accessibility feedback for about:logins

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #0)

  1. In JS, add support for up/down arrow keys to navigate the selected item

When the selection is changed, this needs to be exposed as accessibility focus. That can either be done by using tabindex="-1" on the items and focusing them or by setting aria-activedescendant on the listbox to point at the selected item.

  1. The menu needs to be closeable via keyboard (Esc)

In addition, the menu needs to be navigable with up/down arrow keys (similar to the listbox).

Blocks: 1560431
No longer blocks: about-logins

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Type: task → defect
Summary: Accessibility feedback for about:logins → Accessibility issues for about:logins

Can you assign a priority please?

Flags: needinfo?(jaws)
Flags: needinfo?(jaws)
Priority: -- → P1
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ba5bdea1b608
Add keyboard support for login-list on about:logins. r=fluent-reviewers,sfoster,flod,yzen
https://hg.mozilla.org/integration/autoland/rev/2c0e25c99a72
Simplify the markup for menuitems in the menu on about:logins. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/040ec473bc01
Add keyboard support for the menu on about:logins. r=sfoster,yzen
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a47da25dc196
Add keyboard support for login-list on about:logins. r=fluent-reviewers,sfoster,flod,yzen
https://hg.mozilla.org/integration/autoland/rev/2bfbb6633d3a
Simplify the markup for menuitems in the menu on about:logins. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/f9bbfd8ef2b0
Add keyboard support for the menu on about:logins. r=sfoster,yzen
Flags: needinfo?(jaws)
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Whiteboard: [passwords:management] [skyline]

There are currently two problems with this:

  1. aria-activedescendant isn't working in the account list due to bug 1566324.
  2. The arrows don't work as expected initially in the menu; see bug 1566321.
Regressions: 1563004
Blocks: 1566321
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla69 → Firefox 69
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.