Picture-in-Picture toggle displays when video metadata is still being downloaded, even when supposedly disabled

VERIFIED FIXED in Firefox 69

Status

()

defect
P2
normal
VERIFIED FIXED
2 months ago
Last month

People

(Reporter: mconley, Assigned: mconley)

Tracking

(Blocks 1 bug, Regression, {regression})

68 Branch
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 verified)

Details

Attachments

(1 attachment)

STR:

  1. Ensure the Picture-in-Picture toggle is disabled (set media.videocontrols.picture-in-picture.video-toggle.enabled to false).
  2. Visit this slideshow
  3. Click on the "Play" button in the center of the video, and keep your mouse cursor centered on the video.

ER:

As the video loads, the Picture-in-Picture toggle icon is not displayed.

AR:

As the video loads, the Picture-in-Picture toggle icon is displayed, but then goes away after the video metadata has finished loading.

I suspect this was regressed by my patch for bug 1555834.

It turns out that this has been a problem for a while, and wasn't regressed by bug 1555834.

No longer regressed by: 1555834

Mozregression says this was regressed by bug 1547795.

Regressed by: 1547795

Later, once we have enough video metadata, the binding will decide whether or not to display the toggle again.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/75c588f5f225
Hide the Picture-in-Picture toggle by default when initializing a video binding. r=JSON_voorhees
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → mconley

Build ID 20190626093633
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Verified as fixed on the latest Nightly build on Windows 10.

On Windows 7 the issue is still reproducible, the toggle is displayed for a second when the play button is pressed. Could you please take a look?

Flags: needinfo?(mconley)

Hm... I'm not seeing it:

https://www.screencast.com/t/P2h8F73Bi

Am I skipping a step?

Flags: needinfo?(mconley) → needinfo?(george.craciun)

Build ID 20190627214735
User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Build ID 20190627214735
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

I've tested today with the latest Nightly build on both Windows 10 and Windows 7 and the toggle is not displayed anymore on the demo page, even when the media.videocontrols.picture-in-picture.video-toggle.enabled is set to true. On youtube and other websites the toggle is displayed.

When the preference media.videocontrols.picture-in-picture.video-toggle.enabled is set to false, the toggle is not displayed on any website.

Flags: needinfo?(george.craciun)
Flags: qe-verify+

Hi Mike, could you please take a look over the Comment 8?

Flags: needinfo?(mconley)

(In reply to Cristian Craciun from comment #8)

I've tested today with the latest Nightly build on both Windows 10 and Windows 7 and the toggle is not displayed anymore on the demo page, even when the media.videocontrols.picture-in-picture.video-toggle.enabled is set to true. On youtube and other websites the toggle is displayed.

Hi Cristian,

Yeah, I don't think this video was ever actually meant to display the toggle - it's not fitting the criteria for a "qualifying video" for showing the toggle (see bug 1547795 comment 0). In this case, it's both a silent video, and too short to show the toggle.

Flags: needinfo?(mconley)

Thank you for the clarification.

Verified as fixed based on Comment 10.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.