Closed Bug 1561538 Opened 3 years ago Closed 7 months ago

Extensions manager empty state displays the ‘Manage Your Extensions’ title

Categories

(Toolkit :: Add-ons Manager, defect, P3)

69 Branch
Desktop
Windows 10
defect

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox67 --- unaffected
firefox68 --- wontfix
firefox69 --- wontfix
firefox90 --- fixed

People

(Reporter: alexandru.cornestean, Assigned: sgrasseharoldsen, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug, polish)

Attachments

(3 files, 1 obsolete file)

[Affected versions]:
• Firefox 68.0b13 (20190624133534)
• Firefox 69.0a1 (20190625215814)

[Affected platforms]:
• Windows 10 Pro 64-bit
• MacOS High Sierra 10.13.6

[Prerequisites]:
Make sure to not have any extensions installed.

[Steps to reproduce]:

  1. Navigate to the about:addons page
  2. Access the Extensions tab on the left side menu

[Description]:
While having no extensions installed (extensions manager empty state), the ‘Manage Your Extensions’ title is displayed at the top of the page, instead of only showing the ‘Recommended Extensions’ section as per the latest mock-up at: https://mozilla.invisionapp.com/share/SEPLAO9WKPY#/screens/336575346 .
For further details, see the attached screenshots.

[Expected results]:
@ Mark Striemer : Is the extensions manager page supposed to look as per the mock-up linked above? The images depicted there do not show the mentioned title nor the cogwheel drop down menu. Is this how you intend for it to look?

[Actual results]:
The ‘Manage Your Extensions’ title is displayed at the top of the extensions manager page, alongside the ‘Recommended Extensions’ section.

Flags: needinfo?(mstriemer)
Keywords: polish
Priority: -- → P3

There is a heading so that there is an obvious distinction between Recommendations, Extensions and Themes.

If anything, we should add a placeholder to indicate the absence of installed extensions.

Meridel, do you have a suggestion for the placeholder visual and/or text?

Assignee: mstriemer → nobody
Flags: needinfo?(mstriemer) → needinfo?(mwalkington)

For empty state for the extensions page, and for the themes page, let's use this copy:

Get extensions and themes on addons.mozilla.org

"addon.mozilla.org" should link to AMO: https://addons.mozilla.org

Flags: needinfo?(mwalkington)

Thanks Meridel for the suggestion!

This is a good first bug and I am going to mentor this.
Those who are interested in making their first contribution can get started by reading https://wiki.mozilla.org/WebExtensions/Contribution_Onramp

To resolve this bug, the following changes should be made:

Mentor: rob
Keywords: good-first-bug

Hello, May I work on this?

Is the Manage Your Extensions heading to be displayed when there are no addons?

(In reply to Jayati Shrivastava from comment #7)

Is the Manage Your Extensions heading to be displayed when there are no addons?

Yes. The heading stays, the only new addition is the content suggested in comment 4.

Duplicate of this bug: 1530530

Hey, May I work on this?

There hasn't been any recent activity, so yes.

Are you still working on this issue?

Flags: needinfo?(gurunameh.work)

Yeah but you can give it a shot if u want.

Flags: needinfo?(gurunameh.work)

I'm onboarding a new contributor Sam Grasse-Hardoldsen and he is actively working on a patch for this.

:robwu, I've walked through the dev environment setup and some ideas for implementing this patch. I'll hand-off to you when he has an initial WIP.

Assignee: nobody → sgrasseharoldsen
Status: NEW → ASSIGNED

The patch is still in a draft revision somehow, with status "Changes Planned". Because of that, I'm not reviewing yet. If it is ready for review, please update the revision accordingly.

Hello Rob. I've just submitted the revision. I haven't written any tests yet and would love some guidance on doing so. Thanks.

(In reply to Samuel Grasse-Haroldsen from comment #18)

Hello Rob. I've just submitted the revision. I haven't written any tests yet and would love some guidance on doing so. Thanks.

Adding a need-info to flag :robwu

Flags: needinfo?(rob)

Sam, I assume attachment 9203767 [details] is now obsolete and should be removed in favor of attachment 9205842 [details]?
We need to make sure you are able to push changes to an existing phabricator revision rather than creating a new one each time.

Flags: needinfo?(sgrasseharoldsen)
Attachment #9203767 - Attachment is obsolete: true

(In reply to Samuel Grasse-Haroldsen from comment #18)

Hello Rob. I've just submitted the revision. I haven't written any tests yet and would love some guidance on doing so. Thanks.

It would probably best to add the unit test right before https://searchfox.org/mozilla-central/rev/52a3b19a3de21546f6ab9c10d37d6047107ed874/toolkit/mozapps/extensions/test/browser/browser_html_list_view.js#70
Immediately below that line is a unit test to verify that a non-empty list of addons is rendered. You can look at the existing test code to get an idea of how the test for this feature should look like.

Flags: needinfo?(rob)

Hey Sam, it's been awhile since we've heard from you. Are you still interested in working on this issue?

(In reply to Caitlin Neiman [:caitmuenster] from comment #22)

Hey Sam, it's been awhile since we've heard from you. Are you still interested in working on this issue?

Hey Caitlin. I'm still working on the unit test. I'll submit what I have so far and see if I can get some help.

Flags: needinfo?(sgrasseharoldsen)
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/bd6a10e0e895
Render message when there are no addons. r=robwu,flod
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Thanks for the patch, Sam -- I'm glad that you got this finished! 🎉 Your contribution has been added to our recognition wiki at https://wiki.mozilla.org/Add-ons/Contribute/Recognition.

Hope to see you around in the future. :)

Thanks, Caitlin! I'm happy I finally got this finished too!

You can count on seeing me in the future! :)

You need to log in before you can comment on or make changes to this bug.