Closed Bug 1561577 Opened 3 months ago Closed 3 months ago

Hitting the Escape key to close the shortcuts modal also toggles the Split Console

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox69 --- fixed

People

(Reporter: fvsch, Assigned: arosenfeld2003)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(1 file)

We added the ability to close the Shortcuts modal with the Escape key to be consistent with other modal UI in Debugger, but it was probably not tested in a Firefox build.

Steps to reproduce:

  1. In Firefox Nightly, open the Debugger
  2. On the Welcome page, click "Show all shortcuts"
  3. Hit the Escape key

Expected result:

  • The shortcuts modal is closed

Actual result:

  • The shortcuts modal is closed
  • The Split Console is toggled

We should probably stop the event's propagation or something similar.

Yes. This is a regression. We are really careful with escape because it is context specific.

Blocks: dbg-frontend
Keywords: good-first-bug
Priority: -- → P3

I think I've got a quick one-line fix for this... I'll go ahead and submit a patch for review.

Prevent toggling open Split Console with escape is pressed to toggle shortcutsModal closed.

Assignee: nobody → arosenfeld2003
Status: NEW → ASSIGNED
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/33eca9689b58
prevent default when esc is pressed on shortcutsModal r=jlast
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Blocks: 1565711
Blocks: 1565713
No longer blocks: 1565711
No longer blocks: 1565713
You need to log in before you can comment on or make changes to this bug.