Open Bug 1561850 Opened 2 years ago Updated 4 days ago

[Intermittent] Tab partially overlapped when attempting to change its position

Categories

(Firefox :: Tabbed Browser, defect, P3)

69 Branch
All
Linux
defect

Tracking

()

Tracking Status
firefox69 --- fix-optional

People

(Reporter: Anca, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(4 files)

Attached video screencast issue.mp4

[Affected versions]:

  • 69.0a1 (2019-06-26)

[Affected platforms]:

  • Ubuntu 18.04 x64

[Steps to reproduce]:

  1. Have two windows opened
  2. Drag a tab from one window to the other
    Note: make sure you are not overriding any existing tab
  3. Attempt to move the dragged tab from second position to the first

[Expected result]:

  • The tab is integrated correctly in the browser window.

[Actual result]:

  • The tab is partially covered by the first tab.

[Regression range]:

  • Not sure I can determine one, since it was tricky to reproduce it in the first place.

[Additional Notes]:

Has Regression Range: --- → no

Likely related to bug 1355507.

Priority: -- → P3
Regressed by: 1355507

I tried to find the regression for this issue but i didn't manage to reproduce the bug, so i will delete the regressionwindow-wanted and regression tags due to the fact that this issue is intermitent and impossible to find a regression.

QA Whiteboard: [qa-regression-triage]
Blocks: 1637238
See Also: → 1536480
See Also: → 1628122
Duplicate of this bug: 1645758

I've managed to encounter this issue twice, but it was not required to be moving tabs between two windows. Interestingly, Google Docs was involved both times, although that could be a simple coincidence.

I worded that poorly. I mean that in both cases where this happened I only had one window open.

When this happens, other tabs start misbehaving as well. The close tab button no longer functions on other tabs (although CTRL+W does) and the URL bar stops working (except for new empty tabs)

(In reply to dalley from comment #8)

When this happens, other tabs start misbehaving as well. The close tab button no longer functions on other tabs (although CTRL+W does) and the URL bar stops working (except for new empty tabs)

Was the hover styling still applied on close buttons? Are there any errors in your browser console when you see the above bugs?

Flags: needinfo?(dalley)

Sorry, I already restarted the browser. If it occurs a third time, I'll check those things.

Flags: needinfo?(dalley)

This happened to me again, I forgot to check the browser console for errors, but I did not see hover styling on the close buttons. They are simply non-functional in all respects. It's also impossible to any tabs around after this happens.

And has occurred on both Xorg and Wayland.

To move* any tabs around. This is Firefox 80.0.1

This happened again, I did not see any errors in the browser console. But the common element every single time it has failed in this way is that I had a both a google meet video call and a google doc tab open. And often it has happened immediately after opening the google docs tab or manipulating it in some way such as moving it around in the tab bar.

I'm reasonably certain I've never seen it happen without both of those websites being involved.

I've reached a point where I can semi-reliably reproduce this including creating two videos where catch it happening live. The thing is, I haven't been able to make it happen in a fresh profile yet, only my "normal" one.

I'm not sure where to go from here. How should I continue debugging?

It seems at least vaguely related to video playback, since I've been having this problem with Google Meet, and the original reporter had Netflix open.

Flags: needinfo?(dao+bmo)

It does still reproduce in my normal profile while running in safe mode w/ all addons disabled.

And I got it to happen once without google docs loaded but it seems way more likely to happen when it is for whatever reason.

I run into this every time I load up GMeet and then try to move it tear it off to another window. It'll sometimes render the entire browser chrome inoperable (though the rest of the browser will continue functioning). This just happens in my normal profile (on Nightly). I definitely don't need GDocs loaded to make stuff go awry.

(In reply to Dirkjan Ochtman (:djc) from comment #16)

I run into this every time I load up GMeet and then try to move it tear it off to another window. It'll sometimes render the entire browser chrome inoperable (though the rest of the browser will continue functioning).

This sounds like bug 1621458.

Flags: needinfo?(dao+bmo)
See Also: → 1621458
Duplicate of this bug: 1668276

I have encountered the issue while in a call on WebEx, with microphone being shared.

See Also: → 1692871
See Also: 1692871
Duplicate of this bug: 1692871

Still happening in Firefox 89

You need to log in before you can comment on or make changes to this bug.