Closed Bug 1561955 Opened 6 months ago Closed 5 months ago

Dark mode for the Protection Report (about:protections)

Categories

(Firefox :: Protections UI, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: ewright, Assigned: ntim)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [protection-report] [skyline])

Attachments

(2 files)

Create and implement designs for dark mode for about:protections.

Whiteboard: [protection-report][triage]
Priority: P2 → P3
Whiteboard: [protection-report][triage]
Duplicate of this bug: 1565092
Summary: Dark mode for the Protection Report → Dark mode for the Protection Report (about:protections)
Attached image Screenshot of patch
Whiteboard: [protection-report] [skyline]
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/13bb9ba5f69b
Make about:protections support dark mode. r=ewright,johannh
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED

I requested a backout as mtigley added some comments I haven't addressed: https://hg.mozilla.org/integration/autoland/rev/4c2aaf3c3d25

Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bbde5a300f43
Make about:protections support dark mode. r=ewright,mtigley,johannh
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe65e1f85f74
Run ./mach eslint on protections JS files to fix lint errors. r=eslint-fix CLOSED TREE
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

The changes for the Monitor card's font-sizes seemed to be reverted after the push. This was the original diff with the correct changes: https://phabricator.services.mozilla.com/D38210?id=135958

Flags: needinfo?(ntim.bugs)

(In reply to Micah Tigley [:mtigley] from comment #9)

The changes for the Monitor card's font-sizes seemed to be reverted after the push. This was the original diff with the correct changes: https://phabricator.services.mozilla.com/D38210?id=135958

Ah, thanks for noticing that. This is pretty strange since Lando mentioned diff 135965 was landed and the latest diff on phabricator is Diff 135958.

Flags: needinfo?(ntim.bugs)
Regressions: 1568545
You need to log in before you can comment on or make changes to this bug.