Closed Bug 1562021 Opened 3 months ago Closed 3 months ago

[webvtt] cues are incorrectly displayed twice

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: alwu, Assigned: alwu)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(5 files)

Forked from bug 1535005 comment 6, the cues in English track were incorrectly displayed twice, but cues in other tracks won't have this issue.

Priority: -- → P2
Regressed by: 1550633

Refactor these log by using the WebVTT log module and adding address info in the log.

This log module should be merged into a part of WebVTT log module because it's useless to check this log module independently.

When we start a new load, all previous data fetching from the previous listener and all state changing applied to track element should be ignored.

Therefore, we add a new method Cancel() which owner of the listener should call when we would like to discard current listener.

There are several places doing channel or listenr clean up, all these places should do channel and listener clean-up together because they are used as a pair.

In order to simulate the specific running order, we have to add a test event 'mozStartedLoadingTextTrack', which would be controlled under a pref.

This test is used to ensure that we won't get error event when we change track's mode during loading.

Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/602865e4e969
part1 : modify debug log for WebVTTListener. r=jya
https://hg.mozilla.org/integration/autoland/rev/da1f4f3f0c5c
part2 : using same log module as other VTT related files. r=jya
https://hg.mozilla.org/integration/autoland/rev/4fa9eb527c78
part3 : cancel old VTT listener when we start a new load. r=jya,baku
https://hg.mozilla.org/integration/autoland/rev/1ff85088fbf4
part4 : wrap channel and listener clean-up to a function. r=jya
https://hg.mozilla.org/integration/autoland/rev/084252265e0c
part5 : add test 'test_texttrack_mode_change_during_loading.html'. r=jya
You need to log in before you can comment on or make changes to this bug.