Closed Bug 1562141 Opened 5 months ago Closed 5 months ago

[Wayland] Some addon popups are misplaced (LastPass)

Categories

(Core :: Widget: Gtk, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug, Regressed 2 open bugs, )

Details

Attachments

(1 file)

Some addon popups are misplaced (LastPass)

Assignee: nobody → stransky
Priority: P3 → P2
Keywords: checkin-needed

Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bb73a4c99331
[Wayland] Hide/show popup when it's positioned by gdk_window_move_to_rect() and it's visible, r=jhorak

Keywords: checkin-needed

Backed out changeset bb73a4c99331 (bug 1562141) for build failures at nsWindow.cpp on a CLOSED TREE.

Backout link: https://hg.mozilla.org/integration/autoland/rev/bb73a4c993319bd386ea93fbe742c343de42379c

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&revision=bb73a4c993319bd386ea93fbe742c343de42379c&selectedJob=254074927

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=254074927&repo=autoland&lineNumber=24233

Log snippet:

[task 2019-06-29T11:19:00.188Z] 11:19:00 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/layout/style'
[task 2019-06-29T11:19:01.476Z] 11:19:01 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/widget/gtk'
[task 2019-06-29T11:19:01.478Z] 11:19:01 INFO - /builds/worker/workspace/build/src/sccache/sccache /builds/worker/workspace/build/src/gcc/bin/g++ -o nsWindow.o -c -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DOS_POSIX=1 -DOS_LINUX=1 -DCAIRO_GFX '-DMOZ_APP_NAME="firefox"' -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/widget/gtk -I/builds/worker/workspace/build/src/obj-firefox/widget/gtk -I/builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders -I/builds/worker/workspace/build/src/ipc/chromium/src -I/builds/worker/workspace/build/src/ipc/glue -I/builds/worker/workspace/build/src/layout/base -I/builds/worker/workspace/build/src/layout/generic -I/builds/worker/workspace/build/src/layout/xul -I/builds/worker/workspace/build/src/other-licenses/atk-1.0 -I/builds/worker/workspace/build/src/widget -I/builds/worker/workspace/build/src/widget/headless -I/builds/worker/workspace/build/src/widget/x11 -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=coverage-mismatch -Wno-error=free-nonheap-object -Wformat -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fno-omit-frame-pointer -funwind-tables -Werror -I/builds/worker/workspace/build/src/widget/gtk/compat-gtk3 -pthread -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/gtk-3.0/unix-print -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -Wno-error=shadow -MD -MP -MF .deps/nsWindow.o.pp /builds/worker/workspace/build/src/widget/gtk/nsWindow.cpp
[task 2019-06-29T11:19:01.478Z] 11:19:01 INFO - /builds/worker/workspace/build/src/widget/gtk/nsWindow.cpp: In member function 'void nsWindow::NativeMoveResizeWaylandPopup(GdkPoint*, GdkRectangle*)':
[task 2019-06-29T11:19:01.478Z] 11:19:01 ERROR - /builds/worker/workspace/build/src/widget/gtk/nsWindow.cpp:1321:54: error: 'gtk_widget_is_visible' was not declared in this scope
[task 2019-06-29T11:19:01.479Z] 11:19:01 INFO - bool isWidgetVisible = gtk_widget_is_visible(mShell);
[task 2019-06-29T11:19:01.479Z] 11:19:01 INFO - ^
[task 2019-06-29T11:19:01.479Z] 11:19:01 INFO - /builds/worker/workspace/build/src/config/rules.mk:801: recipe for target 'nsWindow.o' failed
[task 2019-06-29T11:19:01.479Z] 11:19:01 ERROR - make[4]: *** [nsWindow.o] Error 1
[task 2019-06-29T11:19:01.479Z] 11:19:01 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/widget/gtk'
[task 2019-06-29T11:19:01.479Z] 11:19:01 INFO - make[4]: *** Waiting for unfinished jobs....
[task 2019-06-29T11:19:01.479Z] 11:19:01 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/layout/style'
[task 2019-06-29T11:19:01.479Z] 11:19:01 INFO - layout/style/Unified_cpp_layout_style2.o

Flags: needinfo?(stransky)
Backout by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/83b51d942648
Backed out changeset bb73a4c99331 for build failures at nsWindow.cpp on a CLOSED TREE.

Ah, I see, gtk_widget_is_visible() is here since gtk 3.8 but we still use 3.4 headers.

Flags: needinfo?(stransky)
Keywords: checkin-needed

Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8b3c35badb46
[Wayland] Hide/show popup when it's positioned by gdk_window_move_to_rect() and it's visible, r=jhorak

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1572911
Regressions: 1581851
You need to log in before you can comment on or make changes to this bug.