Closed Bug 1562166 Opened 2 years ago Closed 2 years ago

The "CFR FxA Bookmark Panel Message" is not correctly adjusted on the Firefox "ru" locale

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

RESOLVED WONTFIX
Iteration:
70.1 - Jul 8 - 21

People

(Reporter: mcoman, Assigned: andreio)

References

Details

Attachments

(3 files)

Attached image rec of the issue.gif

[Affected versions]:

  • Firefox Beta 68.0b14, Build ID 20190627143605
  • Firefox Nightly 69.0a1, Build ID 20190627214735

[Affected Platforms]:

  • All Windows
  • All Linux
  • All Mac

[Prerequisites]:

  • Have the latest Firefox Beta 68.0b14 "ru" locale build installed.
  • Have the "browser.newtabpage.activity-stream.asrouter.devtoolsEnabled" pref set to "true" in the "about:config" page

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Navigate to any website and click the "Bookmark this page" button from the right part of the "Address Bar".
  3. Observe the "CFR FxA Bookmark Panel Message".

[Expected result]:

  • The message is correctly displayed and rendered.

[Actual result]:

  • The message is not correctly adjusted.

[Notes]:

  • Attached a screen recording of the issue.

I guess this is basically bug 1548784?

Flags: needinfo?(andrei.br92)

That's right the height of the panel causes this issue.
Last time we discussed bug 1548784 it wasn't obvious if we can actually make the height fluid because of the animation used to show the message (in more detail: there is a fixed height container that either shows the purple message or a screenshot of the page being bookmarked. There is a animation where the purple message slides over the screenshot. The fixed height is required in order to keep things from moving up/down).

We might keep both bugs open, fix this one by working around the issue: smaller font size, smaller margins.

Flags: needinfo?(andrei.br92)

margin values adjusted, "ru" preview.

margin values adjusted, "en-US" preview

[Tracking Requested - why for this release]: this feature looks pretty terrible in Russian.

:mcoman, have you tested other locales and/or have you found any other issues?

Assignee: nobody → andrei.br92
Iteration: --- → 69.4 - Jun 24 - Jul 7
Flags: needinfo?(mcoman)
Priority: -- → P1

Hi Tim, I have tested this issue on multiple Firefox locales, especially on the ones with long text strings (e.g. it, de) and with non-Latin characters (e.g. el, uk, zh-CN), but I have not managed to reproduce it. For now, the only affected build that I've found is the "ru" locale.

Flags: needinfo?(mcoman)

If this really only affects Russian I wonder if the "exclude RU through remote targeting" option is the way to go for 68, vs crash-landing a fix straight to mozilla-release. wdyt?

Flags: needinfo?(tspurway)
Flags: needinfo?(khudson)
See Also: → 1548784

That sounds like a plan, Julien. We will make the change to disable RU remotely, but leave this bug open to track the fix for 69

Flags: needinfo?(tspurway)
Flags: needinfo?(khudson)

I have verified and I can confirm that the "Sync to CTA when Bookmarking" message is no longer displayed on the Firefox "ru" locale. Verified on Windows 10 x64, Mac 10.14.5 and Arch Linux using latest Firefox Nightly "ru" locale (69.0a1 - Build ID: 20190704094530).

Iteration: 69.4 - Jun 24 - Jul 7 → 70.1 - Jul 8 - 21

Fixed by bug 1548784 with a solution that works for any locale with longer strings.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.