Closed Bug 1562219 Opened 5 months ago Closed 3 months ago

Gmail - Cursor jumps when moving over list of emails on Intel HD Graphics 620?

Categories

(Core :: Graphics: WebRender, defect, P2)

69 Branch
Desktop
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1556634

People

(Reporter: jgroland, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image firefox_gmail.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

  1. Log into Gmail.
  2. Move mouse of list of emails in mailbox.
  3. Moving fast the hover will not land on the last message row you hover over.
  4. Cursor jumps back to a different email.

Actual results:

Hover effect lands on a completely different email row.

Expected results:

Hovered over email row should be selected.

I tested this on Windows 10 x64 and Mac OS X 10.14 with FF Nightly 69.0a1 (2019-07-01) and I can't reproduce the issue, please note that I used a new profile with no add-ons.
Jesse do you have any add-ons on your profile? If yes please try and retest this in safe mode, here is a link that can help you:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Component: Untriaged → Panning and Zooming
Flags: needinfo?(jgroland)
Product: Firefox → Core

(In reply to ovidiu boca[:Ovidiu] from comment #1)

I tested this on Windows 10 x64 and Mac OS X 10.14 with FF Nightly 69.0a1 (2019-07-01) and I can't reproduce the issue, please note that I used a new profile with no add-ons.
Jesse do you have any add-ons on your profile? If yes please try and retest this in safe mode, here is a link that can help you:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

This works fine in Safe Mode, but when I try and disable my addons one at a time it still happens.

  • I am working off a a fairly new profile.
  • Addons I am using: Decentraleyes, Ublock Origin, and Bitwarden.
  • I also have gfx.webrender.all and fission.autostart to TRUE but I disabled fission and restarted and still saw the same issue.
  • When this issue is occurring I cannot also install XPI addons from links such as the development branch on Ublock (https://github.com/gorhill/uBlock/releases/download/1.20.3b0/uBlock0_1.20.3b0.firefox.signed.xpi) When clicking that link it just gives me a blank window.
  • But when in safe mode it allows the link to open and prompt for permission to install the addon.
  • I am on Windows 10 1903, Using a Lenovo T470s and a Lenovo Thunderbolt Gen 2 dock with two monitors.
Flags: needinfo?(jgroland)

Thanks for the updates, maybe you can try first to disable all the add-ons and then enable them one by one and retest the issue, this way maybe you can see witch add-on cause the issue.

(In reply to ovidiu boca[:Ovidiu] from comment #3)

Thanks for the updates, maybe you can try first to disable all the add-ons and then enable them one by one and retest the issue, this way maybe you can see witch add-on cause the issue.

  • As I said, disabling them and re-enabling did not have an affect.
  • Disabling Hardware acceleration is what stopped the issue from happening.
  • The Thunderbolt dock is new in my situation so that is a possible factor

I just updated to the nightly build for 7-3 and it appears to have fixed what was happening.

(In reply to Jesse Roland from comment #5)

I just updated to the nightly build for 7-3 and it appears to have fixed what was happening.

  • Nevermind this is still happening.

(In reply to Jesse Roland from comment #4)

  • Disabling Hardware acceleration is what stopped the issue from happening.

Setting gfx.webrender.all=true will enable both WebRender and hardware acceleration. When you say disabling HWA stops the issue, can you clarify if you also disabled WebRender at the same time? i.e. it happens with gfx.webrender.force-disabled=true and layers.acceleration.force-enabled=true but not with gfx.webrender.force-disabled=true and layers.acceleration.force-enabled=false?

(In reply to Kartikaya Gupta (email:kats@mozilla.com) (away 17-Jul-2019 to Feb-2020) from comment #7)

(In reply to Jesse Roland from comment #4)

  • Disabling Hardware acceleration is what stopped the issue from happening.

Setting gfx.webrender.all=true will enable both WebRender and hardware acceleration. When you say disabling HWA stops the issue, can you clarify if you also disabled WebRender at the same time? i.e. it happens with gfx.webrender.force-disabled=true and layers.acceleration.force-enabled=true but not with gfx.webrender.force-disabled=true and layers.acceleration.force-enabled=false?

I only disabled Hardware Acceleration under settings.

Ok, so then this sounds like a WebRender issue on Linux.

Blocks: wr-linux
Component: Panning and Zooming → Graphics: WebRender
OS: Unspecified → Linux

(In reply to Kartikaya Gupta (email:kats@mozilla.com) (away 17-Jul-2019 to Feb-2020) from comment #9)

Ok, so then this sounds like a WebRender issue on Linux.

I am running on Windows 10 1903

Oh, my bad. I don't know why I thought you were on Linux. Can you attach your about:support contents to this bug, in the configuration that manifests the problem?

No longer blocks: wr-linux
OS: Linux → Windows 10
Attached file about-support-jroland

(In reply to Kartikaya Gupta (email:kats@mozilla.com) (away 17-Jul-2019 to Feb-2020) from comment #11)

Oh, my bad. I don't know why I thought you were on Linux. Can you attach your about:support contents to this bug, in the configuration that manifests the problem?

Attached as requested.

Priority: -- → P2
Hardware: Unspecified → Desktop

darkspirit, I assume you can't reproduce this?

Flags: needinfo?(jan)
Summary: Gmail - Cursor jumps when moving over list of emails. → Gmail - Cursor jumps when moving over list of emails on Intel HD Graphics 620?
See Also: → 1556634
Blocks: wr-69

Jesse, can you install the KB4512941 update and check if this still happens for you?

Flags: needinfo?(jgroland)

(In reply to Jeff Muizelaar [:jrmuizel] from comment #16)

Jesse, can you install the KB4512941 update and check if this still happens for you?

Looks like this update did resolve the issue.

Flags: needinfo?(jgroland)
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1556634
Flags: needinfo?(jan)
You need to log in before you can comment on or make changes to this bug.