Closed Bug 1550023 (wr-intel-mvp) Opened 6 months ago Closed 3 months ago

[meta] wr-intel-mvp

Categories

(Core :: Graphics: WebRender, enhancement, P3)

69 Branch
Desktop
Windows 10
enhancement

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox68 --- unaffected
firefox69 + disabled
firefox70 ? verified

People

(Reporter: jrmuizel, Assigned: kats)

References

(Depends on 2 open bugs, Blocks 3 open bugs)

Details

(Keywords: meta)

Attachments

(4 files)

No description provided.
Alias: wr-intel-mvp
Depends on: 1404477
Depends on: 1417633
Blocks: wr-intel
Type: defect → enhancement
Keywords: meta
Summary: [mtea] wr-intel-mvp → [meta] wr-intel-mvp
Depends on: 1479786
Depends on: 1550029
No longer depends on: 1479786
Depends on: 1515412
Depends on: 1525084
Depends on: 1528376
Depends on: 1532410
Depends on: 1535979
Depends on: 1540449
Priority: -- → P3
No longer depends on: 1515412
No longer depends on: 1550029
No longer depends on: 1535979

Just to be clear, this bug ("Intel MVP") is for users who are:

  • On Windows10,
  • Using one of the whitelisted Intel graphics cards,
  • Have no battery, and
  • Have small screens (smaller than 1920 x 1200)
Depends on: 1562462
Depends on: 1556634
Depends on: 1560520
Duplicate of this bug: 1556522
No longer depends on: 1404477
No longer depends on: 1528376
No longer depends on: 1532410
Blocks: wr-69

This uses positive-but-empty #if conditions with else clauses rather than
inverted conditions for better readability and documentation.

It doesn't need to be an argument since it's not used by the caller.

Depends on D37083

I'm not really that happy with the third patch but I couldn't think of a better way to do it.

Keywords: leave-open
OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/db4c8cbf463e
Allow WR on a subset of Intel to ride into early beta on Windows. r=jrmuizel

Comment on attachment 9076241 [details]
Bug 1550023 - Allow WR on a subset of Intel to ride into early beta on Windows. r?jrmuizel

Beta/Release Uplift Approval Request

  • User impact if declined: Intel graphics users on Windows desktop machines won't get WR in early beta.

We have WR enabled for this population on Nightly, would like to release it to early beta as well in 69. Then in 70 we can try to push it to release assuming no major issues crop up.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: After uplift, ensure WR is enabled by default on beta builds when running on Windows desktop machines with modern Intel graphics cards and sub-4k displays.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk, just fiddling with some ifdefs to allow early beta windows users to get WR enabled.
  • String changes made/needed:
Attachment #9076241 - Flags: approval-mozilla-beta?

Comment on attachment 9076241 [details]
Bug 1550023 - Allow WR on a subset of Intel to ride into early beta on Windows. r?jrmuizel

Clearing uplift request for now. Apparently we might want this to ride to release in 69 and not 70. Will re-request once we confirm.

Attachment #9076241 - Flags: approval-mozilla-beta?

Yes, we want this to ride into release 69.

In that case we should:

  • tweak the condition to use the smaller display size
  • land the remaining patches up for review
  • request uplift on all three/four patches

Then, just before 69 goes to release, we should land a patch in 69 to turn off gfx.webrender.all.qualified and use normandy to do the gradual rollout of turning it back on.

Once these patches land WR will be riding to release on small-screen intel Windows desktop devices, which effectively completes this bug. So dropping leave-open keyword.

Assignee: nobody → kats
Keywords: leave-open
Version: unspecified → 69 Branch
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b7cb3e295ca7
Move variable into function. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/b6505d3d38c1
Qualify whitelisted Intel cards up to WUXGA screen size for Windows in release 69. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/7aa8046c0902
Don't allow the qualified pref to disable WR for already released populations. r=jrmuizel
QA Contact: tbabos

Comment on attachment 9076241 [details]
Bug 1550023 - Allow WR on a subset of Intel to ride into early beta on Windows. r?jrmuizel

Beta/Release Uplift Approval Request

  • User impact if declined: Firefox 69 users on whitelisted Intel cards will not get WR enabled in beta/release. Also we won't be able to do progressive rollout of WR to more populations without impacting existing users who have WR enabled in release.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: On 69 beta with the patches applied, verify that:
  • Windows 10 desktop machines with modern Intel graphics cards and small displays (less than 1920 x 1200) get WR enabled by default, and WR gets disabled if gfx.webrender.all.qualified (hidden pref) is set to false via about:config.
  • Windows 10 desktop machines with modern Nvidia and AMD graphics cards get WR enabled by default, and WR remains enabled even if gfx.webrender.all.qualified is set to false via about:config.
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): Small risk that we accidentally enable/disable WR on the wrong set of users as the conditions for enabling are getting more complex. QA verification should mitigate the risk, and we are early enough in the beta cycle that we should be able to catch any problems.
  • String changes made/needed:
Attachment #9076241 - Flags: approval-mozilla-beta?
Attachment #9076242 - Flags: approval-mozilla-beta?
Attachment #9076243 - Flags: approval-mozilla-beta?
Attachment #9076821 - Flags: approval-mozilla-beta?

Comment on attachment 9076241 [details]
Bug 1550023 - Allow WR on a subset of Intel to ride into early beta on Windows. r?jrmuizel

Enables WebRender on a targeted set of Intel graphics chipsets as planned for 69. As was noted, it's early enough in the Beta cycle that we should have time to be on the lookout for any fallout. Thanks for including QA testing instructions. Approved for 69.0b4.

Attachment #9076241 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9076242 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9076243 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9076821 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Looks like D37085 needs rebasing for Beta. The other 3 graft cleanly.

Flags: needinfo?(kats)

Thanks for the heads-up. I can rebase and push the uplift.

Flags: needinfo?(kats)
QA Whiteboard: [qa-triaged]

Reopened because it's a meta

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

But.. it's fixed in that lack of any further action will result in WR being released to the intel mvp population in 69. Open blockers should either be fixed or moved to a different meta. For tracking/QA purposes it's better to leave this bug as fixed.

Ok. Seems reasonable.

Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED

I don't think this happened for 69, but it looks to be potentially riding the train for 70.

Flags: needinfo?(jbonisteel)

(In reply to Liz Henry (:lizzard) from comment #26)

I don't think this happened for 69, but it looks to be potentially riding the train for 70.

Correct

Flags: needinfo?(jbonisteel)
Depends on: 1580917

[Tracking Requested - why for this release]: we would like to ship our Intel MVP with 70

Depends on: 1587189

This feature was completed and Sign-off was sent with Green color. Removing qe flags.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.