Closed Bug 1563604 Opened 9 months ago Closed 9 months ago

Detect invariant-violating sends of BrowsingContext over IPC earlier

Categories

(Core :: DOM: Content Processes, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla70
Fission Milestone M4
Tracking Status
firefox70 --- fixed

People

(Reporter: Nika, Assigned: Nika)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

No description provided.

This ensures that the object is not discarded while there are still in-flight
messages from the parent process, which could cause a content process crash if a
CC was run before any pending messages have arrived.

This should help us more easily identify where the crashing issues are coming
from. The issue in part 1 was found due to these assertion changes.

Attachment #9076080 - Attachment description: Bug 1563604 - Part 1: Confirm detach calls with the parent before dropping refs, → Bug 1563604 - Part 1: Confirm detach calls before dropping refs,
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/360b12c6b3e4
Part 1: Confirm detach calls before dropping refs, r=peterv
https://hg.mozilla.org/integration/autoland/rev/54d9810b02ae
Part 2: Assert on the sending side that BrowsingContexts are in valid states, r=peterv
Type: enhancement → task
Regressions: 1566294
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1566806
No longer regressions: 1566806
Regressions: 1579437
See Also: → 1602366
See Also: → 1603976
You need to log in before you can comment on or make changes to this bug.