Open Bug 1563801 Opened 3 years ago Updated 2 years ago

Netflix crashes Firefox

Categories

(Core :: Audio/Video: Playback, defect, P3)

69 Branch
x86_64
Windows 10
defect

Tracking

()

REOPENED
Tracking Status
firefox69 --- affected

People

(Reporter: selim, Unassigned)

References

Details

Attachments

(1 file)

After clicking play on any Netflix video, Firefox crashes and the whole Windows freezes in a few seconds, requiring a hard reset.

I can't reproduce this in safe mode.

I have the latest AMD Radeon driver (19.6.3) installed.

Crash ID: bp-04c97b77-7d05-4913-95df-826620190705

Hi Selim,

I wasn't able to reproduce this on Firefox 67.0.4 or Firefox 69.0a1, it is more than likely an add-on which causes the issue.
Try to disable your add-ons and then enable them one-by-one in order to find the one that causes the crash.

Thanks!

Flags: needinfo?(selim)

I have two addons installed (Facebook Container and LastPass) but disabling both of them didn't help. I can still reproduce this on Nightly 70.

Flags: needinfo?(selim)

So it does not reproduce in safe-mode but it does if you disable the add-ons you have?

If so, please try creating a new profile and see if it re-occurs using that, you can find the steps to do that below:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Flags: needinfo?(selim)

(In reply to Peter_M from comment #3)

So it does not reproduce in safe-mode but it does if you disable the add-ons you have?

Yes, and it seems like updating to the latest Radeon driver (19.7.1) fixed the issue for now.

Flags: needinfo?(selim)
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Since updating the driver fixed your issue, I'm going to close this bug.
Please feel free to reopen it if the problem resurfaces.

Thanks!

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME

The problem has just resurfaced with the latest driver, so I'm going to reopen this.

Seems like it doesn't happen every time but I'm not sure what triggers the bug.

I had another crash yesterday. I tried creating a new profile and couldn't reproduce the issue. Returning back to my older profile, I couldn't reproduce either.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Can you link to any other crash reports you have sent for this? [@ IPCError-browser | ShutDownKill ] is a catch all signature with many different bugs falling into it, so it would help to be able to see more of the ones specific to this bug.

Flags: needinfo?(selim)

Other reports I have are probably useless due to bug 1566855.

And I can't seem to reproduce a crash at the moment.

Flags: needinfo?(selim)

Because now we're lacking of a crash report which has detailed call stack related to a real problem (no matter it's about graphic, playback or EME), it's hard for us to figure out what's going on there.

For now, we don't really know the exact crash amount, so I will temporarily set this bug as P3.

In addition, I found that AMD has released driver version 19.8.1 [1], could you try to see if this update fixs the issue or not?

Thank you.

[1] https://www.amd.com/en/support/kb/release-notes/rn-rad-win-19-8-1

Flags: needinfo?(selim)
Priority: -- → P3

I'm already using 19.8.1 and the issue seems to be fixed for now.

Flags: needinfo?(selim)

According to the comment10, I will close this bug for now, but feel free to reopen this bug if you see the issue again.
Thank you.

Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → WORKSFORME

Looks like it's happening again. I had two crashes in the past hour but no crash report was generated. Any idea why reports might be missing?

Would you be able to upload a copy of the data from about:support?

To make sure I understand the crash: Firefox crashes and the Firefox window locks up, requiring you to close Firefox and open it again (not the whole system)? When the crash happens does Firefox show any information reporting that a crash has happened before it locks? If not, does the Window just freeze in its current state, does it turn black, does something else happen?

Status: RESOLVED → REOPENED
Flags: needinfo?(selim)
Resolution: WORKSFORME → ---

Here it is: https://paste.mozilla.org/is20CHtJ

When the crash happens Firefox locks the whole system. It doesn't respond to Ctrl+Shift+Esc or anything else and I have to hard reset my PC.

Usually no informating is shown but sometimes a "Nightly has stopped working" dialog appears.

Flags: needinfo?(selim)

I see a couple of unsubmitted crash reports in that about:support info, but do not know why they're not appearing. :gsvelto, do you have any insight as to why these reports aren't showing up?

Crashing the whole system sounds like a driver issue. Since it's happening on Netflix, I suspect changing prefs to see if this mitigates the issue may not help, as the component responsible for decoding in this scenario (the Widevine CDM) will not change behaviour based on prefs.

Selim, how often do you see the issue? It's mentioned above that the issue doesn't happen in safe mode, and I'm wondering if you could test that again.

Flags: needinfo?(gsvelto)

(In reply to Bryce Seager van Dyk (:bryce) from comment #15)

I see a couple of unsubmitted crash reports in that about:support info, but do not know why they're not appearing. :gsvelto, do you have any insight as to why these reports aren't showing up?

Probably bug 1566855.

Crashing the whole system sounds like a driver issue. Since it's happening on Netflix, I suspect changing prefs to see if this mitigates the issue may not help, as the component responsible for decoding in this scenario (the Widevine CDM) will not change behaviour based on prefs.

Selim, how often do you see the issue? It's mentioned above that the issue doesn't happen in safe mode, and I'm wondering if you could test that again.

I don't usually watch Netflix on my browser (I prefer my TV) and that's why I rarely update this bug. But I'd say it happens 80% of the time when I visit Netflix.

I just tested again with the latest AMD driver (19.8.2) and had a crash. I manually took a photo of my screen after it completely froze: https://paste.pics/d1a746a4ee23045b925de00adbaeae2b

Restarted, tested again on safe mode and it worked fine.

The two crashes in about:support have been submitted, they're here:

https://crash-stats.mozilla.org/report/index/a11fbb6e-92ac-4a63-b5ac-125e90190901
https://crash-stats.mozilla.org/report/index/a8af37ea-1112-4a30-9c9a-be6840190901

They seem to be unrelated and belong to bug 1566310 which has already been fixed. So that's very, very odd. I have a setup that's similar to Selim - even the same graphics driver - but no Netflix account so I can't check myself.

However if the whole machine is freezing when this happens then it might even be a hardware problem. Selim, are you experiencing instability in other programs too? What happens if you watch Netflix with another browser?

Flags: needinfo?(gsvelto) → needinfo?(selim)

(In reply to Gabriele Svelto [:gsvelto] from comment #17)

However if the whole machine is freezing when this happens then it might even be a hardware problem. Selim, are you experiencing instability in other programs too? What happens if you watch Netflix with another browser?

Not at all. I play games and do somewhat intensive tasks on this PC without a problem.

I just tested on Chrome had the same crash. Tested on Edge and it worked fine.

I haven't experienced this problem outside of Netflix. I've also tried playing some Widevine CDM demo videos from https://shaka-player-demo.appspot.com/ and they worked fine too.

Flags: needinfo?(selim)

OK, if both Chrome and Firefox are affected then it's most likely be a driver issue and specifically related to the video decoding logic. Out of curiosity, what kind of graphics card do you have? Knowing the exact model I could look it up on crash-stats and see if we have more crashes for it.

It's an old MSI Radeon HD 7770 OC 1 GB (device ID: 1002-683D). Probably doesn't have many users any more, but still supported by AMD.

I was searching for this for the past days. I recently started having this exact same issue too and I though it was firefox. It crashes sometimes when clicking play in netflix website. I also have an AMD graphics card and I updated today to the latest driver and software, but it still just happened.

My Graphics card: AMD Radeon R9 270
CPU: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
Radeon software: v19.9.1 (latest)
Firefox: Quantum v69.0 (latest)
Windows: 10 Pro v1903 (Fully patched)

Note: My hardware is fine, did a memetest yesterday succesfully and I have a brand new SSD which runs smoothly.

My suspicion here would be that there is an issue in AMD's driver related to video decoding that causes the crash. Firefox has blacklists of drivers which it will not use for hardware decoding due to such issues, however, I would expect that Widevine has it's own blacklist which may not include these drivers -- this is consistent with the same crash happening in Chrome.

My understanding is that the video decoding parts of these drivers can be distinct far enough that we can see crashes like this while the drivers behave fine for other applications like games.

I'll reach out to Widevine regarding the issue, as they may be able to adjust their blacklists. Ideally this is something that would be fixed in the driver, but I'm not sure how to attempt to rectify that.

Well, it appears Netflix has something that destroyes drivers :/

Just do a simple search on Google with : "netflix crashes display driver"...
You get results from 2015 up to today.

(In reply to Bryce Seager van Dyk (:bryce) from comment #22)

My understanding is that the video decoding parts of these drivers can be distinct far enough that we can see crashes like this while the drivers behave fine for other applications like games.

Yes, the video decoder is a stand-alone part of the GPU (*) and shares almost nothing with the rendering blocks. The latter might be working fine even if the former is broken.

*) On Radeons it's usually implemented as a custom core - often from Tensilica - with fixed-function blocks for common formats and its own firmware

Could you provide the crash id's from Chrome at chrome://crashes? Widevine would like those in order to analyze the issue.

Flags: needinfo?(selim)

Crash reporting was disabled in my Chrome until now, so there's no crash report yet.

I tested again with Chrome for a few times but didn't succeed in reproducing the crash. Tested with Firefox after succeeding in Chrome and had an instant crash. I have no idea how often it happens with Chrome. I'll try again from time to time and update this bug if I can generate a crash report.

Flags: needinfo?(selim)

I was just able to reproduce the crash on Chrome but there's no report to be seen on chrome://crashes.

I'm also experiencing this in Firefox Developer Edition, though I've been unable to make Chrome crash as it works on Netflix just fine. When I go to Netflix.com as soon as the video starts to autoplay my whole system grinds to a halt and I have to do a hard reset. My Event Viewer didn't have any helpful information as far as I can tell. But for me it's just a Firefox issue.

Jason, can you give us some details about your setup? What graphics card are you using? The driver version would also be useful.

Flags: needinfo?(jason9199)

(In reply to Gabriele Svelto [:gsvelto] from comment #29)

Jason, can you give us some details about your setup? What graphics card are you using? The driver version would also be useful.

Sure thing. Windows 10, Firefox Developer Edition latest update (70.0b8 64-bit), AMD Radeon R9 200 Series graphics card with driver version 26.20.13003.1007. Please let me know if you need any additional info.

Flags: needinfo?(jason9199)

I've got the same problem as Jason - the whole computer freezes shortly after a video/trailer starts to autoplay. There's no firefox crash report and no useful windows event log entry. When opening Netflix on Edge there's no problem.

Windows 10 64-bit 1809
Firefox 69.0.1
AMD Radeon HD 7850
driver: "AMD Radeon Adrenalin Edition 19.9.2" (the freeze happens with older driver versions as well)

I'm in ongoing discussions with Widevine to see how we can best diagnose what's going on here. Nothing to action yet, but I'll be sure to comment once they have suggestions.

In the meantime, could those encountering the issue test if disabling hardware acceleration in Firefox helps with the issue? To do so:

  • Navigate to Options menu
  • In the general tab, scroll down to the Performance heading
  • Uncheck "Use recommended performance settings"
  • Uncheck "Use hardware acceleration when available"
  • Restart Firefox.

(In reply to Bryce Seager van Dyk (:bryce) from comment #32)

I'm in ongoing discussions with Widevine to see how we can best diagnose what's going on here. Nothing to action yet, but I'll be sure to comment once they have suggestions.

In the meantime, could those encountering the issue test if disabling hardware acceleration in Firefox helps with the issue? To do so:

  • Navigate to Options menu
  • In the general tab, scroll down to the Performance heading
  • Uncheck "Use recommended performance settings"
  • Uncheck "Use hardware acceleration when available"

I was able to reproduce a crash just after disabling hardware acceleration.

(In reply to Selim Şumlu from comment #33)

(In reply to Bryce Seager van Dyk (:bryce) from comment #32)

I'm in ongoing discussions with Widevine to see how we can best diagnose what's going on here. Nothing to action yet, but I'll be sure to comment once they have suggestions.

In the meantime, could those encountering the issue test if disabling hardware acceleration in Firefox helps with the issue? To do so:

  • Navigate to Options menu
  • In the general tab, scroll down to the Performance heading
  • Uncheck "Use recommended performance settings"
  • Uncheck "Use hardware acceleration when available"

I was able to reproduce a crash just after disabling hardware acceleration.

Thanks for checking that. I missed adding a restart Firefox step in my original instructions (I'll got an amend them). If you didn't already, could you try again with a restart following the toggling?

(In reply to Bryce Seager van Dyk (:bryce) from comment #34)

(In reply to Selim Şumlu from comment #33)

(In reply to Bryce Seager van Dyk (:bryce) from comment #32)

I'm in ongoing discussions with Widevine to see how we can best diagnose what's going on here. Nothing to action yet, but I'll be sure to comment once they have suggestions.

In the meantime, could those encountering the issue test if disabling hardware acceleration in Firefox helps with the issue? To do so:

  • Navigate to Options menu
  • In the general tab, scroll down to the Performance heading
  • Uncheck "Use recommended performance settings"
  • Uncheck "Use hardware acceleration when available"

I was able to reproduce a crash just after disabling hardware acceleration.

Thanks for checking that. I missed adding a restart Firefox step in my original instructions (I'll got an amend them). If you didn't already, could you try again with a restart following the toggling?

I wasn't able to reproduce after a restart but since it happens semi-randomly on my PC, it might just be pure luck. I'll try again from time to time.

I have the exact same issue with the same graphics card series:
AMD Radeon HD 7950 with driver 19.9.2 (older drivers as well)
Windows 10 64 bit 1903
Firefox 69.0.1

(In reply to michel.de.jongh from comment #36)

I have the exact same issue with the same graphics card series:
AMD Radeon HD 7950 with driver 19.9.2 (older drivers as well)
Windows 10 64 bit 1903
Firefox 69.0.1

Disabling hardware accelerating as described solves the problem for now

I am having the same issue as well. Hardware accelerating is off.

AMD R7 200 with 19.9.2
Windows 10 64 bit 1903
Firefox 69.0.1

I also have exactly the same issue and it does not matter if hardware acceleration is on or off. Although my computer also freezes with Chrome.

My computer is otherwise 100% stable (video and gaming) and even Netflix used to previously work perfectly for a few years. I am not exactly sure when this behaviour changed but it has been happening for at least few months now. If I disable WidevineCDM from launcing in Firefox, Netflix does not crash until I enable it. With it enabled, it freezes my entire computer within seconds to a few minutes when viewing trailers. Sometimes when I manage to select something to watch before it freezes, I usually can finish watching the series/movie. After the freeze only a hard reboot helps. Also error logs contain no useful information.

I'm pretty sure this issue is a combination of AMD drivers for older R7 and R9 cards and WidewineCDM, but AMD drivers that previously did work does not seem to fix the issue for me so I'm leaning on a problem within WidevineCDM. It does not seem very widespread since I cannot find many threads on google about this particular problem.

AMD R9 280X with 19.9.2 (also crashes with several months of previous drivers)
Windows 10 Pro 64 bit 1903
Firefox 69.0.1 64-bit

Sounds like we need to escalate this with Widevine. Bryce do you know who needs to be contacted?

Flags: needinfo?(bvandyk)

Also I believe this should be moved to the "External Software Affecting Firefox" component, but I'm not this component triager.

So after reading all of the above I tried to replicate the issue on my computer. My original post is above so that you can see my pc specs.

I did lots of testing and I could replicate 100% of the time the crash on my Firefox. The PC would freeze and only hardresetting worked.
Funnylly I was on discord with some friends when doing that and the call was not interupted at all even 2-3 minutes after the whole screen was frozen.

The testing had me have task manager on half screen and firefox on the other.

After 10-30 seconds everything would freeze. That was with hardware acceleration ON. I repeated this 5-6 times to verify and it crashed everytime on Netflix main page.

Then I disabled hardware acceleration and it crashed again, but I forgot to restart firefox.

After the crash, with hardware acceleration on (checked if it was off), I could replicate the crash at all. I tried different things, like refreshing, opening and closing firefox etc. I am not sure if that fixed the problem, but it wasnt as replicable is before. As of now I could replicate it with hardware acceleration off.

For all the tests, using task manager, I didnt see any memory leaking, high cpu usage or disk usage that was abnormal.

Hope the above helps!

I've reached out to Widevine again to see if they have any further insight.

After the crash, with hardware acceleration on (checked if it was off), I could replicate the crash at all. I tried different things, like refreshing, opening and closing firefox etc. I am not sure if that fixed the problem, but it wasnt as replicable is before. As of now I could replicate it with hardware acceleration off.

Clarifying: after the crash was hardware acceleration off, and then the crash couldn't be replicated again until turned back on?

Flags: needinfo?(bvandyk)

Sorry, I accidentaly wrote it wrong.

Rewriting the above paragraph correctly:

After the crash, with hardware acceleration off (checked if it was off), I could not replicate the crash at all. I tried different things, like refreshing, opening and closing firefox etc. I am not sure if that fixed the problem, but it wasnt replicable. As of now I could not replicate it with hardware acceleration off.

For those experiencing the issue, could you please try the steps below? This will help isolate is if this issue is related to new Widevine versions or not. Based on the reports, it sounds like this is a Windows issue, please let me know if that is not the case and I'll add further platform specific instructions as needed.

We're going to replace the current version of the Widevine CDM used with an older one and see if that has any impact:

  1. Navigate to about:support, in the first block of information there should be a 'Profile Folder' row, navigate to that folder with the 'Open Folder' button.
  2. In the profile folder there should be a gmp-widevinecdm directory, inside that directory should be another directory called either 4.10.1440.18 or 4.10.1440.19, and inside that directory should be several files: a license, a manifest, and 3 widevine files. Copy these files somewhere safe, as we're going to overwrite them and will want to restore them later.
  3. Download an older copy of the CDM for your browser using one of the links below. There are 2 links, one for 32bit browsers, and one for 64bit, if you need to check which version you have, you can do so from the menu via Help -> About Firefox -> Checking the value on the version line.
  1. Extract the the zip file you just downloaded, overwriting the files in the 4.10.1440.18 or 4.10.1440.19 directory from step 2 with the contents of the zip.
  2. Restart Firefox and see if the problem persists (remember to re-enable hardware acceleration if you turned it off).
  3. After checking if the issue persists, the files you backed up in step 2 can be copied back into place to restore the current version of Widevine.

(In reply to Bryce Seager van Dyk (:bryce) from comment #45)

For those experiencing the issue, could you please try the steps below? This will help isolate is if this issue is related to new Widevine versions or not. Based on the reports, it sounds like this is a Windows issue, please let me know if that is not the case and I'll add further platform specific instructions as needed.

We're going to replace the current version of the Widevine CDM used with an older one and see if that has any impact:

  1. Navigate to about:support, in the first block of information there should be a 'Profile Folder' row, navigate to that folder with the 'Open Folder' button.
  2. In the profile folder there should be a gmp-widevinecdm directory, inside that directory should be another directory called either 4.10.1440.18 or 4.10.1440.19, and inside that directory should be several files: a license, a manifest, and 3 widevine files. Copy these files somewhere safe, as we're going to overwrite them and will want to restore them later.
  3. Download an older copy of the CDM for your browser using one of the links below. There are 2 links, one for 32bit browsers, and one for 64bit, if you need to check which version you have, you can do so from the menu via Help -> About Firefox -> Checking the value on the version line.
  1. Extract the the zip file you just downloaded, overwriting the files in the 4.10.1440.18 or 4.10.1440.19 directory from step 2 with the contents of the zip.
  2. Restart Firefox and see if the problem persists (remember to re-enable hardware acceleration if you turned it off).
  3. After checking if the issue persists, the files you backed up in step 2 can be copied back into place to restore the current version of Widevine.

I tested the old widevine version you linked for about 10 minutes, no crashes so far. Usually it would have crashed a lot sooner but I'm still not 100% sure about this version being completely crash free. It's looking very good though! I will test for the next few days and report back when I'm sure.

Thanks for your efforts so far and I really hope this helps in fixing it in the future.

No more Netflix freezes but it broke Hulu and VRV.

(In reply to Shenlyu from comment #47)

No more Netflix freezes but it broke Hulu and VRV.

To clarify, Netflix works, but those sites do not? Do they refuse to play video with a message, or are broken in some other way?

(In reply to Bryce Seager van Dyk (:bryce) from comment #48)

(In reply to Shenlyu from comment #47)

No more Netflix freezes but it broke Hulu and VRV.

To clarify, Netflix works, but those sites do not? Do they refuse to play video with a message, or are broken in some other way?

That is correct. VRV just infinitely loads and Hulu says "Please update your browser" Hulu Error Code P-EDU129 It then has a unique Error it and the local time. This is with the old version of wildvine that doesn't freeze on Netflix.

(In reply to gagorian from comment #46)

I tested the old widevine version you linked for about 10 minutes, no crashes so far. Usually it would have crashed a lot sooner but I'm still not 100% sure about this version being completely crash free. It's looking very good though! I will test for the next few days and report back when I'm sure.

Thanks for your efforts so far and I really hope this helps in fixing it in the future.

I can confirm now, no Netflix crashes with the old widevine version.

I also had same symptoms and tested old widevine version and have had no crashes for 3 days but it has also broken amazon prime video with it complaining I am missing a drm component.

I can reproduce the issue almost instantly and consistently with a cold boot of my media PC. Interestingly the computer itself is not frozen but the GPU locks up entirely meaning I can't do anything except wait for it to come around and watch the HDD LED blink. If I remove the HDMI cable and reinsert it I get a lime green screen.

While writing this I was able to CTRL + ALT + DEL and Windows 10 errored in that it could not render the sign in options. I got about about 5 seconds of control to Firefox before it relocked the GPU after closing it.

I'll probably disable hardware acceleration as a workaround (since I do so on my nVIDIA cards anyway).

I can tell you that, there is something wrong related to Mozilla Firefox and AMD Radeon or maybe something else, but what is for sure, every time I try to access the Netflix, after login, the whole system freezes.
The only way out is to restart the system, I can't use may mouse or keyboard, nothing, and that's not good at all.
With Chrome I have no problem.

System configuration:
Windows 10, 64 bit
RAM 10 GB
AMD Radeon R7 370 Series
AMD processor FX 4320

We've reached out to AMD regarding this, but have yet to hear back. The current working theory is that there may be an issue in their driver responsible for performing HDCP checking. Since recent Widevine versions may be performing HDCP checks differently on Windows we may be running into driver bugs. For those encountering the issue, it's would be useful to know which version of the AMD graphics driver you're on.

If you're feeling daring you could also try and disable HDCP for your display in your radeon settings. It would be useful to know if this prevents that crash.

(In reply to Bryce Seager van Dyk (:bryce) from comment #54)

We've reached out to AMD regarding this, but have yet to hear back. The current working theory is that there may be an issue in their driver responsible for performing HDCP checking. Since recent Widevine versions may be performing HDCP checks differently on Windows we may be running into driver bugs. For those encountering the issue, it's would be useful to know which version of the AMD graphics driver you're on.

If you're feeling daring you could also try and disable HDCP for your display in your radeon settings. It would be useful to know if this prevents that crash.(In reply to badileanu from comment #53)
I can tell you that, there is something wrong related to Mozilla Firefox and AMD Radeon or maybe something else, but what is for sure, every time I try to access the Netflix, after login, the whole system freezes.
The only way out is to restart the system, I can't use may mouse or keyboard, nothing, and that's not good at all.
With Chrome I have no problem.

System configuration:
Windows 10, 64 bit
RAM 10 GB
AMD Radeon R7 370 Series
AMD processor FX 4320

The driver I use now for graphic is:
win10-64bit-radeon-software-adrenalin-2019-edition-19.9.2-sep23
win10-64bit-radeon-software-adrenalin-2019-edition-19.9.2-sep23

I recently began having a similar issue. Updating my Radeon driver to 19.12.2 seems to have fixed the issue for me.

I am running Windows 10 with an AMD Radeon HD 7800.

Sorry to post again, but I was also having the same issue with Hulu, which is now fixed as well.

I have run several tests with different browsers, again my computer freezes. And yes, I tried the latest video driver, win10-radeon-software-adrenalin-2020-edition-19.12.2-dec12 and the same problem.

I read other posts from different forums, different configurations, different OS, but always the only constant is Netflix. I even tried to talk with them,
only elusive responses, use the latest drivers, use Chrome.

My conclusion is Netflix, bad management resources or something else, just is clear, don't care policy, it's the rule for them, of course as long you pay the fee.

Since last week I'm also getting the exact same issues as described above.
I also have an AMD graphics card and driver: HD 7970, running Radeon 19.20

GIGABYTE Radeon 7870, Radeon 19.12.3 affected too.

I can confirm this bug with newest Versions of Firefox 72.0.2 and AMD Driver Version 19.x.x. This also happens with Amazon prime video.

I updated AMD-Driver to 20.1.3 -- bug still there.

OK - Same problem with Chrome. So probably a driver problem -- as you said.

I no longer seem to have the issue with AMD 20.2.1 version drivers, I had stopped watching Netflix due to this problem for several months so I'm unsure at what point this was fixed for me.

Chrome is still crashing with 20.2.1 drivers, but - I also haven't had any freezes with Firefox (ver. 73.0.1) so far!

Nope, Firefox still crashes too with 20.2.1.

The only workaround I found it's to disable onboard audio, I also use an external audio card and I think this is the problem, multiple audio sources and like I said, I don't think it's an AMD driver problem because if it was so, I would have problems elsewhere too.

Also I specify that my motherboard uses for north bridge: AMD 970, south bridge: AMD SB950 and audio Realtek® ALC887 codec

(In reply to badileanu from comment #67)

The only workaround I found it's to disable onboard audio, I also use an external audio card and I think this is the problem, multiple audio sources and like I said, I don't think it's an AMD driver problem because if it was so, I would have problems elsewhere too.

Also I specify that my motherboard uses for north bridge: AMD 970, south bridge: AMD SB950 and audio Realtek® ALC887 codec

Note:
I did more tests, unfortunately I just thought...

Same issue for me on a fresh setup with :

  • Windows 10 Pro ver. 1909 ;
  • Firefox x64 ver. 75.0 ;
  • AMD Radeon Sapphire HD 7870 ;
  • Radeon drivers v20.2.2 ;
  • A lot of frustration.

AFAIK, it only happens with Netflix.

Alright, let's try and get some useful info out of those crashes. From the last few comments I assume that in most of the cases Firefox crashes but the crash report doesn't show up. In that case our only way to getting more info is gathering a crash dump using Windows Error Reporting.

To all the reporters who are experiencing this problem, could you do the following for me:

  • Launch regedit.exe
  • Add a new empty registry key with this path:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps
    
    This changes Windows Error Reporting to collect user-mode dumps locally, you can read more information about this here: Collecting User-Mode Dumps
  • Run Firefox as usual trying to reproduce the crash
  • When Firefox crashes on Netflix go and check if a minidump file (.dmp extension) was generated in the following directory:
    C:\Users\<your_name>\AppData\Local\CrashDumps
    

One important note: if you do get a minidump do not attach it to this bug. Since a minidump contains data directly pulled from Firefox when it crashed it might contain important or private information so you don't want it to be public. Send the minidump to me via e-mail and I'll have a look at it.

i still have this problem, gpu AMD r9 280x (gigabyte GV-R928XOC-3GD (rev. 2.0)), cpu i5 3570k
amd radeon driver 20.4.1, win10 1909 x64
firefox ver. 75.0
04/2020

I too have been experiencing this problem for years. Netflix crashes very frequently, freezing up my entire PC requiring a hard reset. I recently updated the AMD drivers for my 7870 (to version 20.2.2 from 19.?) and now it always crashes, and it crashes when loading the Netflix page now. I have tried every suggestion in this thread and the only thing that works is disabling hardware acceleration. Using the older version of Widevine made Netflix give a "not up to date" error. I use Win 7 SP1 64 bit with all its updates and Firefox 64bit 76.01, but Firefox is always updating itself.

Firefox 80.0.1 (64bit)
AMD Radeon Pro Software-Version: 20.Q3
Graphics card: AMD FirePro W4100

Netflix.com -> Login -> Hover over anything, which starts a playback immediately, crashes first Firefox then the whole system.

Turning off Hardware Acceleration as described here (https://bugzilla.mozilla.org/show_bug.cgi?id=1563801#c32) works.

I have not tried this (https://bugzilla.mozilla.org/show_bug.cgi?id=1563801#c70) yet, I will though. But the Event logs does not show anything, either.

(In reply to func0der from comment #73)

Firefox 80.0.1 (64bit)
AMD Radeon Pro Software-Version: 20.Q3
Graphics card: AMD FirePro W4100

Netflix.com -> Login -> Hover over anything, which starts a playback immediately, crashes first Firefox then the whole system.

Turning off Hardware Acceleration as described here (https://bugzilla.mozilla.org/show_bug.cgi?id=1563801#c32) works.

I have not tried this (https://bugzilla.mozilla.org/show_bug.cgi?id=1563801#c70) yet, I will though. But the Event logs does not show anything, either.

Oh and by the way: It is working in Chrome no problem.

(In reply to func0der from comment #73)

Firefox 80.0.1 (64bit)
AMD Radeon Pro Software-Version: 20.Q3
Graphics card: AMD FirePro W4100

Netflix.com -> Login -> Hover over anything, which starts a playback immediately, crashes first Firefox then the whole system.

Turning off Hardware Acceleration as described here (https://bugzilla.mozilla.org/show_bug.cgi?id=1563801#c32) works.

I have not tried this (https://bugzilla.mozilla.org/show_bug.cgi?id=1563801#c70) yet, I will though. But the Event logs does not show anything, either.

Oh and by the way: It is working in Chrome no problem.
(In reply to func0der from comment #74)

(In reply to func0der from comment #73)

Firefox 80.0.1 (64bit)
AMD Radeon Pro Software-Version: 20.Q3
Graphics card: AMD FirePro W4100

Netflix.com -> Login -> Hover over anything, which starts a playback immediately, crashes first Firefox then the whole system.

Turning off Hardware Acceleration as described here (https://bugzilla.mozilla.org/show_bug.cgi?id=1563801#c32) works.

I have not tried this (https://bugzilla.mozilla.org/show_bug.cgi?id=1563801#c70) yet, I will though. But the Event logs does not show anything, either.

Oh and by the way: It is working in Chrome no problem.

Wivedine in Chrome: 4.10.1679.0
Wivedine in Firefox: 4.10.1582.2

Sorry, i am really bad in not having an 'edit' function xD

Thanks for that information, func0der. Could you set Hardware Acceleration on in the options menu and navigate to about:config and set the media.hardware-video-decoding.enabled pref there to false and see if that also stops the crashes happening? This helps us track what specifically in the hardware acceleration settings is causing the issue.


For Gecko devs (people experiencing the issue can skip this unless you're interested in technical details), it's possible there is more than one problem here.

  • Hardware decoding of non-encrypted media is causing crashes related to AMD drivers. This is consistent with disabling hardware acceleration fixing the issue.
  • Widevine interacting with drivers to check HDCP support is causing crashes related to AMD drivers. This is consistent with different Widevine versions causing crashes, as different versions implement the checks differently.

Widevine does not perform hardware bases decoding, and its interactions with hardware to do the HDCP check are not influenced by prefs. So if latter of the two scenarios above is happening I don't see how disabling hardware acceleration would have an impact on it unless there is some sort of cross talk issue where Fx is interacting with the driver and Widevine also does and that results in a crash.

Flags: needinfo?(accounts+mozilla)

Hello Bryce,

I can confirm that with my preferences regarding encoding reverted back to default and only media.hardware-video-decoding.enabled set to false the Netflix page does playback everything properly and without crashes.
As soon as it is set to true everything crashes again.

Flags: needinfo?(accounts+mozilla)

Thanks for confirming that. I think this makes it highly likely that the two issue scenarios mentioned in comment 76 are both happening.

For anyone encountering the issue, if you could navigate to about:support and copy the information there onto this bug, it would be helpful to help diagnose further the cards and drivers that are hitting the issue (I appreciate that there's already some of this info on the bug). It would also be helpful if you have any crashes in about:crashes that relate to this to submit and link them on the bug.

It sounds like there's some video the Neftlix is serving that is triggering crashes in AMD drivers. Since we don't control the AMD drivers we can't fix them, but we can try mitigate them falling over.

Attached file about:support content
```

My about:support content was attached above.
about:crashes is always empty, because the whole PC crashes.

(In reply to func0der from comment #80)

My about:support content was attached above.
about:crashes is always empty, because the whole PC crashes.

Thanks!


For devs, see also bug 1644074 where we BSODs due to AMD drivers failing decodes.

See Also: → 1644074

I wasn't having crashes (although, I did not start a video), but as soon as I opened Netflix, today, the whole system would freeze for a few seconds repeating every few seconds after (mouse and everything becomes unresponsive/frozen). The Task Manager pointed me toward the plugin-container for widevine cdm being the issue (every few seconds everything would freeze and then when things unfroze, you could see the widevine plugin CPU usage tapering-off after hard slamming the the system).

I did not update any drivers recently (no driver changes this year, actually), and the widevine cdm plugin is the one from February (4.10.1582.2). In fact, no system/software changes in the past month except for the automatic Thunderbird and Mozilla updates recently. So I do not know what would cause the behavior on Netflix to change suddenly (first time using it for about half a week). Win7 Pro-64b, AMD Radeon RX480.

Changing hardware acceleration in Options did nothing to fix it, but changing media.hardware-video-decoding.enabled to false did work to stop the freezing.

(In reply to busi.bugzilla from comment #82)

I wasn't having crashes (although, I did not start a video), but as soon as I opened Netflix, today, the whole system would freeze for a few seconds repeating every few seconds after (mouse and everything becomes unresponsive/frozen). The Task Manager pointed me toward the plugin-container for widevine cdm being the issue (every few seconds everything would freeze and then when things unfroze, you could see the widevine plugin CPU usage tapering-off after hard slamming the the system).

I did not update any drivers recently (no driver changes this year, actually), and the widevine cdm plugin is the one from February (4.10.1582.2). In fact, no system/software changes in the past month except for the automatic Thunderbird and Mozilla updates recently. So I do not know what would cause the behavior on Netflix to change suddenly (first time using it for about half a week). Win7 Pro-64b, AMD Radeon RX480.

Changing hardware acceleration in Options did nothing to fix it, but changing media.hardware-video-decoding.enabled to false did work to stop the freezing.

Could you please create another bug to track this in the Audio/Video: Playback component? It sounds like it may be related in that AMD hardware decoding, but since it's not crashing it would be useful if we track the debugging it in its own bug.

My friend is also experiencing this problem on Firefox 84, with a Radeon HD 7850 on Radeon 20.12.1 by scrolling around on Netflix with a near 100% reproduction rate (presumably the preview tiles for the shows). Changing media.hardware-video-decoding.enabled to false works for him as well.

You need to log in before you can comment on or make changes to this bug.