Closed Bug 1563809 Opened 7 months ago Closed 7 months ago

artifact builds on Windows are busted

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ehsan, Assigned: chmanchester)

References

(Blocks 1 open bug)

Details

(Keywords: in-triage)

$ cat .mozconfig
ac_add_options --enable-artifact-builds
ac_add_options --disable-debug

$ ./mach build
 1:30.63 Clobber not needed.                                                                                                               
 1:30.63 Adding make options from c:\Users\Ehsan\gecko\.mozconfig                                                                          
    MOZ_OBJDIR=c:/Users/Ehsan/gecko/obj-x86_64-pc-mingw32                                                                                  
    OBJDIR=c:/Users/Ehsan/gecko/obj-x86_64-pc-mingw32                                                                                      
    FOUND_MOZCONFIG=c:/Users/Ehsan/gecko/.mozconfig                                                                                        
    export FOUND_MOZCONFIG                                                                                                                 
 1:30.76 c:\mozilla-build\bin\mozmake.EXE -f client.mk -s                                                                                  
 1:40.95 Error running mach:                                                                                                               
 1:40.95     ['--log-no-times', 'artifact', 'install']                                                                                     
 1:40.95 The error occurred in code that was called by the mach command. This is either                                                    
 1:40.95 a bug in the called code itself or in the way that mach is calling it.                                                            
 1:40.95 You can invoke |./mach busted| to check if this issue is already on file. If it                                                   
 1:40.95 isn't, please use |./mach busted file| to report it. If |./mach busted| is                                                        
 1:40.95 misbehaving, you can also inspect the dependencies of bug 1543241.                                                                
 1:40.95 If filing a bug, please include the full output of mach, including this error                                                     
 1:40.95 message.                                                                                                                          
 1:40.95 The details of the failure are as follows:                                                                                        
 1:40.96 IndexError: list index out of range                                                                                               
 1:40.96   File "c:/Users/Ehsan/gecko\python/mozbuild/mozbuild/mach_commands.py", line 1398, in artifact_install                           
 1:40.96     return artifacts.install_from(source, distdir or self.distdir)                                                                
 1:40.96   File "c:/Users/Ehsan/gecko\python/mozbuild\mozbuild\artifacts.py", line 1246, in install_from                                   
 1:40.96     return self.install_from_recent(distdir)                                                                                      
 1:40.96   File "c:/Users/Ehsan/gecko\python/mozbuild\mozbuild\artifacts.py", line 1163, in install_from_recent                            
 1:40.96     return self._install_from_hg_pushheads(hg_pushheads, distdir)                                                                 
 1:40.96   File "c:/Users/Ehsan/gecko\python/mozbuild\mozbuild\artifacts.py", line 1142, in _install_from_hg_pushheads                     
 1:40.96     for trees, hg_hash in hg_pushheads:                                                                                           
 1:40.96   File "c:/Users/Ehsan/gecko\python/mozbuild\mozbuild\artifacts.py", line 1017, in _find_pushheads                                
 1:40.96     candidate_pushheads = self._pushheads_from_rev(last_revs[0].rstrip(),                                                         
 1:40.98 mozmake.EXE[3]: *** [Makefile:160: recurse_artifact] Error 1                                                                      
 1:40.98 mozmake.EXE[2]: *** [c:/Users/Ehsan/gecko/config/recurse.mk:34: artifact] Error 2                                                 
 1:40.99 mozmake.EXE[1]: *** [c:/Users/Ehsan/gecko/config/rules.mk:400: default] Error 2                                                   
 1:40.99 mozmake.EXE: *** [client.mk:125: build] Error 2                                                                                   
 1:41.02 188 compiler warnings present.                                                                                                    
                                                                                                                                           

It is worth mentioning this is a git-cinnabar repo:

$ git log
commit cc463d9632bf82314ff3db112bcbb5c18cb1b337 (HEAD -> central, origin/central, origin/HEAD)
Author: Jonathan Kingston <jkt@mozilla.com>
Date:   Wed Jun 5 12:07:33 2019 +0000

    Bug 1556747 - Remove UUIDGenerator dependency of NullPrincipalURI.cpp r=ckerschb

    Differential Revision: https://phabricator.services.mozilla.com/D33641

commit 6440941b095e4ed17c2551e08b0bfcbd08340df2
Author: Jeff Gilbert <jgilbert@mozilla.com>
Date:   Fri Jun 21 16:52:50 2019 +0000

    Bug 1319426 - Don't keep ANGLE shader compilers around. r=lsalzman

    This will also make it easier if we want to reuse compilers/validators.

    Differential Revision: https://phabricator.services.mozilla.com/D35398

commit 04e34fc75fb73e919de6e0ce2f4e1509c9e0f28a
Author: Jeff Gilbert <jgilbert@mozilla.com>
Date:   Fri Jun 21 16:53:09 2019 +0000

    Bug 1560157 - Remove EGLUtils.h. r=lsalzman

    EGLImageWrapper was completely unused.

    Differential Revision: https://phabricator.services.mozilla.com/D35349

commit 2859d4e1f5cb6c3ebd288fb39c47f854132fbed4
Author: Nika Layzell <nika@thelayzells.com>
Date:   Fri Jun 21 16:34:30 2019 +0000

    Bug 1559460 - Support subframe process switches into embedder process, r=mccr8

    This change comes in two parts. First, the code in WindowGlobalChild was changed
    to detect the in-process case, and instruct the nsFrameLoader to become a
    non-remote nsFrameLoader, and second the logic in WindowGlobalParent was updated
    to ensure that the OwnerProcessID is updated after the change.

    Differential Revision: https://phabricator.services.mozilla.com/D35060

commit c00be0dd255ea87ae898022027a86f12cbd9f7e8
Author: Nika Layzell <nika@thelayzells.com>
Date:   Fri Jun 21 16:24:55 2019 +0000

    Bug 1560399 - Propagate remote type selection into subframes with Fission, r=farre

    Differential Revision: https://phabricator.services.mozilla.com/D35451

commit c42f2842c28bcf31e3318fec7e4e1838eadd6789
Author: Maja Frydrychowicz <mjzffr@gmail.com>
Date:   Fri Jun 21 16:26:53 2019 +0000
Keywords: in-triage

I'll try to reproduce this tomorrow.

Assignee: nobody → cmanchester

Things seemed to work when I updated my tree today...

Hmm, yeah, I just tried with a cinnabar checkout at that revision and couldn't reproduce.

Please re-open or re-file if you see this again.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.